El post que buscas se encuentra eliminado, pero este también te puede interesar

Algoritmos resueltos con Pseint parte 1

Anuncios

Hola, les dejo algunos algoritmos resueltos con pseint, espero les sea de utilidad. Funcionan.

1)
Proceso sin_titulo
//Una compañía de autos premia anualmente a sus mejores vendedores de acuerdo a la siguiente tabla:
//Si vendió Le corresponde de Comisión
//1.000.000 <= ventas < 3,000,000 3%
// 3.000.000 <= ventas < 5,000,000 4%
// 5.000.000 <= ventas < 7,000,000 5%
// 7.000.000 <= ventas 6%
//Diseñar un pseudocódigo que lea las ventas de 100 vendedores y que escriba la comisión anual que le corresponda a cada vendedor.
Dimension vendedor[10];
Dimension comision_ven[10];
i<-1;
ventas<-0;

mientras i<=3 Hacer
Escribir "Ingrese nombre vendedor: ";
leer nombre;
vendedor<-nombre;
Escribir "Ingrese importe total venta";
leer venta;
si venta >= 1000000 y venta <3000000 Entonces
comision<-venta*0.03;
Sino
si venta >= 3000000 y venta <5000000 Entonces
comision<-venta*0.04;
Sino
si venta >=5000000 y venta <7000000 Entonces
comision<-venta*0.05;
Sino
si venta >= 7000000 Entonces
comision<-venta*0.06;
Sino
si venta<1000000 Entonces
escribir " El vendedor no tiene comisiones ";
FinSi

FinSi
FinSi
FinSi
FinSi
i<-i+1;
comision_ven<-comision;

FinMientras
i<-1;

comision_ven<-comision;

Escribir " ";
Escribir " COMISIONES VENDEDORES ";
Escribir "-----------------------------------------------------";
Mientras i<=3 Hacer
Escribir "Nombre vendedor: ", vendedor, " Comision: ", comision_ven;
Escribir "-----------------------------------------------------";
i<-i+1;
FinMientras
Escribir "-----------------------------------------------------";

FinProceso

2) Proceso Ejercicio_7
// En una escuela funcionan 5 materias, ajedrez, canto, literatura, matematica y fotografia
//el de ajedrez funciona un dis y el otro no, el de canto una vez cada 3 dias, el de literatura
// cada 4, el de matematica cada 5 y fotografia cada 6
//todos las materias comienzan el 01/01 y a partir de alli cada uno se reuno cuando le corresponde
//El algoritmo, al ingresar un numero N(1<N<395) que represente un periodo de tiempo medido en dias
//determine el total de dias que se reuniran todos los circulos en dicho periodo, el total de dias
// en que se reunen ajedrez y literatura los mismos dias y el total de dias que tendra actividad
//cada circulo
// VARIABLES: ajedrez, canto, literatura, matemacia, fotografia: arreglos // i,ta,tc,tm,tf,tl,total, total12:enteros

dimension ajedrez[365];
dimension canto [365];
dimension literatura[365];
dimension matematica [365];
dimension fotografia[365];
i<-1; // inicializo en uno antes de cada ciclo mientras
mientras i<=365 hacer //esto inicializa toda la tabla en cero
ajedrez<-0;
canto<-0;
literatura<-0;
matematica<-0;
fotografia<-0;
i<-i+1;
finmientras
i<-1;
mientras i<=365 hacer // cada dos días
ajedrez<-1;
i<-i+2;
finmientras
i<-1;
mientras i<=365 hacer // cada tres días
canto<-1;
i<-i+3;
finmientras
i<-1;
mientras i<=365 hacer // cada cuatro días
literatura<-1;
i<-i+4;
finmientras
i<-1;
mientras i<=365 hacer // cada cinco días
matematica<-1;
i<-i+5;
finmientras
i<-1;
mientras i<=365 hacer // cada seis días
fotografia<-1;
i<-i+6;
finmientras
i<-1;
ta<-0;
tc<-0;
tm<-0;
tf<-0;
tl<-0;
mientras i<=365 hacer // necesito saber cuantas veces se juntan todas las materias
ta<-ta+ajedrez;
tc<-tc+canto;
tm<-tm+matematica;
tf<-tc+fotografia;
tl<-tl+literatura;
total<-ta+tc+tm+tf+tl;
i<-i+1;
si total=5 Entonces
escribir i;
finsi
FinMientras
escribir ta," ",tc," ",tm," ",tf," ",tl;
total2<-0;
i<-1;
ta<-0;
tc<-0;
mientras i<=365 hacer // necesito saber cuantas veces se juntan ajedrez y canto
ta<-ta+ajedrez;
tc<-tc+canto;
total2<-ta+tc;
i<-i+1;
si total2=2 Entonces
escribir i;
finsi
FinMientras
FinProceso

3)
Proceso sin_titulo
//Una compañía de autos premia anualmente a sus mejores vendedores de acuerdo a la siguiente tabla:
//Si vendió Le corresponde de Comisión
//1.000.000 <= ventas < 3,000,000 3%
// 3.000.000 <= ventas < 5,000,000 4%
// 5.000.000 <= ventas < 7,000,000 5%
// 7.000.000 <= ventas 6%
//Diseñar un pseudocódigo que lea las ventas de 100 vendedores y que escriba la comisión anual que le corresponda a cada vendedor.
Dimension vendedor[10];
Dimension comision_ven[10];
i<-1;
ventas<-0;

mientras i<=3 Hacer
Escribir "Ingrese nombre vendedor: ";
leer nombre;
vendedor<-nombre;
Escribir "Ingrese importe total venta";
leer venta;
si venta >= 1000000 y venta <3000000 Entonces
comision<-venta*0.03;
Sino
si venta >= 3000000 y venta <5000000 Entonces
comision<-venta*0.04;
Sino
si venta >=5000000 y venta <7000000 Entonces
comision<-venta*0.05;
Sino
si venta >= 7000000 Entonces
comision<-venta*0.06;
Sino
si venta<1000000 Entonces
escribir " El vendedor no tiene comisiones ";
FinSi

FinSi
FinSi
FinSi
FinSi
i<-i+1;
comision_ven<-comision;

FinMientras
i<-1;

comision_ven<-comision;

Escribir " ";
Escribir " COMISIONES VENDEDORES ";
Escribir "-----------------------------------------------------";
Mientras i<=3 Hacer
Escribir "Nombre vendedor: ", vendedor, " Comision: ", comision_ven;
Escribir "-----------------------------------------------------";
i<-i+1;
FinMientras
Escribir "-----------------------------------------------------";

FinProceso

4)
Proceso sin_titulo
//Introducir tres vectores de tipo string y mostrarlos en orden descendente.
Dimension A[10], B[10], C[10];
I<-1;
Escribir "ingrese N ";
leer N;
Mientras i<=N hacer
Escribir 'Ingrese primer cadena :';
Leer A;
Escribir 'Ingrese segunda cadena :';
Leer B;
Escribir 'Ingrese tercera cadena :';
Leer C;
i<-i+1;
FinMientras

i<-1;

Si A < B Entonces
Si B < C Entonces
Si B<C Entonces
ESCRIBIR " ", A," ", B," ", C;
Sino
ESCRIBIR " ", A," ", C," ", B;
FinSi
Sino
ESCRIBIR " ", C," ", A," ", B;
FinSi
Sino
Si B<C Entonces
Si A<C Entonces
ESCRIBIR " ", B," ", A," ", C;
Sino
ESCRIBIR " ", B," ", C," ", A;
FinSi
Sino
ESCRIBIR " ", C," ", B," ", A;
FinSi
FinSi
FinProceso

5)
//Dada la secuencia de números 10 - 22- 78 - 55 - 90 - 5 - 13,
//realizar la prueba de escritorio correspondiente a los algoritmos
//de selección, inserción directa y burbuja para ordenar la secuencia
//correspondiente
//VARIABLES V[]: Arreglo, i, j,min, aux, total_elem:entero
Dimension v[7];
i<-1;
para i<-1 hasta 7 hacer
Escribir "ingrese n";
leer n;
v<-n;
finpara
j<-1;
i<-1;
total_elem<-7;
mientras i<=total_elem hacer
j<-i;
min<-j;
j<-j+1;
mientras j<=total_elem Hacer
si v[j] < v Entonces
min<-j;
aux<-v[min];
v[min]<-v;
v<-aux;
FinSi
j<-j+1;
//Escribir v;
//Escribir v[j];
FinMientras
i<-i+1;
FinMientras
i<-1;
mientras i<=total_elem Hacer
escribir v;
i<-i+1;
FinMientras


FinProceso





Si dejan algunos puntos subo muchos más!!

Anuncios

18 comentarios - Algoritmos resueltos con Pseint parte 1

yacoby01
no me funciona el del vendedor
lucayirante +1
pero
como no les sirven ¿?? donde los prueban?¿¿?
roquero_
tan buenas me pero tienen alguos errores el qinto v&lt;-n; te falta ubicar bien
_DarKaiN_
hola en de vendedor no funka pero,l se agradece tuve un examen sobre esto y me fue como el orto!, si me ayudas vendran mas puntines XD! +10
lalas_ +1
te dejo 10 y ya casi sos FULL USER, un abrazo
valada +1
te dejo 10 asi sos NFU , buen post&quot;!!!
48mati48
te faltan los sub indices en el primero, estas guardando en todo el arreglo y tenes que guardar solo en una celda.
lanustaringuera
al momento de asignar los valores en los arrays tenés que agregar el indice en donde la estructura de repetición esta en ese momento,