El post que buscas se encuentra eliminado, pero este también te puede interesar

algoritmo

Anuncios

Proceso Fiesta
acu<-0;
Escribir "Sus amigos en la agenda son:";
Escribir "1. Pedro";
Escribir "2. Juan";
Escribir "3. Maria";
Escribir "4. Diana";
Escribir "5. Marcos";
Escribir " ";
Repetir
Escribir " ";
Escribir "Desea llamar a sus amigos";
Escribir " ";
Escribir "presione 1 para llamar a Pedro";
Escribir "presiona 2 para llamar a Juan";
Escribir "presiona 3 para llamar a Maria";
Escribir "Presiona 4 para llamar a Diana";
Escribir "presiona 5 para llamar a Marcos";
Escribir "presiona 0 para finalizar";
Leer num;
Si num < 0 Entonces
Escribir " ";
Escribir "numero no valido";
Sino
Si num = 0 Entonces
Escribir " ";
Escribir "Gracias por utilizar el servicio";
Escribir " ";
Sino
Si num > 5 Entonces
Escribir " ";
Escribir "El numero no esta Registrado en la agenda";
Escribir " ";
Sino
Si num = 1 Entonces
Escribir " ";
Escribir "llamando a Pedro... Espere...";
Opcion <-0;
Escribir "Presiona 1 para contestar, 2 para no contestar, otro numero corta la llamada.";
Leer Opcion;
Escribir " ";
Si Opcion = 1 Entonces
Repetir
Escribir "Asistiras a la fiesta del sabado si o no";
Leer res;
Hasta Que res = "si" o res = "no"
Si res = "si" Entonces
Escribir " ";
Repetir
Escribir "Asistiras solo o acompanado";
Leer soa;
Hasta Que soa = "solo" o soa = "acompanado"
Si Soa = "acompanado" Entonces
Repetir
Escribir " ";
Escribir "Escoje tu plato";
Escribir " ";
Escribir "presiona 7000 para carne";
Escribir "presiona 6000 para pollo";
Escribir "presiona 10000 para pescado";
Escribir "presiona 8000 para Vegetariano";
Leer cos1;
Hasta Que cos1 = 7000 o cos1 = 6000 o cos1 = 10000 o cos1 = 8000
tp<-cos1;
Escribir " ";
Repetir
Escribir "Cuantos invitados vas a llevar";
Leer inv;
Hasta Que inv >= 1
Para i<- 1 Hasta inv Hacer
Repetir
Escribir " ";
Escribir "Que plato deseas comer el invitado";
Escribir " ";
Escribir "presiona 7000 para carne";
Escribir "presiona 6000 para pollo";
Escribir "presiona 10000 para pescado";
Escribir "presiona 8000 para Vegetariano";
Leer cppv;
Hasta que cppv = 7000 o cppv = 6000 o cppv = 10000 o cppv = 8000
acu<-acu+cppv+tp;
FinPara
tot<-inv*2000;
gtot<-tot+2500;
tg<-gtot+acu;
Escribir " ";
Escribir "El costo de los platos es:", " ", acu;
Escribir "El costo de la entrada pedro mas sus invitados es:", " ", gtot;
Escribir "El dinero gastado entre todos es de:", " ", tg;
Sino
Si Soa = "solo" Entonces
Escribir lista_de_expresiones;Repetir
Escribir " ";
Escribir "Escoge tu plato";
Escribir " ";
Escribir "presiona 7000 para carne";
Escribir "presiona 6000 para pollo";
Escribir "presiona 10000 para pescado";
Escribir "presiona 8000 para Vegetariano";
Leer cosp2;
Hasta Que cosp2 = 7000 o cosp2 = 6000 o cosp2 = 10000 o cosp2 = 8000
totped<-2500+cosp2;
Escribir " ";
Escribir "Tu costo dinero gastado es de:", " ", totped;
FinSi
Finsi
Sino
Si res = "no" Entonces
Escribir "ok hablamos";
Escribir " ";
FinSi
Finsi
Sino
Si Opcion = 2 Entonces
Escribir "Pedro esta ocupado deje su msj";
Escribir "Intente mas tarde";
Escribir " ";
FinSi
Finsi
Sino
FinSi
FinSi
Si num = 2 Entonces
Escribir " ";
Escribir "llamando a Juan... Espere...";
Opcion <-0;
Escribir "Presiona 1 para contestar, 2 para no contestar, otro numero corta la llamada.";
Leer Opcion;
Escribir " ";
Si Opcion = 1 Entonces
Repetir
Escribir "Asistiras a la fiesta del sabado si o no";
Leer res;
Hasta Que res = "si" o res = "no"
Si res = "si" Entonces
Escribir " ";
Escribir "Asistiras solo o acompanado";
Leer soa;
Si Soa = "acompanado" Entonces
Escribir " ";
Escribir "Escoje tu plato";
Escribir " ";
Escribir "presiona 7000 para carne";
Escribir "presiona 6000 para pollo";
Escribir "presiona 10000 para pescado";
Escribir "presiona 8000 para Vegetariano";
Leer cos1;
tp<-cos1;
Escribir " ";
Escribir "Cuantos invitados vas a llevar";
Leer inv;
Para i<- 1 Hasta inv Hacer
Escribir " ";
Escribir "Que plato deseas comer el invitado";
Escribir " ";
Escribir "presiona 7000 para carne";
Escribir "presiona 6000 para pollo";
Escribir "presiona 10000 para pescado";
Escribir "presiona 8000 para Vegetariano";
Leer cppv;
acu<-acu+cppv+tp;
FinPara
tot<-inv*2000;
gtot<-tot+2500;
tg<-gtot+acu;
Escribir " ";
Escribir "El costo de los platos es:", " ", acu;
Escribir "El costo de la entrada juan mas sus invitados es:", " ", gtot;
Escribir "El dinero gastado entre todos es de:", " ", tg;
Sino
Si Soa = "solo" Entonces
Escribir " ";
Escribir "Escoge tu plato";
Escribir " ";
Escribir "presiona 7000 para carne";
Escribir "presiona 6000 para pollo";
Escribir "presiona 10000 para pescado";
Escribir "presiona 8000 para Vegetariano";
Leer cosp2;
totped<-2500+cosp2;
Escribir " ";
Escribir "Tu costo dinero gastado es de:", " ", totped;
FinSi
Finsi
Sino
Si res = "no" Entonces
Escribir "ok hablamos";
Escribir " ";
FinSi
Finsi
Sino
Si Opcion = 2 Entonces
Escribir "Juan esta ocupado deje su msj";
Escribir "Intente mas tarde";
Escribir " ";
FinSi
Finsi
FinSi
Si num = 3 Entonces
Escribir " ";
Escribir "llamando a Maria... Espere...";
Opcion <-0;
Escribir "Presiona 1 para contestar, 2 para no contestar, otro numero corta la llamada.";
Leer Opcion;
Escribir " ";
Si Opcion = 1 Entonces
Escribir "Asistiras a la fiesta del sabado si o no";
Leer res;
Si res = "si" Entonces
Escribir " ";
Escribir "Asistiras sola o acompanada";
Leer soa;
Si Soa = "acompanada" Entonces
Escribir " ";
Escribir "Escoje tu plato";
Escribir " ";
Escribir "presiona 7000 para carne";
Escribir "presiona 6000 para pollo";
Escribir "presiona 10000 para pescado";
Escribir "presiona 8000 para Vegetariano";
Leer cos1;
tp<-cos1;
Escribir " ";
Escribir "Cuantos invitados vas a llevar";
Leer inv;
Para i<- 1 Hasta inv Hacer
Escribir " ";
Escribir "Que plato deseas comer el invitado";
Escribir " ";
Escribir "presiona 7000 para carne";
Escribir "presiona 6000 para pollo";
Escribir "presiona 10000 para pescado";
Escribir "presiona 8000 para Vegetariano";
Leer cppv;
acu<-acu+cppv+tp;
FinPara
tot<-inv*2000;
gtot<-tot+2500;
tg<-gtot+acu;
Escribir " ";
Escribir "El costo de los platos es:", " ", acu;
Escribir "El costo de la entrada Maria mas sus invitados es:", " ", gtot;
Escribir "El dinero gastado entre todos es de:", " ", tg;
Sino
Si Soa = "sola" Entonces
Escribir " ";
Escribir "Escoge tu plato";
Escribir " ";
Escribir "presiona 7000 para carne";
Escribir "presiona 6000 para pollo";
Escribir "presiona 10000 para pescado";
Escribir "presiona 8000 para Vegetariano";
Leer cosp2;
totped<-2500+cosp2;
Escribir " ";
Escribir "Tu costo dinero gastado es de:", " ", totped;
FinSi
Finsi
Sino
Si res = "no" Entonces
Escribir "ok hablamos";
Escribir " ";
FinSi
Finsi
Sino
Si Opcion = 2 Entonces
Escribir "Maria esta ocupada deje su msj";
Escribir "Intente mas tarde";
Escribir " ";
FinSi
Finsi
FinSi
Si num = 4 Entonces
Escribir " ";
Escribir "llamando a Diana... Espere...";
Opcion <-0;
Escribir "Presiona 1 para contestar, 2 para no contestar, otro numero corta la llamada.";
Leer Opcion;
Escribir " ";
Si Opcion = 1 Entonces
Escribir "Asistiras a la fiesta del sabado si o no";
Leer res;
Si res = "si" Entonces
Escribir " ";
Escribir "Asistiras sola o acompanada";
Leer soa;
Si Soa = "acompanada" Entonces
Escribir " ";
Escribir "Escoje tu plato";
Escribir " ";
Escribir "presiona 7000 para carne";
Escribir "presiona 6000 para pollo";
Escribir "presiona 10000 para pescado";
Escribir "presiona 8000 para Vegetariano";
Leer cos1;
tp<-cos1;
Escribir " ";
Escribir "Cuantos invitados vas a llevar";
Leer inv;
Para i<- 1 Hasta inv Hacer
Escribir " ";
Escribir "Que plato deseas comer el invitado";
Escribir " ";
Escribir "presiona 7000 para carne";
Escribir "presiona 6000 para pollo";
Escribir "presiona 10000 para pescado";
Escribir "presiona 8000 para Vegetariano";
Leer cppv;
acu<-acu+cppv+tp;
FinPara
tot<-inv*2000;
gtot<-tot+2500;
tg<-gtot+acu;
Escribir " ";
Escribir "El costo de los platos es:", " ", acu;
Escribir "El costo de la entrada Diana mas sus invitados es:", " ", gtot;
Escribir "El dinero gastado entre todos es de:", " ", tg;
Sino
Si Soa = "sola" Entonces
Escribir " ";
Escribir "Escoge tu plato";
Escribir " ";
Escribir "presiona 7000 para carne";
Escribir "presiona 6000 para pollo";
Escribir "presiona 10000 para pescado";
Escribir "presiona 8000 para Vegetariano";
Leer cosp2;
totped<-2500+cosp2;
Escribir " ";
Escribir "Tu costo dinero gastado es de:", " ", totped;
FinSi
Finsi
Sino
Si res = "no" Entonces
Escribir "ok hablamos";
Escribir " ";
FinSi
Finsi
Sino
Si Opcion = 2 Entonces
Escribir "Diana esta ocupada deje su msj";
Escribir "Intente mas tarde";
Escribir " ";
FinSi
Finsi
FinSi
Si num = 5 Entonces
Escribir " ";
Escribir "llamando a Marcos... Espere...";
Opcion <-0;
Escribir "Presiona 1 para contestar, 2 para no contestar, otro numero corta la llamada.";
Leer Opcion;
Escribir " ";
Si Opcion = 1 Entonces
Escribir "Asistiras a la fiesta del sabado si o no";
Leer res;
Si res = "si" Entonces
Escribir " ";
Escribir "Asistiras solo o acompanado";
Leer soa;
Si Soa = "acompanado" Entonces
Escribir " ";
Escribir "Escoje tu plato";
Escribir " ";
Escribir "presiona 7000 para carne";
Escribir "presiona 6000 para pollo";
Escribir "presiona 10000 para pescado";
Escribir "presiona 8000 para Vegetariano";
Leer cos1;
tp<-cos1;
Escribir " ";
Escribir "Cuantos invitados vas a llevar";
Leer inv;
Para i<- 1 Hasta inv Hacer
Escribir " ";
Escribir "Que plato deseas comer el invitado";
Escribir " ";
Escribir "presiona 7000 para carne";
Escribir "presiona 6000 para pollo";
Escribir "presiona 10000 para pescado";
Escribir "presiona 8000 para Vegetariano";
Leer cppv;
acu<-acu+cppv+tp;
FinPara
tot<-inv*2000;
gtot<-tot+2500;
tg<-gtot+acu;
Escribir " ";
Escribir "El costo de los platos es:", " ", acu;
Escribir "El costo de la entrada Maria mas sus invitados es:", " ", gtot;
Escribir "El dinero gastado entre todos es de:", " ", tg;
Sino
Si Soa = "solo" Entonces
Escribir " ";
Escribir "Escoge tu plato";
Escribir " ";
Escribir "presiona 7000 para carne";
Escribir "presiona 6000 para pollo";
Escribir "presiona 10000 para pescado";
Escribir "presiona 8000 para Vegetariano";
Leer cosp2;
totped<-2500+cosp2;
Escribir " ";
Escribir "Tu costo dinero gastado es de:", " ", totped;
FinSi
Finsi
Sino
Si res = "no" Entonces
Escribir "ok hablamos";
Escribir " ";
FinSi
Finsi
Sino
Si Opcion = 2 Entonces
Escribir "Marcos esta ocupado deje su msj";
Escribir "Intente mas tarde";
Escribir " ";
FinSi
Finsi
FinSi
FinSi
FinSi
Hasta Que num = 0
FinProceso


aqui le dejo mas algoritmo:

http://algoritmoresuelto.blogspot.com/

2 comentarios - algoritmo

@elvir2k8
Loco te falta poner mas detalles darle vida al post!! mejora eso +10 para que te animes.
@waaalteeer +1
algoritmo

www.chatcondesconocidos.com.ar