Juego del Nim, Algoritmo para Pseint (Pseudocodigo)

Anuncios

Hola les traigo este Juego escrito en pseudocodigo.. Este algoritmo lo pueden probar en Pseint..

Se los dejo para aquellos que estudian informatica o sistema..

El problema que se plantea es como hacer para que la computadora gane siempre. Asi que bueno lo resolvi y aca se los dejo para que vean como funciona.




Proceso Juego_del_Nim
Escribir "Ingrese cantidad de fosforos:";
leer num;
si num<=4 Entonces
Repetir
Escribir "Debes ingresar una cantidad mayor a 4.";
Escribir "Vuelve a ingresar:";
Leer num;
Hasta Que num>4
FinSi

Escribir "Comienza usted?(si/no)";
Leer resp;
si (resp='si') o (resp='SI') Entonces
turno<-Verdadero;
Sino
turno<-Falso;
FinSi
mientras num<>1 Hacer
si turno=Falso Entonces
turno<-Verdadero;

si num mod 4=0 Entonces
num<-num-3;
Escribir "La computadora saca 3 fosforos.";
Escribir "";
Escribir "Quedan ",num," fosforos."
Sino
si (num mod 4=1) o (num mod 4=2) Entonces
num<-num-1;
Escribir "La computadora saca 1 fosforo";
Escribir "";
Escribir "Quedan ",num," fosforos";
Sino
si (num mod 4=3) Entonces
num<-num-2;
Escribir "La computadora saca 2 fosforos.";
Escribir "";
Escribir "Quedan ",num," fosforos.";

FinSi




FinSi
FinSi

Sino
si turno=Verdadero Entonces
turno<-Falso;
Escribir "Cuantos fosforos saca?";
Leer s;
si (s<=0) o (s>3) Entonces
Repetir
Escribir "Error, vuelve a ingresar: (Mayor que cero y menor o igual a 3)";
Leer s;
Hasta Que s>0 y s<=3;
FinSi

num<-num-s;
Escribir "Quedan ",num," fosforos.";


FinSi
FinSi



FinMientras
si turno=Verdadero Entonces
Escribir "Usted pierde.";
Sino
Escribir "Usted gana.";
FinSi



FinProceso



Deben copiar todo y pegarlo en el pseint para luego ejecutarlo.
Por si no tienen el Pseint y les interesa saber que es se lo pueden Descargar de aca. Solo elijan su version de windows o Linux.


Pseint


Mis Otros Post:


Todo los Programas que necesitas!

Xilisoft Converter Varias versiones

Libros de Stephen Hawking

Ozzy Osbourne, Un Grande

Cracks Y Keygens Para Todo!

Fisica Universitaria Tomo 1 y 2




Juego del Nim, Algoritmo para Pseint (Pseudocodigo)



Espero que les sirva

11 comentarios - Juego del Nim, Algoritmo para Pseint (Pseudocodigo)

@kenchu
la verdad te felicito, por interesarte en la programacion e informatica, y compartirnoslo para todos! te dejaria puntitos pero no soy full..
@Mako_Chan
gracias por el algoritmo pero tengo q traducilo a c++ ni modo aunq me costo entenderlo ya vere si funciona te daria puntos pero lastimosamente soy novato
@Lxcho92
wena men ta bien hecho el programa, , no tengo puntos pero bien , si tienes otros programas o saber de donde sacar te lo agradeceria
@pablo252
esta bueno el juego! te debe haber costado...
@chelini93
mmmmm
la computadora no gana siempre!!! yo le gane!!! ;D
@postmar
Muy bueno el programa!! pero... es mentira que siempre la computadora gana.. porq yo le gane!!

Ingrese cantidad de fosforos:
Yo ingrese 5 (es el minimo de fosforos que se puede ingresar)
Comienza usted? (si/no)
Yo puse que no
La computadora saca 1 fosforo
Quedan 4 fosforos

Cuantos fosforos saca?
Yo puse 3 (es lo maximo que se puede sacar por ronda)

Queda 1 fosforo
Usted gana!!