Solucion Visual Studio 2010 y Crystal Report

Hola a todos. Estos dias estuve haciendo un sistema en el cual necesitaba pasar a un reporte lo que tenia en un grid, busque en internet como hacerlo porque era algo que nunca habia hecho, entonces empece a probar. Por suerte encontre un video en youtube en donde lo explicaban muy bien, pero como siempre pasa (por lo menos a mi), hago todo lo que dice el video y cuando lo quiero probar no andaba :S
Me daba un error que decia "No se puede cargar el archivo o ensamblado 'file:///C:/Program Files/SAP BusinessObjects/Crystal Reports for .NET Framework 4.0/Common/SAP BusinessObjects Enterprise XI 4.0/win32_x86/dotnet1/crdb_adoplus.dll' ni una de sus dependencias. El sistema no puede encontrar el archivo especificado."
Estuve renegando un buen rato hasta que por fin pude encontrar la solución.
Solamente habia que agregar esa sentencia al archivo App.config.

<startup useLegacyV2RuntimeActivationPolicy="true">

Por suerte con esto logre solucionar el problema.
Es un post muy pobre pero seguro que de mucha utilidad para varios.

3 comentarios - Solucion Visual Studio 2010 y Crystal Report

@Sabrewulfx +5
Hermano, me salvo la vida.......
Nunca pense que en taringa encontraria la solucion a este tipo de cosas......
Muchas gracias..!!
+10
@eltoby7
De 10 capo. Se solucionó con eso.
Te dejo +10. Buen aporte!
@Angiemar116
Muchas gracias, ...no es pobre es conciso y eso me encanta no me gusta que le den tantas vueltas para dar una solución... de nuevo muchas gracias