Modo a prueba de fallos se cuelga en ISAPNP.SYS

Anuncios

MODO A PRUEBA DE FALLOS SE CUELGA DESPUES DE CARGAR ISAPNP.SYS


Esta semana tuve dos maquinas con el mismo problema. Asi que tuve que ponerme a investigar.

La PC se tilda con pantalla negra al arrancar windows.

En modo a prueba de fallos, una pista: El arranque se cuelga despues de cargar el driver ISAPNP.SYS

Diagnostico:

ISAPNP.SYS es el ultimo driver del grupo "reservados del sistema". Luego XP carga el grupo "BOOT BUS EXTENDER" (no quiero meter la pata con la traducción, asi que lo dejo tal cual lo encontre en MicroSoft).

Algunos virus inyectan su codigo dentro de drivers de este grupo, y si algo sale mal o el antivirus elimino el codigo, XP se colgara al cargarlo.

Solucion:

¡OJO! Hay que tocar sonar delicadas, asi que ante cualquier duda consulte a su medico o tecnico amigo.


Arrancar la pc con algun Live CD. A mi me gusta el MINI PE pero cualquiera deberia servir.
Tambien sirve colocar el disco en otra PC como disco secundario.

Ingresar a Windowssystem32drivers y buscar algun archivo extraño. En mis dos casos encontre archivos de nombres raros (Tipo XFZWXD.SYS) con tamaño 0 kb. Eliminarlo. (si no tiene tamaño 0, por las dudas mejor solo moverlo a otra ubicacion)

Editado 21/05/2010:
Y como muy bien me acotaron Carlomagno y Hosopolar generalmente estos archivos tienen fecha reciente.



Normalmente con esto ya deberia arrancar.

Usando RegEdit busca el nombre del archivo eliminado y elimina la entrada.
(Recomiendo primero hacer un backup en un archivo .reg!!!!)

Es muy posible que el virus haya dejado algo mas para asegurarse la ejecución en el arranque, asi que busca tambien en HKEY_LOCAL_MACHINESOFTWAREMicrosoftWindowsCurrentVersionRun

¡¡SUERTE!!

25 comentarios - Modo a prueba de fallos se cuelga en ISAPNP.SYS

@Hansom
Buen dato. Gracias por compartir.
@maxisoad
te dejo 10 man, no encontraba esto por ningun lado che graciasssssss
@ferchulandia
Capooo!!!, me salvaste la vida Tenia el mismo problema en la compu de un amigo y era eso! De orto se me dio por probar en modo seguro y como se clavó en ISAPNP.SYS lo googlé y me llevó hasta aca! Te dejo mis 10!
@MrDownload
Funcionó...... Gracias y +10!!
@edwood
Te doy 10 por la info y a ver si se ponen media pila y le dan los 10 que faltan, no puede seguir novato!
@juanctkc
te amo! jajaja ....mi solución fué liberar espacio de disco (de la pc de un cliente que tenia 1mb libre el c donde esta instalado el SO) y renombrar un archivo de tamaño 0KB dentro de la carpeta que indicó..
saludos.
@edwood
Listo netcrash, mañana cambiás de rango, gracias por el dato
@aloncho
Te comento que termine de optimizar la maquina de un cliente... y cuando hago el reinicio final para emitirle tiket y costo, la maquina no me arranca.... not{e que el isapnp.sys se clavaba en modo a prueba de fallos y lo googleé..

GRACIAS POR LA SOLUCIOOONN!!!!

de paso agrego que el nod 32 no detecto el supuesto virus... +10
@DALNIN
DALNIN dijo: YO TAMBIÉN TUVE ESE PROBLEMA EN LA PC Y SE ARREGLO SOLA AUNQUE AUN ME FALTA EL ARCHIVO (ISAPNP.SYS) POR QUE REVISE NO ME A SALIDO EL MENSAJE QUE ME FALTA EL ARCHIVO CREO QUE ESE ARCHIVO NO ES MUY IMPORTANTE SI ES QUE LA PC PUEDE FUNCIONAR SIN ÉL Y TENGO EL WIN XP PRO SP3


GRACIAS POR LA INFO

GRACIAS POR LA INFO
@kunaguero100
Genio! Me encanta encontrar la solucion exacta a los problemas. Obviamente +10
@mxpwr
Fueron 10, muchas gracias..
@Arturbeily
Info muy util, sin lugar a dudas... +10
@ericforeman
gracias loco era eso nomas.... te dejo 10.
@deloeste
Capooooo.. +10 para usted. Salu2 DELOESTE
@checo_25
a mi me pasa con una memoria ram dañada
@gacabral
...creer o reventar. Moví 3 archivos con tamaño 0 y arrancó!
@gacabral
+7