Instalar decentemente sublime text 2 en ubuntu

Hace mucho que venía buscando unHace mucho que venía buscando una forma de instalar Sublime Text y que Ubuntu me lo reconozca como programa hasta que encontré la solución:

Agregamos el siguiente PPA:

sudo add-apt-repository ppa:webupd8team/sublime-text-2

actualizamos:

sudo apt-get update

Instalamos:

sudo apt-get install sublime-text

Y con ello tendremos Sublime Text instalado en: /usr/lib/sublime-text-2a forma de instalar

Algunas capturas de pantalla de Sublime Text 2 corriendo como programa instalado en Ubuntu 11.10:

Instalar decentemente sublime text 2 en ubuntu

Ubuntu

GNU

39 comentarios - Instalar decentemente sublime text 2 en ubuntu

@Debian_GNU +2
Jajaja, "decentemente".
@learod87
muy bueno... este editor es lo mas :-)
@shago57
Gracias
Acabas de ayudar a un novato en Ubuntu GRACIAS
@NuryFV
Amigo excelente tutorial, queria preguntarte si la version de ese repositorio se va actualizando al tiempo que la de la pagina oficial, ahi te deje unos puntos. Gracias
@nikkolazo
no hay forma de obtener la licencia?
@crowys83 +1
Gracias me sirvió !
@JBRIZ +1
Ya lo había instalado de forma decente antes de ver este tuto en ubuntu 12.04.
lo curioso es que me quedo con el viejo logo, tuve que usar la app menu principal para editarlo.

excelente post, fácil de entender para los novatos y muy útil q lo tengan instalado de esa manera.
@CARNOTAURO
Gracias por el aporte.. muy buen editor
@slim83
Buenas noches

no me instala me envia el siguiente error
"Reading package lists... Done
Building dependency tree
Reading state information... Done
El paquete sublime-text-2 no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente
Sin embargo, los siguientes paquetes lo reemplazan:
sublime-text-dev sublime-text

E: El paquete «sublime-text-2» no tiene un candidato para la instalación"

Me podrían ayudar
@winkase +1
slim83 dijo:Buenas noches

no me instala me envia el siguiente error
"Reading package lists... Done
Building dependency tree
Reading state information... Done
El paquete sublime-text-2 no está disponible, pero algún otro paquete hace referencia
a él. Esto puede significar que el paquete falta, está obsoleto o sólo se
encuentra disponible desde alguna otra fuente
Sin embargo, los siguientes paquetes lo reemplazan:
sublime-text-dev sublime-text

E: El paquete «sublime-text-2» no tiene un candidato para la instalación"

Me podrían ayudar


Ahí mismo dice..."algún otro paquete hace referencia a él." usa:

sudo apt-get install sublime-text

Claro después de agregar el repositorio y actualizar. Y ya! Lee lo que dice.

Muy buen post!! Y muy buen programa!!
@NuryFV
nikkolazo dijo:no hay forma de obtener la licencia?


sakata_san dijo:el serial


Se puede obtener pagando pero el programa sin licencia presenta todas las funcionalidades, yo lo he usado asi siempre y no ha faltado nada.
@ro_4865
Me sirvió, Gracias!
@DuendeSlayer93 +1
Podrías actualizar el post ya que ahora se instala:
sudo apt-get install sublime-text
Así evitamos confusiones para los que apenas empiezan con Linux.
Gracias!
@alonsin
muchas gracias, justo iba a escribir que no me servia y asi lo pude instalar
DuendeSlayer93 dijo:Podrías actualizar el post ya que ahora se instala:
sudo apt-get install sublime-text
Así evitamos confusiones para los que apenas empiezan con Linux.
Gracias!

@Fenrihr
No basta con eso:
1- Agregamos el siguiente PPA
2- actualizar repositorios
3- ejecutar: sudo apt-get install sublime-text

Gracias, van puntos.
@jacksballes
es cierto deberías de actualizar el post pues si la instalacion correcta ahora es:

sudo apt-get install sublime-text
@daniartavia
muy bueno... gracias pero es sudo apt-get install sublime-text
@ELmeerALeexiss
Gracias amigo se me había olvidado la repo xD +5
@matesasesinos
un groso viejo... nada mas que no me dejo instalar el 2 en xubuntu solo el sublime-text (sin el 2)... una masa ahi te van +10
@banekinesiologo
hoy me quede sin puntos Man !! maniana van 10 + !! anduvo de una Maestro !!! gracias !!
@mdqseba
muchas gracias! se instaló más que "decentemente"
@danielarario
Hola.
Sirve para 13.04?
@danielarario
Hola.
Soy nuevo en Gnu/Linux.
Tengo ubuntu 13.04, esto serviria para mi?
Gracias!
@3rps +1
Sí. Yo también tengo 13.04 y me funciona perfecto.
@LimberCS
ayuda!!! por que tengo este problema???
Traceback (most recent call last):
File "/usr/bin/add-apt-repository", line 125, in <module>
ppa_info = get_ppa_info_from_lp(user, ppa_name)
File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 84, in get_ppa_info_from_lp
curl.perform()
pycurl.error: (6, "Couldn't resolve host 'launchpad.net'"
NO ME DEJA INSTALAR EL PROGRAMA...
@O5C4R93
muy bueno el tuto, lo ocupaba, gracias +10 +reco
@guichogdl +2
ahi les dejo una licencia valida

----- BEGIN LICENSE -----
Alexander
Single User License
EA7E-814345
51F47F09 4EAB1285 7827EFF0 8B1207DC
A76A6EA3 E1A1CA7A DC1F2703 14897784
8EDC1C82 3F2A58B9 1C0C8B24 67686432
281245B3 6233DE5C ADC5C2F9 61FB8A04
171B63EF 86BA423F 6AC884FD 3273A7AA
5F50A6DB CE7859AE D62D2B37 AEEDD8C2
078A8A20 70EEA791 84F48C1E 8ABA7DEB
0B3907C0 C9A3523B 0091A045 6F67AED8
------ END LICENSE ------
@sylary2j
Gracias
@Tiranic
Gracias amigo te dejo +10

Saludos
@xMegamanx
gracias un excelente programa multiplataforma, muchas gracias por la info, nos facilita el trabajo de búsqueda.
@Facuu78
gracias loco! un Monton de veces intente y no pude, y ahora con un par de comandos al toke se instalo!

+5
@sylary2j
Groso, funciona de maravilla