El post que buscas se encuentra eliminado, pero este también te puede interesar

Solución a Instalacion de ATI Radeon HD4350 Debian Squeeze

Anuncios

Buenas tengan todos, después de mucho tiempo intentando instalar correctamente los drivers de mi tarjeta ATI Radeon HD 4350, al fin pude instalarla y aqui les voy a mostrar como hacerlo de manera correcta para los que tengan problemas similares como los que a continuación voy a mostrar.

Hay muchos que tienen problemas al instalar los drivers propietarios siguiendo el manual de la wiki:

http://wiki.debian.org/ATIProprietary

Aun así seguiremos la instalación que viene en el manual de la wiki:

cuando llegamos al punto 4 del manual de la wiki

4. Unload the radeon and drm modules:

# modprobe -r radeon drm

al ejecutar ese comando nos aparece el siguiente error:

FATAL: module radeon is in use

a pesar de que ya paramos el entorno gráfico el modulo radeon sigue en uso entonces lo que vamos a hacer es lo siguiente:

vamos a ejecutar

dmesg | grep drm

y despues vamos a purgar los siguientes módulos:

apt-get purge xserver-xorg-video-radeon libdrm-radeon1 radeontool

reiniciamos la maquina: reboot

veremos que nos carga el entorno gráfico pero se ve raro por la resolución que tiene que esta mal pero no importa, Abrimos una terminal y seguimos en la parte donde se quedaron, paran la interfaz gráfica y ejecutan:

# modprove -r radeon drm

veran que ahora el comando se ejecuta sin problemas y continúan con lo que sigue en la wiki excepto que ahora les saltará un problema al tratar de iniciar el modo gŕafico:

# invoke-rc.d gdm3 start

No recuerdo el error que salta pero no hay nada que preocuparse damos un:

# reboot

a algunos les inicia bien en modo grafico pero a otros no como a mi (inicia en modo texto), el problema esta en que modificaron la pantalla del xorg.conf y pusieron "Default Screen" entonces se inicia en modo grafico y al tratar de dar el comando #startx dice que no puede iniciar en modo gráfico porque no reconoce las pantallas o algo similar, bueno lo que yo hice es volver a cargar los módulos que purgamos:

apt-get install xserver-xorg-video-radeon libdrm-radeon1 radeontool

una ves que instalamos nos vamos al archivo xorg.conf:

#nano /etc/X11/xorg.conf

en la sección que modificamos como dice en la wiki lo dejamos como estaba que en este caso es el identificador:

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
EndSection

Automáticamente cuando terminamos de dejarlo como estaba y salvar los cambios la maquina saltara a modo grafico con los drivers propietarios de ATI Radeon instalados y ahora si a instalar compiz.

Espero que les sirva a todos.

PD: encontre la solución en un foro de debian en la parte de la fuente les dejo el link.

A DISFRUTAR DE ACELERACIÓN EN DEBIAN.

DEBIAN ES LA LEY XD

Anuncios

5 comentarios - Solución a Instalacion de ATI Radeon HD4350 Debian Squeeze

@tostadofernandez -9
que ganas de complicarse la vida,sabiendo que en windows con 3 clicks esta todo instalado y sin dramas
@pablitotm +4
tostadofernandez dijo:que ganas de complicarse la vida,sabiendo que en windows con 3 clicks esta todo instalado y sin dramas

pobrecito no le da la cabecita para hacer mas de 3 clicks... Buen post!
@gamborimbo +3
tostadofernandez dijo:que ganas de complicarse la vida,sabiendo que en windows con 3 clicks esta todo instalado y sin dramas



trata de instalar win sin el disco de instalacion de tu mobo, me corto un huevo si te instala la red, los graficos, la wifi, etc etc...con linux, te instala todo ¡¡¡¡ aqui se trata de que mejore la calidad, por que los drivers de ati no son presisamente diseñados para linux.

la proxima ves antes de escribir piensa un poco antes de decir pendejadas ( o boludeces, segun sea el caso)