Instalando nuestro lector Dnie en Karmic

Anuncios

Esto es un copy and paste de: htttp://www.ubuntizandoelplaneta.com


Hace un par de días me ha llegado un lector para DNIe y smartcards. Las gracias debo dárselas una vez mas a Bloguzz y a la gente de Tractis. Debo decir que incluso, estos últimos, vía twitter nos informaron de como iba el envío del paquete. Lo de twitter es toda una novedad.



La presentación es impecable. El paquete contiene el lector de tarjetas, Cd con drivers para Windows, Mac y Linux, instrucciones y un tríptico publicitario. Todo está pensado para conectar y comenzar a usarlo.

Lo mejor de todo es que este pack puede ser tuyo por 2€. Todo surge la siguiente iniciativa, copio y pego:

Tractis y red.es han unido sus fuerzas para regalar más de 300.000 lectores de DNIe a los ciudadanos. Se trata del primer reparto masivo de lectores de DNIe de la historia de España. Comenzará el 1 de Octubre y terminará antes de finales de 2009 (Desde el 1 de Octubre hasta el 31 de Diciembre de 2009 o hasta que se acaben los lectores, lo que ocurra antes).

¿A qué esperas? Todavía queda un mes, en algunas comunidades se han quedado sin existencias. Basta con hacer click en el siguiente banner.




¿Que es el Dnie? Tradicionalmente los españoles estamos identificados ante la autoridad competente mediante un Dni, con este documento realizamos números tramites cada día pero no dejaba de ser un documento carente de vida. Desde hace unos años la administración a apostado por dotarle de más vida y acercar este al siglo en el que vivimos. La clave está en un chip y certificado digital, que permite autentificarnos a traves de internet ante las diferentes administraciones publicas. Esto es acercar el concepto de ventanilla virtual a los hogares de todos nosotros. Se acabaron las fotocopias para muchos tramites.




Para poder usarlo es necesario disponer de un lector de tarjetas compatible y seguir unos pasos:

1.- Instalar los paquetes necesarios de los repositorios de Ubuntu:
sudo aptitude install libccid libpcsclite1 pcscd libopensc2 pinentry-gtk2 opensc mozilla-opensc pcsc-tools

* Para usuarios de KDE instalamos pinentry-qt4 en lugar de pinentry-gtk2.

2.- Conectamos nuestro lector y probamos si se reconoce el lector ejecutando:
pcsc_scan

(al introducir la tarjeta en el lector se debe encender la luz verde y salir unos mensajes)

3. -Descargar las librerías especificas para Dnie para la última versión para Ubuntu:
http://www.dnielectronico.es/descargas/PKCS11_para_Sistemas_Unix/opensc_1.4.6_arq.html
(Para Karmic se descargará la versión de Jaunty)

Descomprimir e instalar los ficheros obtenidos:

Para 64bits
tar xvf Ubuntu_Jaunty_opensc-dnie_1.4.6-2_amd64.deb.tar
sudo dpkg -i libopensc2_0.11.7-7_amd64.deb opensc_0.11.7-7_amd64.deb opensc-dnie_1.4.6-2_amd64.deb


Para 32bits
tar xvf Ubuntu_Jaunty_opensc-dnie_1.4.6-2_i386.deb.tar
sudo dpkg -i libopensc2_0.11.7-7_i386.deb opensc_0.11.7-7_i386.deb opensc-dnie_1.4.6-2_i386.deb

4. - Instalamos la librería y certificados en Firefox:
Siguiendo las indicaciones tras la instalación accedemos al menú Aplicaciones/Oficina/Registrar módulo DNIe PKCS#11 y se acepta la instalación de los tres certificados cuando Firefox nos pregunte por ello.

Ahora en Firefox vamos a editar/preferencias/avanzado/dispositivos de seguridad y pulsamos la pestaña cargar nos abrirá una ventana y donde pone nombre modulo ponemos DNIe PKCS#11 luego pulsamos examinar y nos dirigimos a usr/lib/opensc-pkcs11.so pulsamos aceptar y listo.

5. - Ahora lo delicado es evitar que Karmic no actualice "opensc". Si queremos que funcione y hasta que la administración no lance librerías para Karmic, debemos tener cuidado con esto. Para ello:

sudo echo -e "opensc hold\nlibopensc2 hold" | sudo dpkg --set-selections

Con esto finalizamos. Podemos probar nuestro Dnie en el siguiente enlace:
http://www.dnielectronico.es/como_utilizar_el_dnie/verificar.html

Si nos pide clave y vuelca los datos de nuestro certificado es que esta guia ha cumplido su misión.

1 comentario - Instalando nuestro lector Dnie en Karmic

@pablojota
¿Será posible instalar los paquetes para arquitectura de 32 bits en el Dell Inspiron Mini 9 con el sencillo truquillohttp://jecomovi.homelinux.org/wordpress/?p=89&cpage=1 de modificar el indicador de arquitectura de 32 bits a lpia. Debería valer ¿no? ¿Alguna recomendación?