El post que buscas se encuentra eliminado, pero este también te puede interesar

Instalando los drivers privativos ATI en Debian/Ubuntu

Anuncios

Ok antes de comenzar quiero aclarar que ya hay varios post sobre como instalar el driver privativo o binario de ATI. Estaría bueno que también les peguen una ojeada, los links están al final.

Este tuto esta probado en debian squeeze y (k)ubuntu 10.4

La diferencia es que yo los instalo de 2 maneras un tanto distintas a los otros post, una de ellas una tanto más complicada. En fin arrancamos.

La forma seguramente mas sencilla sin lugar a dudas es instalar el driver que viene con la distribución que usamos, de esto hay un par de posts (nikolatesla1, jjm66, MukenioArg, entre otros)

Nada mas que para hacer el post mas completo la vamos a incluir pero vamos a hacerlo distinto, aunque no todo, como para que no sea tan repost! jajaja

FORMA 1

La forma mas sencilla de instalar los driver que vienen en ubuntu es ir al menu:

Sistema --> Administración --> Hardware Drivers
o
Sistema --> Hardware Drivers


FORMA 2

Desde consola:

Primero y principal nos vamos a pasar a la consola o terminal. Para esto presionamos:

Ctrl+Alt+F1

Nos pide login y password así que ponen su nombre de usuario y el password.

Ahora hay que cerrar el gestor de ventanas.
Para Gnome:

$ sudo /etc/init.d/gdm stop

Para Kde

$ sudo /etc/init.d/kdm stop

(Tb podria usarse sudo service kdm stop por ej)

Si ya tenemos un driver instalado

$ sudo aptitude purge fglrx-modaliases fglrx fglrx-amdccle fglrx-dev

ATENCIÓN: Si no querés que te informe mal la versión cuando instales el nuevo driver (una pavadita, amdccle informa mal la versión nada mas) tenes que:

$ sudo rm -R /usr/lib/fglrx/etc/ati/

si no seguimos.

CAMINO 1

Para instalar el que viene por defecto en debian/ubuntu pueden hacerlo con:

$ sudo aptitude install fglrx-modaliases fglrx fglrx-amdccle fglrx-dev

si faltase alguna dependencia aptitude se va a encargar solito.

Para que se configure (sobre todo si es la primera vez que lo instalamos)

$ sudo aticonfig --initial

Si todo salio bien reiniciamos la maquina:

$ sudo reboot


CAMINO 2

SI queremos instalar el ultimo driver a la fecha (10.9) Tenemos dos caminos. El mas fácil a mi parecer es este:

1)Bajar el script del creador de kanotix:

$ wget http://www.kanotix.com/files/install-fglrx-debian.sh

$ sudo sh install-fglrx-debian.sh

Este script se encarga de todo, nos informa si nos quedo alguna X abierta, descarga el driver, lo instala e incluso creo que se encarga de eliminar el driver anterior de haberlo, aunque eso no lo probé.

Si todo salio bien reiniciamos la maquina:

$ sudo reboot


CAMINO 3

2)Bajar el driver de la pagina de ati:

$ wget https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/ati-driver-installer-10-9-x86.x86_64.run

Puede ser que nos falten algunas dependencias así que:

$ sudo aptitude install prelink libqtgui4 libqtcore4 dkms build-essential module-assistant fakeroot debhelper bzip2 libstdc++5

Si es de 64 bits hacemos tb:

$ sudo aptitude install ia32-libs ia32-libs-gtk

Finalmente vamos a crear los paquetes con el instalador de ati para que cuando tengamos que desinstalarlo sea mas fácil.

$ sh ati-driver-installer-10-9-x86.x86_64.run --listpkg

Esto les va a tirar las distribuciones para las que hace los paquetes. Para hacerla corta:
Para Ubuntu lucid por ej:

$ sh ati-driver-installer-10-9-x86.x86_64.run --buildpkg Ubuntu/lucid

Para Debian testing

$ sh ati-driver-installer-10-9-x86.x86_64.run --buildpkg Debian/testing

Una vez creados los paquetes llego la hora de la instalación!!!

$ sudo dpkg -i fglrx*

Para que se configure (sobre todo si es la primera vez que lo instalamos)

$ sudo aticonfig --initial

Si todo salio bien reiniciamos la maquina:

$ sudo reboot


Fuente: Yo y mi tiempo.

Posts de instalación de drivers ati privativos:

MukenioArg
http://www.taringa.net/posts/linux/5442381/Driver-de-Ati-oficial-facil-en-Debian.html

nikolatesla1
http://www.taringa.net/posts/linux/5877568/3D-Con-ATi-En-Ubuntu-Lucid-Lynx-_Driver-Propietario_.html

jjm66
http://www.taringa.net/posts/linux/5683148/Como-instalar-el-driver-privativo-de-ATI-en-linux.html

SI me comí alguno avisen y disculpen no los revise a todos... No puse ninguna imagen porque se hacia muy largo!!

EDIT1:
Para debian este post no funciona bien debido a que el script de crear paquetes de ati es una porquería... de cualquier manera y para futura referencia aquí la solución:

sh ati-driver-installer-10-9-x86.x86_64.run --extract fglrx10.9

Eso descomprime el driver al directorio fglrx10.9

cd fglrx10.9

una vez dentro copiamos los directorios x740 y x740_64a a x710 y x710_64a

cp -a x740 x710
cp -a x740_64a x710_64a

ahora debido a algunos problemitas con fakeroot en el script tenes que ejecutar el creador de paquetes como root (o usando sudo)

sudo ./packages/Debian/ati-packager.sh --buildpkg stable

listo ya tenes los paquetes listos para instalar!!
Gracias ati por complicarnos la vida! jajajaja

EDIT2:
Decidí que iba a explicar un poco mas lo anterior... estoy medio al pedo... ese numero x740 marca la version de X11. Por lo que los pasos anteriores deberían de funcionar sin problemas para debian lenny (x11 7.3). Testing y sid tienen X11 7.5 por lo que lo recomendable es copiar los directorios x750 y x750_64a.

Una porquería el script que ni siquiera apunta a una carpeta que sirva, si no a una que ya no existe (x710) y que esta sin actualizar desde hace mucho (En fglrx 10.11 todavía esta el mismo script y todavía marca como estable a woody...) Es por eso que recomiendo usar el script de kano.

Si usan testing o sid la versión actual del driver es la 10.9 y en experimental esta la 10.11.

Fuente: YO

Anuncios

8 comentarios - Instalando los drivers privativos ATI en Debian/Ubuntu

Tosh78
Gracias, siempre instalaba el de la pagina de ATI pero no tenia idea de las dependencias.
8MoCoSo7

sh ati-driver-installer-10-9-x86.x86_64.run --buildpkg Debian/stable
Created directory fglrx-install.fcZNYZ
Verifying archive integrity... All good.
Uncompressing ATI Catalyst(TM) Proprietary Driver-8.771.............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
=====================================================================
 ATI Technologies Catalyst(TM) Proprietary Driver Installer/Packager 
=====================================================================
Generating package: Debian/stable
cp: cannot stat `/home/chucks/fglrx-install.fcZNYZ/x710/*': No such file or directory
Package build failed!



que puto que es nose porque carajo me tira eso... instale las dependencias y todo pero nada.
Probe crear le paquete para lenny, stable y unstable pero lo mismo. es como que no descomprime o algo asi verdad?...
neinGott
Muy buena info.
¡Gracias!