Que onda Taringueros(as), acá les dejo un Post de algunos de los algoritmos que hice el semestre pasado, espero y les sea de ayuda, todos fueron hechos por mi (yo no los invente, el ingeniero los dejaba de trabajo y creo que los sacaba de la web y libros, yo solo los resolví) todos están probados y funcionan, algunos son de lo mas simple y el método de solución es largo pudiéndolo hacer corto, pero nos exigían hacerlos así, ustedes pueden modificar los algoritmos a su gusto.

Por favor, si hay alguna duda sobre algo, o se dan cuenta de que tengo algún error, comenten y me lo dicen para corregirlo, siempre reviso bien antes de publicar, pero casi siempre se filtran algunos errores, ya saben, pueden cambiar las constantes y los nombres de las variables a su antojo



Acá les dejo el link para que descarguen el PSeInt por si no lo tienen (es gratuito)
http://pseint.sourceforge.net/index.php?page=descargas.php

LISTA DE ALGORITMOS


1. Este algoritmo nos pide dos números cualesquiera y nos muestra por pantalla si el cuadrado del primero es mayor que el cubo del segundo.



Algoritmos Resueltos En PSeInt


2.Este algoritmo nos pide ingresar diez números cualesquiera y nos muestra por pantalla la cantidad de números positivos, negativos y nulos que se hayan digitado, ademas también nos muestra la suma de positivos y negativos.


Programacion


3.Este algoritmo nos pide ingresar tres números y nos muestra por pantalla el orden ascendente de estos números.


algoritmos


4.Este algoritmo nos pide ingresar la cantidad de números que se quieran evaluar, luego nos pide digitar los números elegidos y nos muestra por pantalla la cantidad y el producto de los números pares e impares que se hayan introducido.


halo


Acá adjunto el código ya que la imagen no se ve bien :

1 Proceso Numeros_Pares_Impares
2cont<-c
3numpar<-0
4numimpar<-0
5prodpar<-1
6prodimpar<-1
7Escribir "digite la cantidad de numeros a evaluar"
8Leer c
9Mientras cont<c Hacer
10Escribir "introduzca un numero entero"
11Leer n
12Si n mod 2=0 Entonces
13numpar<-numpar+1
14prodpar<-prodpar*n
15Sino
16numimpar<-numimpar+1
17prodimpar<-prodimpar*n
18FinSi
19cont<-cont+1
20FinMientras
21Escribir "la cantidad de numeros pares es: ", numpar
22 Si numpar=0 Entonces
23Escribir "el producto de los numeros pares es: ", prodpar-1
24 Sino
25Escribir "el producto de los numeros pares es: ", prodpar
26 FinSi
27Escribir "la cantidad de numeros impares es: ", numimpar
28 Si numimpar=0 Entonces
29Escribir "el producto de los numeros impares es: ", prodimpar-1
30 Sino
31Escribir "el producto de los numeros impares es: ", prodimpar
32 FinSi
33 FinProceso


5.Este algoritmo nos pide ingresar un numero y nos muestra por pantalla si es primo o no.


suma


6.Este algoritmo nos muestra por pantalla los números pares menores que cien.


promedio


7.Este algoritmo nos muestra por pantalla los números múltiplos de cinco menores que mil.


pseint


8.Este algoritmo nos muestra los números menores que "n" números.


RESUELTOS


9.Este algoritmo nos pide ingresar "n" números cualesquiera y nos muestra por pantalla la cantidad de números positivos, negativos y nulos ingresados.


pseudocodigo


10. Este algoritmo nos pide ingresar el numero de trabajadores de una plantilla, la tarifa por hora, el numero de horas trabajadas y nos muestra por pantalla el salario para cada empleado y el de la nomina en total.


resta


11.Este algoritmo nos pide el numero de horas trabajadas y la tarifa por hora y no muestra el sueldo del trabajador, teniendo en cuenta que si el numero de horas trabajadas es mayor de cuarenta, entonces le descuentan el cinco porciento.


bien explicado


12.Este algoritmo nos permite hallar el volumen y el área de un cilindro.


Algoritmos Resueltos En PSeInt


13. Este algoritmo nos muestra todos los números impares del uno hasta el cien, y también la cantidad que hay.


Programacion


14. Con este algoritmo podemos multiplicar cinco números cualesquiera.


algoritmos


15.Este algoritmo nos muestra por pantalla los números del uno hasta el cien.


halo


16.Este algoritmo es el contrario del programa anterior, nos muestra por pantalla los números del cien al uno.


suma


17.Este algoritmo nos muestra los números pares positivos menores que cien, utiliza el ciclo Para.


promedio


18. Este algoritmo nos pide ingresar una cantidad cualquiera de trabajadores, luego un sueldo que no necesariamente tiene que ser el mismo para todos, si el sueldo es menor igual a mil, le descuentan el diez porciento; si el sueldo esta entre mil y dos mil, le descuentan el cinco porciento; y si es mayor que dos mil, le descuentan el tres porciento, luego nos muestra por pantalla un sueldo neto para cada intervalo de descuento (si los hay) y la nomina total de la empresa.


pseint


19. Este algoritmo seria parecido al anterior, solo que en este solo es para un trabajador.


RESUELTOS


20. Con este algoritmo podemos sumar diez números cualesquiera.


pseudocodigo


21.Este es parecido a uno descrito anteriormente, solo que utiliza el ciclo para, nos muestra por pantalla los números del uno al cien, nos dice la cantidad de pares e impares, y ademas la suma entre pares y luego la suma entre impares.


resta




DESCARGA PDF CON LOS ALGORITMOS en el siguiente link:

https://www.facebook.com/257051141136947/photos/a.262003187308409.1073741828.257051141136947/267022573473137/?type=1&theater

Si les gusto y les fue de ayuda, por favor, comenten para saber que valió la pena hacer este Post, puntúen (Y). hasta la próxima


Por si se quieren descargar el Halo Custom Edition para jugar Online, esta en español, no hay q instalarlo, para mas detalles vicitar:

http://www.taringa.net/posts/juegos-online/15514287/Descargar-Halo-Custom-Edition-Espanol.html

O en mi canal de YouTube:

http://www.youtube.com/watch?v=kkRy8d2FFgk