Bueno como sabrán el visual estudio 2010 tiene la posibilidad de incluir reportes de crystal reports y al generar un setup de la aplicación aparecen distintos problemas como que tienen que bajar un paquete de requisitos previos para nuestros proyectos y cosas así, bueno no entrare en detalles.

El problema es que cuando hago el instalador de mi proyecto en visual estudio 2010 me aparece que debo seleccionar como requerimiento previo .NET Framework 4.0, lo selecciono y al volver a generar el setup apararece la siguiente leyenda .NET Framework 4.0 requiere Framework 2.0, cuando voy a seleccionarlo a requerimientos previos solo me aparece Framework 2.0 SP2, y lo selecciono, al volver a generar el setup me sigue apareciendo la leyenda .NET Framework 4.0 requiere Framework 2.0

Alguien sabe como se arregla esto, ya lo intente en 3 pcs diferentes por que en un principio me comentaron que podía estar mal mi instalación de visual estudio, pero no ha podido solucionarse el problema