Como unir 2 redes LAN con Mikrotik...

Hola a todos!!! Bueno, este es mi primer post así que espero que les guste. Les voy a explicar como unir 2 redes LAN remotas mediante dos routers Mikrotik de una manera sencilla y sin tener que saber mucho acerca de configuración avanzada.


Una VPN es un "tunel" por donde pueden ser transportada información de manera segura (Los paquetes viajan encriptados) usando como medio de transporte Internet. Este tipo de conexión vamos a usar en este ejemplo.
En mi trabajo, nos vimos con la necesidad de unir dos LAN por pedido de un cliente, ya que este quería lograr conectividad transparente para los usuarios al intentar conectarse desde la sucursal hacia algún recurso de casa central y viceversa. También puede servir en el caso que ustedes y algún amigo tengan Mikrotik y quieran compartir archivos o jugar mediante una conexión segura entre sus redes.

Inicialmente configuramos básicamente dos Mikrotik en los dos lugares y armamos una VPN IPSEC para que cree un túnel seguro y como este protocolo enruta de manera nativa, en pocos minutos teniamos conexión entre las dos oficinas.

Este cliente en su sucursal tenía una conexión a Internet muy inestable y eso nos trajo problemas con IPSEC. Se desconectaba solo y a veces no volvía a conectarse hasta no reiniciar los dos routers. Luego de buscar una solución a este problema, dimos con que configurando una VPN PPTP gateway-to-gateway, esta era menos proclive a desconectarse ante fallas de la conexión a Internet y ademas soportaba reconexión automática.

Las direcciones IP que muestro a continuación son solo de ejemplo, si las reemplazan por las que ustedes tengan funcionaría de igual manera. Pueden copiar los comandos, reemplazar los nombres de las interfaces y las IP con el Bloc de notas, mediante Winbox abren "New Terminal", pegan ahí lo copiado y listo!
Cabe aclarar que para que se establezca la comunicación entre las dos redes, estas tienen que tener diferentes rango de IP.

Configurando la VPN PPTP gateway-to-gateway

Router1 (Casa central):

Configuramos las IP en las interfaces:

LAN:


/ip address
add address=10.0.0.254/24 broadcast=10.0.0.255 comment="" disabled=no
interface=lan network=10.0.0.0

En este caso la conexión a Internet es por cablemodem así que la interfaz de "WAN" obtiene IP mediante el "dhcp-client".
Muy importante en este es que queden las opciones "add-default-route=yes" y "use-peer-dns=yes". La primera setea la ruta por defecto y la segunda permite que se usen los DNS del ISP.

/ip dhcp-client
add add-default-route=yes comment="" default-route-distance=0 disabled=no
interface=wan use-peer-dns=yes use-peer-ntp=yes

Los DNS. Tiene que estar la opción "allow-remote-requests=yes" para que el router actúe como DNS cache y los equipos de la red puedan resolver nombres de dominio en IPs.

/ip dns
set allow-remote-requests=yes

Configuramos el "masquerade" para que haga NAT de las IP de la LAN por la IP publica hacia Internet.

/ip firewall nat
add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan

Protegemos básicamente el router.

/ip firewall filter
add action=accept chain=input comment="" connection-state=established
disabled=no
add action=accept chain=input comment="" connection-state=related disabled=no
add action=accept chain=input comment="" disabled=no protocol=udp
add action=drop chain=input comment="" connection-state=invalid disabled=no



Router2 (Sucursal)


/ip address
add address=10.0.1.254/24 broadcast=10.0.1.255 comment="" disabled=no
interface=lan network=10.0.1.0


/ip dhcp-client
add add-default-route=yes comment="" default-route-distance=0 disabled=no
interface=wan use-peer-dns=yes use-peer-ntp=yes


/ip dns
set allow-remote-requests=yes


/ip firewall nat
add action=masquerade chain=srcnat comment="" disabled=no out-interface=wan


/ip firewall filter
add action=accept chain=input comment="" connection-state=established
disabled=no
add action=accept chain=input comment="" connection-state=related disabled=no
add action=accept chain=input comment="" disabled=no protocol=udp
add action=drop chain=input comment="" connection-state=invalid disabled=no





Y lo mas importante...

OK, hasta acá tendriamos las dos oficinas con conexión a Internet pero nada mas. Para configurar la VPN, en Router1:

En Winbox vamos al menú PPP > Secrets. Mediante el boton "+" agregamos una cuenta. En Name ponemos "sucursal", en Password, por ej. 123456, en la lista desplegable Profile elegimos "default-encryption", en Local Address la IP de LAN del router (10.0.0.254), en Remote Address 10.0.0.200 y damos Apply.

Como unir 2 redes LAN con Mikrotik...

En la solapa Interface en la lista desplegable del botón "+" elegimos PPTP Server. En la ventana que se abre en User pondremos "sucursal" que era el usuario que anteriormente creamos. Damos Apply.

vpn

Finalmente cliqueamos el botón "PPTP Server", marcamos "Enable" y nos aseguramos que en Default Profile este seleccionado "default-encryption".

mikrotik


En el Router2 mediante Winbox vamos al menú PPP, desde el botón "+", elegimos PPTP Client, en la ventana seleccionamos la solapa "Dial Out". En "Connect To" ingresamos la IP publica del Router1, en este caso por ejemplo sería 192.168.10.164, en User ponemos "sucursal" y en Password "123456". Nuevamente nos aseguramos que en Profile figure "default-encryption" y damos Apply.

pptp

Si esta todo bien, automáticamente cuando den Apply en la lista de Interface el "PPTP Client" va figurar como "Connected". Eso significa que ya esta conectado al otro router mediante la VPN. Lo podemos comprobar fácilmente si desde el menu Tools le hacemos un ping a la IP de la LAN del router de Casa central (10.0.0.254) y este responde.

gateway-to-gateway

Ahora tenemos respuesta del Router1 hacia el Router2, pero si prueban al revés no va a funcionar. Lo que sucede en ese caso es que los paquetes IP no conocen "el camino de vuelta" por decirlo de alguna manera, entonces nosotros se lo vamos a enseñar.

En el Router1 vamos a IP > Routes, con el "+" añadimos una ruta estática. En Destination ponemos la red remota (10.0.1.0/24) y en Gateway ingresamos la IP que le otorga el PPTP Server al "usuario" "sucursal" (10.0.0.200).

Como unir 2 redes LAN con Mikrotik...

De la misma manera en el Router2 agregamos una ruta estática. En Destination ponemos la red remota 10.0.0.0/24 y en Gateway la IP de LAN del Router1 (10.0.0.254). Aplicamos.

vpn


Finalizando...

Ahora, si hacemos ping entre los routers a sus IP de LAN van a responder los dos, igualmente si lo hacemos entre dos equipos de las 2 redes.

mikrotik






Bueno, esto es todo por ahora. Espero les sirva como a mi!!!

Saludos!!!

Fuentes de Información - Como unir 2 redes LAN con Mikrotik...

El contenido del post es de mi autoría, y/o, es un recopilación de distintas fuentes.

Dar puntos
106 Puntos
Votos: 15 - T!score: 7.5/10
  • 4 Seguidores
  • 44.805 Visitas
  • 40 Favoritos

41 comentarios - Como unir 2 redes LAN con Mikrotik...

@niinoomoya Hace más de 3 años
Exelente el aporte =)
@DcChapatin Hace más de 3 años
esto me sirbe para jugar gta IV por lan?, es como el hamachi?
@DarckSM Hace más de 3 años
puerta
@TheGiuse Hace más de 3 años
DcChapatin dijo:esto me sirbe para jugar gta IV por lan?, es como el hamachi?

supongo xd.... conectate xd
@zonenet Hace más de 3 años
Hola amigo muy buen aporte, pero...eso es para conectar un rb a otro rb, puedo preguntarte como hago para conectar varios rb-sucursales a un rb master ?..si pudieras escribirme a correozone-net@hotmail.com, te agradesco de antemano.
@zonenet Hace más de 3 años
nada amigo logro hacer ping de la base al cliente pero del cliente a una estacion (podria ser un server web)no logro hacer ping...que sera?
@Ozkaxr Hace más de 3 años
sirbe para el RB 750G o para cual version es espero tu respuesta
@burrito2 Hace más de 3 años
+10 podrias subir algun video
@Nabucodonosor_2 Hace más de 3 años
Exelente información, muy bien explicado,y ademas no llenaste la pagina de codigos, pusite lo justo.
@Tonblader Hace más de 3 años
Esto es para unir las computadoras de casa o empresas de un solo lugar para que esten todos en una red lan? Osea, que las computadoras esten en una red LAN?
@Tonblader Hace más de 3 años
Tonblader dijo:Esto es para unir las computadoras de casa o empresas de un solo lugar para que esten todos en una red lan? Osea, que las computadoras esten en una red LAN?

Ya lo resolvi , con este comando era la cosa:

Enmascarado de red.

/ip firewall nat
add action=masquerade comment="Enmascarado de red local" chain=srcnat
disabled=no src-address=192.168.1.0/24
@ivan_at Hace más de 3 años
oye amigo si las combino signific combinar la Velocidad por ejemplo en mi oficina cuento con 5 redes a mi alrededor la mayoria de ella de 2mb si las combino me diera un total de 10Mb.... Es por lo unico que entre al post
@clr1900 Hace más de 3 años
Hola me podias mandar el tutorial que hiciste ya que no se ven la imágenes, quiero hacer lo mismo con los dos Mikrotik, y no me doy cuenta donde estoy cometiendo el error.-
Desde ya muchas gracias.-
clr1900@yahoo.com.ar
@jgesberattiel Hace más de 3 años
Buenas, lo que necesito es crear 3 VPN en distinas sucursales apuntanto a una misma red ej: 192.168.88.x pero lo que se quiere es transportar datos no internet, ellos manejan un servidor DHCP, el cual las 3 sucursales se encuentran en ese rango, se podrian conectar las 3 vpn con ese sevidor?? desde ya muchas gracias por la ayuda.-
@jgesberattiel Hace más de 3 años
Lo que me falto es que utilizaria RB750 MK en las 3 sucursales para crear las VPN.-
@tjdemon454 Hace más de 3 años
una consulta, e echo todo lo que indica en tutorial, mi pc y el mikrotik se logran comunicar, pero?
tengo un AP, en realidad varios y quieros manejarlos desde mi casa, ya que esos AP se encuentran en provincia y no logro acceder a ellos por este modo, aunq eis puedo pinear al mikrotik remoto y de ese mikrotik tambien a mi pc, pero no acceder a las pcs de la lan de provincia.
@Jeleo Hace más de 3 años
Excelente aporte ... Gracias
@patoruso Hace más de 3 años
me re sirvio van 10
@Kalingthor Hace más de 3 años
hola amigo, Me gustaría configurar mi RB750GL mikotik, tengo 2 lineas de telefonica de 3mb cada una quiero balancearlo y juntar las 2 lineas. tienes algún tutorial bien explicado........NFU si lo subes
@freedarwuin Hace más de 2 años
Amigo una pregunta esta buenisimo tu aporte muchos quisieran poner a prueba podria agarar el mikrotik y en new teerminal colocar export para que nos envie un documento.txt de esos datos asi podemos ver mucho mejor tu aporte muchas gracias aqui esta mi correo para todos los que quieran ajuntar y aportat mas informacion



darwuinjose@gmail.com me conecto mas por aqui
darwuin_2010@hotmail.com
darwuin_2010 esta es una cuenta Skype.

salu2
@caracohete Hace más de 2 años
Muy util el tutorial, lo he probado con dos rb750 y funciona perfectamente, el único incoveniente que he encontrado es que solo puedo acceder a los equipos por ip y no por el nombre de las máquinas, me explico si pongo xxx.xxx.xxx.xxx accedo a los recursos del ordenador pero si pongo: "servidor" que es el nombre del equipo me dice que no se encuentra en la red, habria alguna manera de solucionar esto?
@Rabenss Hace más de 2 años
excelente ! lo probe en un rb750 funciona perfecto
@thurhii Hace más de 2 años
en donde consigo el programa??
@dschroder Hace más de 2 años
Hola, como estas! Te hago una consulta. Logre realizar el túnel, puedo hacer ping entre routers. Pero no puedo llegar de pc a pc. Osea, no puedo ver los equipos del entorno de red de la central en la sucursal. Básicamente, necesito compartir archivos entre las pcs de las distintas sucursales, pero no lo estoy logrando. Me falta agregar algún ruteo? Espero me des una mano. Saludos. Dardo.
@LandlaX Hace más de 2 años
Suena interesante.... lo probare... de momento te dejo los 6 puntos que te faltan para que seas NFU.... o como se llame ahora... ya no se sabe con tanto cambio que tubo taringa...
@truenito79 Hace más de 11 meses
Muy bueno el tutorial !!! Muchas gracias
@kingoflinuxake Hace más de 9 meses
Hola Jebx
Quisiera hacer una consulta, que configuracion adicional se necesitaria si es que el IP del Server es dinamico y en este tengo configurado un script de actualizacion de IP Dinamica, digamos con no-ip.com o changeip.com?
Y Muy buen aporte muchas gracias.