pseudocodigos Ejercicios resueltos

‚Äé¬ŅQue es el Pseudoc√≥digo?¬†
El pseudocódigo (falso lenguaje) es una descripción de alto nivel de un algoritmo que emplea una mezcla de lenguaje natural con algunas convenciones sintácticas propias de lenguajes de programación, como asignaciones, ciclos y condicionales. Es utilizado para describir algoritmos en libros y publicaciones científicas, y como producto intermedio durante el desarrollo de un algoritmo. 

El pseudocódigo está pensado para facilitar a las personas el entendimiento de un algoritmo, y por lo tanto puede omitir detalles irrelevantes que son necesarios en una implementación. Programadores diferentes suelen utilizar convenciones distintas, que pueden estar basadas en la sintaxis de lenguajes de programación concretos. Sin embargo, el pseudocódigo en general es comprensible sin necesidad de conocer o utilizar un entorno de programación específico, y es a la vez suficientemente estructurado para que su implementación se pueda hacer directamente a partir de él. 


¬ŅPara que sirve el Pseudoc√≥digo?¬†
Sirve para escribir programas de computadora en lenguaje natural de tal manera que se facilite la comprensión, prueba y posterior codificación en un lenguaje de programación específico. 




1. Programa que lee una temperatura en grados centígrados y nos la calcula y nos la escribe en las escalas reamur, Fahrenheit y kelvin.
Reamur = Centígrados x 0.8
Fahenheit = Centígrados * 1.8 +32
Kelvin = Centígrados + 273

Proceso CONVERSION_DE_TEMPERATURA
Escribir "Introduzca Grados Celsius Para Su Conversion"
LEER a
F<-(a*9/5)+32
K<-a+273.15
R<-a*0.8
escribir "El Resurtado de Grados Fahrenheit es " , F ;
escribir "El Resurtado de Grados Kelvin es " , K ;
escribir "El Resurtado de Grados Reamur es " , R ;
FinProceso

2. Programa que lee dos n√ļmeros enteros, los suma, los resta y muestra el resultado de las dos operaciones.


Proceso SUMA_RESTA
Escribir "Introduzca La Primera cantidad"
leer a
Escribir "Introduzca La Segunda cantidad"
leer b
S<-a+b
R<-a-b
escribir "El Resurtado de la Suma Es: " , S ;
escribir "El Resurtado de la Resta Es: " , R ;
FinProceso

3. Programa que lee tres n√ļmeros enteros y positivos y calcula su producto sacando el resultado en pantalla.

Proceso LECTURA_TRES_NUMEROS
Escribir "Introduce el Primer numero Entero"
Leer a
Escribir "Introduce el Segundo numero Entero"
Leer b
Escribir "Introduce el tercer numero Entero"
leer c
V<-(a*b)*c
escribir "El Resurtado del Producto es " , v ;
FinProceso

4. Algoritmo que, dado un n√ļmero entero no negativo que designa un periodo de tiempo expresado en segundos, devuelva el equivalente en d√≠as, horas, minutos y segundos.


Proceso Conversion_Tiempo
Escribir "Introduce los Sengundo a calcular"
Leer a
M<-a*0.0166666666666667
H<-(a*0.0166666666666667)*0.0166666666666667
D<-(a*0.0166666666666667)*0.0166666666666667*0.0416666666666667
S<-a+0
escribir "El Resurtado del Minuto es " , M ;
escribir "El Resurtado de la Hora es " , H ;
escribir "El Resurtado del Dia es " , D ;
escribir "El Resurtado del Segundo es " , S ;
FinProceso

5. Algoritmo que dadas dos horas distintas expresadas en hora, minutos y segundos nos calcule la diferencia en segundos entre ambas.


Proceso DIFERENCIA_SEGUNDOS
Escribir "Introduce Hora #1"
Leer a
Escribir "Introduce Hora #2"
leer b
Ha1<-a*60
Ha2<-a*1
Ha3<-a*0.0416666666666667
Ha4<-a*3600
Hb1<-b*60
Hb2<-b*1
Hb3<-b*0.0416666666666667
Hb4<-b*3600
Ha4_Hb4<-a*3600-b*3600
Hb4_Ha4<-b*3600-a*3600
escribir "El Resurtado de la Hora #1 en Minuto es " , Ha1 ;
escribir "El Resurtado de la Hora #1 en Hora es " , Ha2 ;
escribir "El Resurtado de la Hora #1 en Dia es " , Ha3 ;
escribir "El Resurtado de la Hora #1 en Segundo es " , Ha4 ;
escribir "El Resurtado de la la Hora #2 Minuto es " , Hb1 ;
escribir "El Resurtado de la la Hora #2 en Hora es " , Hb2 ;
escribir "El Resurtado de la la Hora #2 Dia es " , Hb3 ;
escribir "El Resurtado de la la Hora #2 Segundo es " , Hb4 ;

Escribir "La Diferencia de Segundos de la Hora #1 de la Hora #2 es " , Ha4-Hb4 ;
Escribir "La Diferencia de Segundos de la Hora #2 de la Hora #1 es " , Hb4-Ha4 ;
FinProceso


1)Se posee un monto de dinero de $120, se gasta en supermercado $49,5 y luego en verdulería 12,10. Mostrar el saldo. 

Proceso gasto 
saldo<-120-49.5-12.10; 
Escribir "Saldo ",saldo; 
FinProceso 


Usar este ejercicio para resaltar la necesidad de la utilizaci√≥n de las variables, ya que este ejercicio se ajusta √ļnicamente para los valores constantes consignados.¬†


2)Realizar el pseudocódigo para calcular el 15% de un valor constante. 

Proceso 15% 
cal<-325*.15; 
Escribir "El 15% de 325 es ",cal; 
FinProceso 


3)Modificar el pseudocódigo anterior para que muestre el 15% de un valor ingresado. 

Proceso 15% 
Escribir "Ingrese un numero"; 
Leer n; 
cal<-n*.15; 
Escribir "El 15% de ",n," es ",cal; 
FinProceso 


4)Calcular el nuevo salario de un obrero si obtuvo un incremento del 25% sobre su salario anterior. 


Proceso sueldo_obrero 
Escribir ‚ÄúIngrese el Sueldo‚ÄĚ;¬†
Leer sueldo; 
Nuevo<-sueldo*.25+sueldo; 
Escribir “El nuevo sueldo es: “,nuevo; 
FinProceso 

Comentarios Destacados

7 comentarios - pseudocodigos Ejercicios resueltos

@viewmaster09
preciso uno que cargue un vector y los ordene con cualquier metodo de ordenamiento, pero usando punteros
@valece +1
BLUE J ON

buena info como para ir empezando
@eduardo7000 +1
no me complico uso java y listo xD.
Yo pensaba que el pseudocódigo era algo mas difícil que hacían los programadores para que no entendieras nada
@HaroldVillot
imprimir y contar los numeros que hay del 1 al 100. excepto los multiplos del 2