驴Que es el Pseudoc贸digo?
El pseudoc贸digo (falso lenguaje) es una descripci贸n de alto nivel de un algoritmo que emplea una mezcla de lenguaje natural con algunas convenciones sint谩cticas propias de lenguajes de programaci贸n, como asignaciones, ciclos y condicionales. Es utilizado para describir algoritmos en libros y publicaciones cient铆ficas, y como producto intermedio durante el desarrollo de un algoritmo.聽

El pseudoc贸digo est谩 pensado para facilitar a las personas el entendimiento de un algoritmo, y por lo tanto puede omitir detalles irrelevantes que son necesarios en una implementaci贸n. Programadores diferentes suelen utilizar convenciones distintas, que pueden estar basadas en la sintaxis de lenguajes de programaci贸n concretos. Sin embargo, el pseudoc贸digo en general es comprensible sin necesidad de conocer o utilizar un entorno de programaci贸n espec铆fico, y es a la vez suficientemente estructurado para que su implementaci贸n se pueda hacer directamente a partir de 茅l.聽


驴Para que sirve el Pseudoc贸digo?聽
Sirve para escribir programas de computadora en lenguaje natural de tal manera que se facilite la comprensi贸n, prueba y posterior codificaci贸n en un lenguaje de programaci贸n espec铆fico.聽




1. Programa que lee una temperatura en grados cent铆grados y nos la calcula y nos la escribe en las escalas reamur, Fahrenheit y kelvin.
Reamur = Cent铆grados x 0.8
Fahenheit = Cent铆grados * 1.8 +32
Kelvin = Cent铆grados + 273

Proceso CONVERSION_DE_TEMPERATURA
Escribir "Introduzca Grados Celsius Para Su Conversion"
LEER a
F<-(a*9/5)+32
K<-a+273.15
R<-a*0.8
escribir "El Resurtado de Grados Fahrenheit es " , F ;
escribir "El Resurtado de Grados Kelvin es " , K ;
escribir "El Resurtado de Grados Reamur es " , R ;
FinProceso

2. Programa que lee dos n煤meros enteros, los suma, los resta y muestra el resultado de las dos operaciones.


Proceso SUMA_RESTA
Escribir "Introduzca La Primera cantidad"
leer a
Escribir "Introduzca La Segunda cantidad"
leer b
S<-a+b
R<-a-b
escribir "El Resurtado de la Suma Es: " , S ;
escribir "El Resurtado de la Resta Es: " , R ;
FinProceso

3. Programa que lee tres n煤meros enteros y positivos y calcula su producto sacando el resultado en pantalla.

Proceso LECTURA_TRES_NUMEROS
Escribir "Introduce el Primer numero Entero"
Leer a
Escribir "Introduce el Segundo numero Entero"
Leer b
Escribir "Introduce el tercer numero Entero"
leer c
V<-(a*b)*c
escribir "El Resurtado del Producto es " , v ;
FinProceso

4. Algoritmo que, dado un n煤mero entero no negativo que designa un periodo de tiempo expresado en segundos, devuelva el equivalente en d铆as, horas, minutos y segundos.


Proceso Conversion_Tiempo
Escribir "Introduce los Sengundo a calcular"
Leer a
M<-a*0.0166666666666667
H<-(a*0.0166666666666667)*0.0166666666666667
D<-(a*0.0166666666666667)*0.0166666666666667*0.0416666666666667
S<-a+0
escribir "El Resurtado del Minuto es " , M ;
escribir "El Resurtado de la Hora es " , H ;
escribir "El Resurtado del Dia es " , D ;
escribir "El Resurtado del Segundo es " , S ;
FinProceso

5. Algoritmo que dadas dos horas distintas expresadas en hora, minutos y segundos nos calcule la diferencia en segundos entre ambas.


Proceso DIFERENCIA_SEGUNDOS
Escribir "Introduce Hora #1"
Leer a
Escribir "Introduce Hora #2"
leer b
Ha1<-a*60
Ha2<-a*1
Ha3<-a*0.0416666666666667
Ha4<-a*3600
Hb1<-b*60
Hb2<-b*1
Hb3<-b*0.0416666666666667
Hb4<-b*3600
Ha4_Hb4<-a*3600-b*3600
Hb4_Ha4<-b*3600-a*3600
escribir "El Resurtado de la Hora #1 en Minuto es " , Ha1 ;
escribir "El Resurtado de la Hora #1 en Hora es " , Ha2 ;
escribir "El Resurtado de la Hora #1 en Dia es " , Ha3 ;
escribir "El Resurtado de la Hora #1 en Segundo es " , Ha4 ;
escribir "El Resurtado de la la Hora #2 Minuto es " , Hb1 ;
escribir "El Resurtado de la la Hora #2 en Hora es " , Hb2 ;
escribir "El Resurtado de la la Hora #2 Dia es " , Hb3 ;
escribir "El Resurtado de la la Hora #2 Segundo es " , Hb4 ;

Escribir "La Diferencia de Segundos de la Hora #1 de la Hora #2 es " , Ha4-Hb4 ;
Escribir "La Diferencia de Segundos de la Hora #2 de la Hora #1 es " , Hb4-Ha4 ;
FinProceso


1)Se posee un monto de dinero de $120, se gasta en supermercado $49,5 y luego en verduler铆a 12,10. Mostrar el saldo.

Proceso gasto聽
saldo<-120-49.5-12.10;聽
Escribir "Saldo ",saldo;聽
FinProceso聽


Usar este ejercicio para resaltar la necesidad de la utilizaci贸n de las variables, ya que este ejercicio se ajusta 煤nicamente para los valores constantes consignados.聽


2)Realizar el pseudoc贸digo para calcular el 15% de un valor constante.

Proceso 15%聽
cal<-325*.15;聽
Escribir "El 15% de 325 es ",cal;聽
FinProceso聽


3)Modificar el pseudoc贸digo anterior para que muestre el 15% de un valor ingresado.

Proceso 15%聽
Escribir "Ingrese un numero";聽
Leer n;聽
cal<-n*.15;聽
Escribir "El 15% de ",n," es ",cal;聽
FinProceso聽


4)Calcular el nuevo salario de un obrero si obtuvo un incremento del 25% sobre su salario anterior.


Proceso sueldo_obrero聽
Escribir 鈥淚ngrese el Sueldo鈥;聽
Leer sueldo;聽
Nuevo<-sueldo*.25+sueldo;聽
Escribir 鈥淓l nuevo sueldo es: 鈥,nuevo;聽
FinProceso聽