El post que buscas se encuentra eliminado, pero este también te puede interesar

Instalar tarjetas inalámbricas Broadcom en Debian Squeeze

Instalación de tarjetas de red inalámbricas Broadcom en GNU/Linux Debian 6.0 Squeeze

Instalar tarjetas inalámbricas Broadcom en Debian Squeeze


En este post voy a explicar como instalar los controladores de las tarjetas de red inalámbricas Broadcom basados en los modelos de los chipsets series 4311, 4312, 4313, 4321, 4322, para ello instalaremos el controlador híbrido Broadcom que contiene los módulos para estos dispositivos.

Si no estas seguro de cual modelo de tarjeta inalámbrica tienes en tu PC o Laptop visita este post.

Algunos dispositivos inalámbricos Broadcom no son soportados por este controlador por el momento, entre ellos:

BCM4313 (PCI-ID: 14E4:4727)
BCM4321 (PCI-IDs: 14E4:4328, 14E4:4329)
BCM4322 (PCI-ID: 14E4:432B)


El soporte para estos chipsets es posible solo usando el controlador (wl) hecho por el fabricante, éstos incluyen componentes binarios únicamente para las arquitecturas x86 ó x86-64.

Instalación

Para instalar el controlador Broadcom necesitamos agregar el repositorio non-free, así que editamos nuestro sources.list
nano /etc/apt/sources.list


Agregamos el repositorio non-free. Nota: Para saber la lista de repositorios que pueden añadir al sources.list visiten mi post "Repositorios GNU/Linux Debian 6 Squeeze"
# Repositorio Oficial
deb http://ftp.us.debian.org/debian squeeze main contrib non-free


Actualizamos e instalamos los paquetes necesarios.
aptitude update

aptitude install module-assistant wireless-tools


Compilamos e instalamos el paquete broadcom-sta-modules-* para nuestro sistema, usando Module-Assistant:
m-a a-i broadcom-sta


Actualizamos el kernel con initramfs.
update-initramfs -u -k $(uname -r)


Inhabilitamos los módulos conflictivos.
modprobe -r b44 b43 b43legacy ssb


Cargamos el módulo wl.
modprobe wl


Verificamos las interfaces disponibles para nuestra tarjeta inalámbrica.
iwconfig


Levantamos la interface de nuestra tarjeta inalámbrica.
ifconfig wlan0 up


Nota: Si la pequeña bombilla de la tarjeta inalámbrica no enciende debemos encenderla por Hardware (presionando el botón en la Laptop) o por Software (network-manager, wincd, etc.).

Dispositivos Soportados
PCI: 14E4:4311 Broadcom Corporation BCM4311 802.11b/g WLAN
PCI: 14E4:4312 Broadcom Corporation BCM4312 802.11a/b/g
PCI: 14E4:4313 Broadcom Corporation BCM4311 802.11a
PCI: 14E4:4315 Broadcom Corporation BCM4312 802.11b/g LP-PHY
PCI: 14E4:4328 Broadcom Corporation BCM4321 802.11a/b/g/n
PCI: 14E4:4329 Broadcom Corporation BCM4321 802.11b/g/n
PCI: 14E4:432A Broadcom Corporation BCM4321
PCI: 14E4:432B Broadcom Corporation BCM4322 802.11a/b/g/n Wireless LAN Controller
PCI: 14E4:432C Broadcom Corporation BCM4322 802.11b/g/n
PCI: 14E4:432D Broadcom Corporation BCM4322 802.11a/b/g/n
PCI: 14E4:4353 Broadcom Corporation BCM43224 802.11a/b/g/n
PCI: 14E4:4357 Broadcom Corporation BCM43225 802.11b/g/n
PCI: 14E4:4727 Broadcom Corporation BCM4313 802.11b/g LP-PHY


Wifi

- Si tienes una tarjeta de red inalámbrica Atheros visita mi post "Instalar tarjetas inalámbricas Atheros en Debian Squeeze"

- Si tienes una tarjeta de red inalámbrica Intel visita mi post "Instalar Tarjetas Inalámbricas Intel en Debian Squeeze"

GNU

Espero este post les ayude, alguna duda o sugerencia es bien recibida.

11 comentarios - Instalar tarjetas inalámbricas Broadcom en Debian Squeeze

@LiGNUxero
Nose como funcionarán las broadcom con esta técnica de instalación, siempre usé la instalación desde git y hasta podes inyectar paquetes con aircrack-ng
tendría que probar esta alguna vez a ver que tal esta gracias por el dato
@gaddafi
GRACIAS, ¡me ha funcionado perfectamente!, (este comentario lo envié conectado via Wi-Fi).

+ 10 pts, + 10 marios debianwirelessTarjetasqueezeinalambricaLinuxBroadcomInstalar tarjetas inalámbricas Broadcom en Debian SqueezeWifiGNU

Lo único que me falataba era descargar un gestor gráfico para configurar la red. Me bajé un montón: WiFi-radar, Wicd Network Manager, pero el que me funcionó (y es más bonito ) fue Network-Manager.
Los encontré con el gestor de paquetes Synaptic.
@gaddafi
network-manager-gnome
herramienta para conectarte via wifi
debian

www.muylinux.com/2009/07/16/10-herramientas-para-conectarte-a-redes-wi-fi
@antalawn_alen
disculpa pero tengo el siguiente problema,,,llego hasta aqui

[i]root@usuarios: m-a a-i broadcom-sta

Actualizado los ficheros infos de los paquetes 1
Obteniendo los fuentes de la versión del núcleo: 2.6.32-5-686
apt-get install linux-headers-2.6.32-5-686
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
linux-headers-2.6.32-5-686 : Depende: gcc-4.3 pero no va a instalarse
E: Paquetes rotos
apt-get install build-essential
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
libglib2.0-0 : Rompe: eog (< 3.2.2-3) pero 2.30.2-1 va a ser instalado
libgnome-keyring0 : Rompe: gnome-keyring (< 3.0) pero 2.30.3-5 va a ser instalado
network-manager : Recomienda: crda pero no va a instalarse
Rompe: network-manager-gnome (< 0.9) pero 0.8.1-2 va a ser instalado
E: Paquetes rotos

¡Hecho!
download
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
libglib2.0-0 : Rompe: eog (< 3.2.2-3) pero 2.30.2-1 va a ser instalado
libgnome-keyring0 : Rompe: gnome-keyring (< 3.0) pero 2.30.3-5 va a ser instalado
network-manager : Recomienda: crda pero no va a instalarse
Rompe: network-manager-gnome (< 0.9) pero 0.8.1-2 va a ser instalado
E: Paquetes rotos
[/i]

y leugo de eso no se que hacer. soy nuevo en debian y necesito urgente activar la tarketa wifi

Gracias
@antalawn_alen
deivijesus dijo:antalawn_alen, si podrias decirme el contenido del archivo sources.list, puedes verlo escribiendo:
nano /etc/apt/sources.list

Así podre ayudarte al parecer necesitaras modificar los repositorios para poder tener las versiones correctas de los archivos que o paquetes que necesitas instalar.


ya solucione el problema y pude habilitar la tarjeta,,,el problema era que en la sources.list

habian unos repositorios desde un CD,,los quite y funciono todo bien.

Muchas gracias
@HARKOZ +1
muchas gracias!!!! me funcionó de maravilla!! +10 excelente info
@deivijesus
Que bueno que te funciono