Problemas para instalar Dropbox en Debian

Problemas para instalar Dropbox en Debian

Dropbox es un servicio de almacenamiento masivo en la nube, del que ya hemos hablado un poco aquí. Es multiplataforma, y ofrece un paquete para compilar con el código fuente, paquetes .deb (para Ubuntu) y .rpm (para Fedora) para Linux. Si estás en Debian, y tienes problemas para instalar el .deb o el paquete fuente, aquí explico cómo solucionarlo.

Problemas en la instalación

Voy a describir brevemente las dos opciones principales para instalar Dropbox en Debian, y los errores que resultan de ellas, y luego explico cómo sí se puede instalar esta utilidad.

Caso 1: Instalación del .deb

Si al instalar el paquete .deb que ofrece Dropbox en su página, ya sea via Synaptic o con dpkg resulta en un error así:

nautilus-dropbox:
Depends: libnautilus-extension1 (>=1:2.22.2) but 2.30.1-2 is to be installed

Caso 2: Compilando el código fuente

Hay que tener instalados ciertos paquetes antes de empezar

# apt-get install libnautilus-extension-dev python-docutils

Si después de descargar el archivo con el código fuente de aquí, extraerlo, navegar desde una terminal hacia el directorio recién creado y:

$./configure
$ make
# make install

Y aún así, NADA:

Solucionar problemas de dependencia, e instalar Dropbox

Con esta solución, se necesita del paquete .deb, se puede bajar de aquí. Con este ejemplo, voy a trabajar con la última versión (0.6.7) de 32bits. El problema con este archivo no es de dependencias exactamente, sino que en el caso de Debian, el .deb no especifica las dependencias que necesita correctamente.

Para corregir este defecto, desde una terminal naveguen a la carpeta donde descargaron el .deb, y sigan los siguientes pasos para desempaquetar el archivo:

mkdir -p extract/DEBIAN
dpkg-deb -x nautilus-dropbox_0.6.7_i386.deb extract/
dpkg-deb -e nautilus-dropbox_0.6.7_i386.deb extract/DEBIAN/

Ahora, hay que editar el archivo control en la carpeta extract/DEBIAN/, con el editor de texto de su preferencia: gedit, leafpad, etc.

Ubiquen la línea que diga lo siguiente:

Depends: libatk1.0-0 (>= 1.20.0), libc6 (>= 2.4), libcairo2 (>= 1.6.0), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.12.0), libnautilus-extension1 (>= 1:2.22.2), libpango1.0-0 (>= 1.20.1), python (>= 2.5), python-gtk2 (>= 2.12)

Y cambien el valor de libnautilus-extension1 (>= 1:2.22.2) a libnautilus-extension1 (>= 2.22.2). El formato original es el utilizado en Ubuntu; al cambiarlo, podrán instalar sin problemas en Debian.

Después del cambio, hay que crear un directorio llamado build y utilizar dpkg-deb para crear un nuevo .deb:

mkdir build
dpkg-deb -b extract/ build/

En esta nueva carpeta, se creará un nuevo .deb que pueden instalar sin "problemas de dependencias".

Finalmente, pueden inicializar el servicio con el siguiente comando:

dropbox start -i


Fuente

Fuentes de Información - Problemas para instalar Dropbox en Debian

Tags: Ubuntu | debian | Linux | Dropbox

Dar puntos
0 Puntos
Votos: 0 - T!score: 0/10
  • 0 Seguidores
  • 1.727 Visitas
  • 5 Favoritos

4 comentarios - Problemas para instalar Dropbox en Debian

@Exiliadomx Hace más de 3 años
No uso dropbox pero uso Debian.

Seguramente en algun momento me será utili tu post, por lo mientras a favoritos gracias
@SinSo0n Hace más de 3 años
gracias.
@Bosta Hace más de 3 años
a mi me pasaba q cuando queria instalar la version de ubuntuen debian, me tiraba error de dependencias y no me anime. revisando los foros de dropbox hay una version un poco mas vieja q sí funciona, pero tiene un problema: en el menú contextual no aparece la opción "copy public link"