epelpad

El post que buscas se encuentra eliminado, pero este también te puede interesar

ingreso remoto a mikroik

PRIMERO QUE TODO TIENES QUE CREAR UNA CUENTA EN DYNDNS.COM y seguir los pasos de activación
para poder ingresar remotamente a nuestro mikrotik solo copia y pega ese en system---scripts


# Set needed variables
:local username "TU NOMBRE DE USUARIO"
:local password "TU CONTRASEÑA"
:local hostname "TUHOST.DYNDNS.ALGO"
:global dyndnsForce
:global previousIP
# print some debug info
:log info ("UpdateDynDNS: username = $username"
:log info ("UpdateDynDNS: password = $password"
:log info ("UpdateDynDNS: hostname = $hostname"
:log info ("UpdateDynDNS: previousIP = $previousIP"
# get the current IP address from the internet (in case of double-nat)
/tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
:local result [/file get dyndns.checkip.html contents]
# parse the current IP result
:local resultLen [:len $result]
:local startLoc [:find $result ": " -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result "</body>" -1]
:local currentIP [:pick $result $startLoc $endLoc]
:log info "UpdateDynDNS: currentIP = $currentIP"
# Remove the # on next line to force an update every single time - useful for debugging,
# but you could end up getting blacklisted by DynDNS!
#:set dyndnsForce true
# Determine if dyndns update is needed
# more dyndns updater request details available at http://www.dyndns.com/developers/specs/syntax.html
:if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={
:set dyndnsForce false
:set previousIP $currentIP
/tool fetch user=$username password=$password mode=http address="members.dyndns.org"
src-path="/nic/update?hostname=$hostname&myip=$currentIP" dst-path="/dyndns.txt"
:local result [/file get dyndns.txt contents]
:log info ("UpdateDynDNS: Dyndns update needed"
:log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
:put ("Dyndns Update Result: ".$result)
} else={
:log info ("UpdateDynDNS: No dyndns update needed"
}


al copiar este scritps solo lo pegas en system scripts y después le das una regla
(scheduler) para su funcionamiento con un intervalo de 01:00:00


a mi me ha funcionado perfecto con mis dos servidores con dos compañias diferentes (vtr y movistar) y he ingresado a nivel nacional en mi país (CHILE)

0 comentarios - ingreso remoto a mikroik