Configurar Video y WiFi en Notebook Bangho L10 para UBUNTU 9.04


Hola!
Este es mi primer Post. Lo hago para tratar de devolver algo de todo lo que me da esta comunidad.

Me compre una Notebook Bangho L10. Ahora estan de oferta y se consiguen buenos equipos a buen precio.
La verdad que no fue facil instalar Ubuntu en esta maquina debido a la placa de video Sis y la placa Wireless Realtek. A continuacion le muestro los dos pequeños pasos que hay que realizar para configurar correctamente el video y wifi. Los datos fueron tomados de la instalacion en una Olivetti 520, y resulto ser completamente compatible.

Aclaracion!!!
Las placas de video Sis no poseen soporte para los efectos 3d en linux debido a que el procesamiento de dichos efectos esta basado en software... y adivinen en que?... si, en Direct-x. Por lo tanto NO SE PODRAN HABILITAR LOS EFECTOS GRAFICOS. Esto es un problema de SIS que no da soporte, no de linux.


No detecta mi placa Wireless (Realtek 8187B)

Obtenemos los drivers adecuados de la placa y los compilamos. Te recomiendo que lo hagas igual, aunque ya ubuntu te detecte la placa wireless.

Bajamos el archivo del siguiente link. Debes estar registrado en Ubuntuforums. Sino, te registrasy creas tu usuario; es facil y rapido.
http://ubuntuforums.org/attachment.php?attachmentid=111328&d=1240801314
Es mas que obvio que si no tenemos para conectarnos por cable, lo bajamos de un ciber o la casa de un amigo y luego lo pasamos a nuestra notebook.

Luego nos situamos en la carpeta donde bajamos el driver y tipeamos en una terminal:
tar -xvvzf rtl8187B_linux_26.1052.0225.2009.release.tar.gz
cd rtl8187B_linux_26.1052.0225.2009.release
make
sudo make install

luego reiniciamos linux
sudo reboot

Si ubuntu cuando lo instalastes te habia detectado la placa wireless no prosigas. Si seguis sin que te la detecte segui leyendo:
Luego volvemos al directorio rtl8187B_linux_26.1052.0225.2009.release y tipeamos
sudo ./wlan0up

y listo. Ya tenemos nuestra placa habilitada.

para verificar esto comprobemos que existe wlan0 en el iwconfig
iwconfig

AGREGADO:
Ahora para eliminar el problema de la perdida de conexion por la distancia, ver el siguiente Post:

http://www.taringa.net/posts/linux/2138446/Soluci%C3%B3n-Placa-wifi-rtl8187b-en-Ubuntu.html

Problemas con el Video (SiS 671)

Baja resolución, bajo rendimiento y colores del video.
Hay que instalar el driver correspondiente para la distribución de Ubuntu que tengamos. Para Ubuntu 9.04, tan sencillo como descargar los drivers de la SiS671 desde aca:

http://launchpadlibrarian.net/24529643/xorg-driver-sis671_0.9_i386.deb

Una vez que lo bajamos le damos doble clic y lo instalamos.
Luego reconfigurar el xorg. Para eso abrimos una Terminal (Aplicaciones -> Accesorios -> Terminal). En la linea de comandos escribimos lo siguiente:

$ sudo dpkg-reconfigure -phigh xserver-xorg

Nos pedira la contraseña del usuario. La ingresamos.

Reiniciamos la pc. Podemos hacerlo desde la misma Terminal (escribir: sudo reboot).

Listo!. Cuando iniciemos nuevamente tendremos una hermosa resolución de pantalla.


Espero que sea de ayuda! Este es mi granito de arena.

Saludos!!

Fuente: http://www.guia-ubuntu.org/index.php?title=Olivetti_520