Solucion instalar GeForce 6150SE & nForce 430 en ubuntu

Solucion instalar GeForce 6150SE & nForce 430 en ubuntu



Este es un sencillo, pequeño pero jugoso tutorial para instalar la tarjeta gráfica
NVIDIA(R) GeForce 6150SE & nForce 430 en Ubuntu


Vamos manos a la Obra, primero que todo antes de bajar las X para que nos quede mas facil debemos bajar el Driver propio de nVidia:



Ese lo bajamos de esta pagina:



http://www.nvidia.es/object/linux-display-ia32-256.44-driver-es.html



Lo guardamos para que nos quede mas fácil en el Home de nuestra cuenta en mi caso /home/jhosman



Ahora vamos a desinstalar el nouveau para que no tengamos los conflictos que yo tuve al descubrir como es que se instala y todo sea mucho mas fácil:



Abrimos la terminal y le damos:



sudo apt-get --purge remove nvidia-*
sudo apt-get --purge remove xserver-xorg-video-nouveau



Ahora vamos a añadir el nouveau a la Blacklist para que en el próximo o próximos arranques no se nos monte al inicio:



sudo gedit /etc/modprobe.d/blacklist.conf



Y al final añadimos las siguientes lineas:



blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv



Aqui vamos a bajar las X te recomiendo que de aqui en adelante anotes los pasos en una hoja aunque son bastante sencillos...



sudo service gdm stop



Después de haber bajado las X vamos a presionar Ctrl+ALt+F1 para abrir una terminal, iniciamos sesión y reiniciamos el compu



sudo reboot



Despues de haber reiniciado procedemos con la instalación del Driver, iniciamos sesión en modo sin X y le damos



sudo chmod 777 -R NVIDIA-Linux-x86-256.44.run (en mi caso este es el driver, escribe el que hallas bajado)



Ahora vamos a instalar



sudo sh NVIDIA-Linux-x86-256.44.run



Seguimos lo que nos diga el instalador y listo después de haber terminado seguramente te preguntara que si deseas guardar el archivo de configuración dale para que lo haga.



Ahora vamos a subir las X



sudo service gdm star



Valla!!! ya tenemos la resolución de la pantalla como debe ser con aceleración Gráfica y todo, ahora vamos a generar nuestro xorg.conf para en el futuro no tener problemas, vamos a Sistema>Preferencias>Monitores, nos saldrá un Aviso le damos que SI deseamos usar el gestor de nvidia.



Ahora vamos a donde dice "X Server Display Configuration"



Le damos "Save to X Configuration File"



Ahora "Show Privew"



Copiamos el texto que nos salga todas las lineas, después en la terminal tecleamos



sudo gedit /etc/X11/xorg.conf



Pegamos el texto que nos dio nVidia Server y guardamos.



Hemos Terminado!



Si no estoy mal supongo este proceso es idéntico para las siguientes tarjetas nVidia.



GeForce 400 series:
GTX 470, GTX 480
GeForce 300 series:
GT 340, GT 330, GT 320
GeForce 300M series:
310M, GTS 250M, GT 330M, GTS 350M, GT 335M, GTS 360M, 305M, GT 325M
GeForce 200 series:
GT 230, GT 240, GTX 295, GTX 275, GTS 250, 205, GTX 260, GTX 285, GTS 240, 210, G210, GTX 280, GT 220
GeForce 200M series:
GTX 285M, G210M, GT 230M, GT 220M, GTX 260M, GTS 260M, GT 240M, GTX 280M
GeForce 100 series:
GT 130, GT 140, G 100, GT 120
GeForce 100M series:
G 102M, GT 130M, G 105M, G 110M, G 103M, GT 120M
GeForce 9 series:
9600 GS, 9400, 9800 GX2, 9600 GT, 9400 GT, 9300 GE, 9200, 9500 GT, 9300, 9800 GTX/GTX+, 9300 SE, 9600 GSO 512, 9100, 9800 GT, 9500 GS, 9600 GSO, 9300 GS
GeForce 9M series:
9400M G, 9300M GS, 9800M GS, 9700M GTS, 9700M GT, 9500M GS, 9800M GT, 9600M GT, 9500M G, 9200M GS, 9800M GTX, 9800M GTS, 9600M GS, 9650M GT, 9300M G, 9400M, 9650M GS, 9100M G
GeForce 8 series:
8800 GTX, 8800 GTS 512, 8500 GT, 8400, 8300, 8800 GT, 8400 GS, 8100 / nForce 720a, 8200 / nForce 730a, 8600 GTS, 8300 GS, 8800 Ultra, 8600 GS, 8800 GTS, 8400 SE, 8800 GS, 8600 GT, 8200
GeForce 8M series:
8400M GS, 8200M G, 8400M G, 8800M GS, 8700M GT, 8400M GT, 8800M GTX, 8600M GT
GeForce 7 series:
7800 GTX, 7550 LE, 7300 SE / 7200 GS, 7050 / NVIDIA nForce 630i, 7300 GT, 7150 / NVIDIA nForce 630i, 7600 GT, 7950 GX2, 7900 GS, 7600 GS, 7025 / NVIDIA nForce 630a, 7600 LE, 7650 GS, 7500 LE, 7800 GS, 7100 GS, 7100 / NVIDIA nForce 630i, 7350 LE, 7900 GT/GTO, 7950 GT, 7900 GTX, 7300 LE, 7100 / NVIDIA nForce 620i, 7800 SLI, 7050 PV / NVIDIA nForce 630a, 7050 / NVIDIA nForce 610i, 7300 GS
GeForce Go 7 series:
Go 7800 GTX, Go 7950 GTX, Go 7900 GTX, Go 7900 GS
GeForce 6 series:
6600, 6100 nForce 405, 6800 GS/XT, 6100 nForce 420, 6500, 6200 LE, 6100 nForce 400, 6700 XL, 6200 A-LE, 6200 TurboCache, 6600 GT, 6150 LE, 6150SE nForce 430, 6600 VE, 6200, 6800, 6610 XL, 6150, 6600 LE, 6800 Ultra, 6800 XT, 6800 GT, 6800 GS, 6800 XE, 6800 LE, 6150LE / Quadro NVS 210S, 6250, 6100, 6200SE TurboCache
Quadro FX series:
FX 5600, FX 350, FX 4500, FX 4000, CX, FX 3400/4400, FX 5500, FX 3500, FX 1400, FX 1500, FX 4500 X2, FX 4800, FX 4600, FX 370, FX 580, FX 5800, FX 1800, FX 560, FX 550, FX 1700, FX 3700, FX 4700 X2, FX 570, FX 3800, FX 540, FX 3450, FX 370 Low Profile, FX 380
Quadro FX Notebook series]
FX 3600M, FX 570M, FX 2700M, FX 1700M, FX 360M, FX 1600M, FX 370M
Quadro NVS series:
NVS 285, NVS 420, NVS 295, NVS 450, NVS 280, NVS 440, NVS 210, NVS 290
ION series:
ION
GPU Computing Processor series:
Tesla C1060


Este manual no es mio solo lo encontré y lo puse para el que lo necesite.... pero esto me saco de la pesadilla de no tener tarjeta gráfica en linux ubuntu, fue lo único que me funcionó, yo tengo una 6150se, lo único que si les puedo decir con seguridad es que cuando tienes dos sistemas operativos en el mismo pc, al abrir el otro SO (al menos en mi pc) esto causaba el pantallazo negro del modo terminal... la solución que encontré fue antes de pasar al otro sistema operativo, ir a sistema> preferencias> apariencia>efectos visuales> y marcar la casilla de ninguno.... y ahí si entrar al otro sistema operativo... (yo tengo W7) y cuando no lo necesite mas... iniciamos en ubuntu y ponemos de nuevo los efectos visuales que queramos.

Sí por alguna razón se quedan en el modo terminal (después de haber todo lo de este manual), tranquilos, simplemente reinstalen el driver desde modo terminal, osea..... vuelven a ejecutar el .run que se bajaron desde Nvidia desde el modo terminal.... y vuelven a seguir los pasos de instalación que hay en este manual.



El contenido original está en:

http://jhosman.com/documentacion-ubuntu/hardware/70-instalar-driver-de-la-tarjeta-grafica-nvidiar-geforce-6150se-a-nforce-430-en-ubuntu.html

18 comentarios - Solucion instalar GeForce 6150SE & nForce 430 en ubuntu

@quartiz -2
Por eso no uso Linux
@Kingreil +1
Jajaj, hablas como si instalaras drivers todos los dias
quartiz dijo:Por eso no uso Linux
@gonza_212
quartiz dijo:Por eso no uso Linux

Si no usas Linux, ¿para qué entrás??
@CHIPI -1
quartiz dijo:Por eso no uso Linux


Las placas se instalan automáticamente con cualquier distribución más o menos moderna, sin usar tutoriales. Hablo incluso del caso citado en este tutorial.
@krafty +1
mmmmmmmmmmmmmm..........

Mas facil:

1 -Vas a modo consola CTRL+F1 e ingresas como root
2 - matas al servidor grafico: #>init 3[/b]
3 - instalas el driver: #>sh NVIDIA-Linux-x86-256.44.run
4 - editas el archivo: /etc/X11/xorg.conf
y cambias con que driver va arrancar el servidor X:
donde dice Driver camvias nouveau por nvidia

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"


5 - por ultimo arrancas en modo mutiusuario: #> init 5

y listo el pollo..........
@narosky
sudo gedit /etc/X11/xorg.cong esta linea esta mal es

sudo gedit /etc/X11/xorg.conf
@CHIPI
fgranda dijo:muucho ignoraaaaaamusssss

CHIPI dijo:
quartiz dijo:Por eso no uso Linux


Las placas se instalan automáticamente con cualquier distribución más o menos moderna, sin usar tutoriales. Hablo incluso del caso citado en este tutorial.


los drivers de graficos son drivers privativos y que siempre estan cambiando.... linux te manda sugerencias de drivers pero esto no quiere decir que sean los correctos. "si no sabes linux viene con un driver grafico por defecto que no permite aceleración gráfica.. " y hay que bajar el original de la placa para poder acelerar..


pero en fín..

gonza_212 dijo:
quartiz dijo:Por eso no uso Linux

Si no usas Linux, ¿para qué entrás??


Muy de acuerdo..


No estoy desacreditando tu post para instalar un driver, le estoy diciendo al usuario que si no quiere no necesita hacer eso porque la distribución de GNU/Linux se lo instala ya que si no aclarás eso parece que después de instalar el S.O es necesario instalar las cosas con comandos que a la gente le producen alergia. Con respecto al driver, linux trae el driver por defecto pero te descarga del repositorio el propietario así que nada de comandos para lograr un buen resultado salvo que instales un driver abierto hecho por terceros y que no esté en el repositorio.
@SeAgradece
Lo voy a probar! Si anda van los 10!
Gracias!

CHIPI dijo:
fgranda dijo:muucho ignoraaaaaamusssss

CHIPI dijo:
quartiz dijo:Por eso no uso Linux


Las placas se instalan automáticamente con cualquier distribución más o menos moderna, sin usar tutoriales. Hablo incluso del caso citado en este tutorial.


los drivers de graficos son drivers privativos y que siempre estan cambiando.... linux te manda sugerencias de drivers pero esto no quiere decir que sean los correctos. "si no sabes linux viene con un driver grafico por defecto que no permite aceleración gráfica.. " y hay que bajar el original de la placa para poder acelerar..


pero en fín..

gonza_212 dijo:
quartiz dijo:Por eso no uso Linux

Si no usas Linux, ¿para qué entrás??


Muy de acuerdo..


No estoy desacreditando tu post para instalar un driver, le estoy diciendo al usuario que si no quiere no necesita hacer eso porque la distribución de GNU/Linux se lo instala ya que si no aclarás eso parece que después de instalar el S.O es necesario instalar las cosas con comandos que a la gente le producen alergia. Con respecto al driver, linux trae el driver por defecto pero te descarga del repositorio el propietario así que nada de comandos para lograr un buen resultado salvo que instales un driver abierto hecho por terceros y que no esté en el repositorio.


no siempre! no sé por qé será, pero por más que en las versiones anteriores de Ubuntu siempre me salía el driver privativo en la parte de Hardware, pero ahora tengo instalado Xubuntu 10.10 y no sale en ningún lado, ya intenté de todo y nada funcionó. Vamos a ver si estos pasos me funcionan...
@RicardoMP
Es bastante mas fácil.

ctr+alt+F1 y logueas con cualquier user

sudo telinit 3
sudo sh NVIDIA-loquecorresponda (en mi caso NVIDIA-Linux-x86_64-260.19.21.run) y le das a todo que si.
sudo shu*** -r now

Y listo, no hay que editar nada, el instalador ya edita los archivos de configuración necesarios y des-instala el driver viejo.

Salu2.
@SeAgradece
Con la explicación del post al menos pude instalar el driver, con las de krafty y RicardoMP no me dejó. Pero de cualquier manera me parece que mi xubuntu está en contra de los drivers de nvidia, porque por mas que lo pude instalar, me pasó lo mismo que cuando instalé los de los repositorios, chau interfaz gráfica. después hice un mix entre lo del post y lo de krafty pero tampoco funcionó, eso pareció ser un paso más adelante, porque al menos cargaba la pantalla de bienvenida, pero ahí se colgaba la computadora y no me quedaba otra que reiniciar. así que por ahora seguiré sin el driver... gracias a todos igual por las sugerencias!
@RicardoMP
Es raro, yo lo hago así y lo mas bien siempre, de echo uso el mismo método tanto en Ubuntu como en Archlinux y me funciona de pelos, la única diferencia es que en ubuntu uso el driver de 32 y en Arch el de 64.

Tal vez tengas algún conflicto por un driver mal instalado o algo así, podes probar haciendo una desisntalacion de todos los drivers anteriores a mano y luego recién ahí instalar los nuevos.

seria interesante saber que error te tira para poder ver la solución.

Salu2.
@SeAgradece
RicardoMP dijo:Es raro, yo lo hago así y lo mas bien siempre, de echo uso el mismo método tanto en Ubuntu como en Archlinux y me funciona de pelos, la única diferencia es que en ubuntu uso el driver de 32 y en Arch el de 64.

Tal vez tengas algún conflicto por un driver mal instalado o algo así, podes probar haciendo una desisntalacion de todos los drivers anteriores a mano y luego recién ahí instalar los nuevos.

seria interesante saber que error te tira para poder ver la solución.

Salu2.


Sí, es rarísimo, de hecho en Ubuntu nunca tuve problemas...
Pero en Xubuntu, algún problema hay, porque no me aparece (como supongo que debería) en "Controladores adicionales" el de nVidia. En Ubuntu, aunque no lo instales te aparece ahí, pero acá no me aparece nada en la lista, como si no hubiera controladores de nVidia para mi placa.
Probé desinstalando todo y ahí se instala perfecto el driver, pero cuando va a iniciar xubuntu por primera vez no me tira ningún error, simplemente entra como si hubiera apretado Ctrl+Alt+F1 (o sea, me pide usuario y contraseña sin entorno gráfico).
Si no edito más nada, siempre inicia xubuntu así. Si edito el xorg.conf siguiendo a krafty, es como que empieza a cargar xubuntu pero se cuelga en la pantalla de bienvenida (un cartelito que dice xubuntu) y no sé cómo hacer para ver cuál es el error. Supongo que estará en la parte de logs pero no tengo idea...
Igual más o menos me arreglo.
Gracias
@rastune
hola yo tengo esta placa y o sea la maquina me funciona youtube y algun q otro juego pero no logro tener buen rendimiento.. se me ven cortados hasta los juegos flash.. no se porque sera.. ni contar los videos que se ven todos cortados.. alguien tiene alguna idea?¿ ya cambie los drivers... y esto en el vista no me pasa
@slavebender
a mi me pasaba lo mismo... lo que pasa es que tienes que habilitar el triple buffering , si tienes nvidia en agrega esta linea al archivo xorg.conf buscas donde diga Section device y agregas esto Option "TripleBuffer" "true" con esto deberia de dejarte de pasar eso, otro detalle es que si tu video es integrado y activas los efectos avanzados del escritorio te pasara lo mismo te sugiero que los desactives.
@_UnderGraund_
como bajo las x?? me treabe en esa parte alguien me ayuda ???
@elmateador
Esto creo que es nuevo ya que actualicé a la última versión de este momento (Abril 2014) Vers. 14.04 y con esta misma placa, la solución planteada en este post no me anduvo. Les mando los pasos a seguir para lograrlo en la versión de 64 bits.
Iniciamos una consola (Ctrl+alt+F1) y vamos haciendo ejecutar los siguientes comandos:

1.- Agrego a repositorios (para versión de 12.10 hasta 14.04)
sudo apt-add-repository ppa:xorg-edgers/ppa

2.- Actualizo
sudo apt-get update

3.- Instalamos
sudo apt-get install nvidia-current nvidia-settings

Si tengo versión de 10.04 hasta 12.04 usar esto en el punto 1.-
sudo apt-add-repository ppa:ubuntu-x-swat/x-updates

Suerte y disfruten de este grandioso SO.
@alito0723
Este metodo funciono a la perfeccion muchas gracias por el aporte!!!