solucion Webcam no funciona en sitios como Chatroulette

solucion Webcam no funciona en sitios como Chatroulette


Algunos usuarios han manifestado problemas para entrar en Chatroulette,justin tv, etc en Ubuntu y Linux en general debido a Flash.
En fin, a lo que vamos. Muchos usuarios han manifestado problemas. Básicamente lo que sucede es que al entrar en *** u otra de ese tipo se encuentran que la web, basada en Flash, les pide permiso para acceder a su webcam pero por más que aceptan no es posible.


solucion



La solución es simple:

1. Entramos en este http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager06.html
2. Aquí buscamos de la lista la web que nos interese, en nuestro ejemplo chatroulette.

Como


Y cambiamos las propiedades tal como se muestra en la siguiente captura:


funciona





Reiniciamos nuestro navegador y ahora debería funcionar. Este truco es perfectamente válido para muchos otros sitios donde esto pueda suceder. Y ahora permitirme insistir en el punto indicado más arriba. Navegad con precaución

NOTA:si eres usuario archlinux debes hacer esto antes
agregar tu usuario a el grupo de video:


# gpasswd -a <username> video

Y establece los permisos necesarios:


# chmod 666 /dev/video0

fuente:http://www.ubuntizandoelplaneta.com/2010/06/webcam-no-funciona-en-chatroulette.html
link original a peticion del compa MukenioArg, cualquier peticion o duda hagan un cometario.

18 comentarios - solucion Webcam no funciona en sitios como Chatroulette

@MukenioArg
illuminaty dijo:tengo que aclarar que opciones libres de flash como Gnash, F4L, UIRA, Ktoon, y Qflash no lo he probado no se cual estas usando

Uso el flash de adobe, lo probe en arch y en lmde y nada. La camara porque la he probado con vlc y funciona. En el articulo original hay un comentario de otro usuario que usa arch y tampoco le funciona.

P.D: Recomiendo que coloques un link al post original asi se puede ir directamente a la fuente
@MukenioArg
illuminaty dijo:no teda imagen o cual es el problema?

Aparece en la lista pero la selecciono y vuelve a &quot;No camera&quot;. Tengo todo actualizado en ambos sistemas y uvcvideo es un modulo que ya viene incorporado en el kernel, lo cargue a mano y nada. Igual no importa, te agradezco el interes
@tangato
MukenioArg dijo:
illuminaty dijo:no teda imagen o cual es el problema?

Aparece en la lista pero la selecciono y vuelve a &quot;No camera&quot;. Tengo todo actualizado en ambos sistemas y uvcvideo es un modulo que ya viene incorporado en el kernel, lo cargue a mano y nada. Igual no importa, te agradezco el interes

qué estraño... y si hacés un wrapper para firefox con uvcvideo?

LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so firefox
@ICE_U
lo probare a mi se me tilda la camara y toda la pc cuando le doy en preview
@feican
En esta funciona che SEECAM.TK
@OBM2011 +1
no se ven las imagenes del post