Este post lo hago porque me costó una barbaridad encontrar solución al siguiente problema:

Usando el Sonar y/o guitar rig con una guitarra conectada con un plug al line in, se escucha MUCHO ruido, constante, haciendo imposible tocar, escucharse y mucho menos grabar.
La cuestión es que la entrada line in funcionaba perfecto sin utilizar estos programas.

En caso que alguien tenga el mismo problema y ya no sepa que hacer, he aquí una posible solución efectiva y simple:

para Win XP:

1) doble click en el ícono del parlantito
Problemas audio ruido Sonar y Guitar Rig

2) se abre esta ventana
guitar rig

3) hacer click en "Options" u "Opciones" y en el menú que se despliega hacer click en "Properties" o "Propiedades"
ruido

4) Se abrirá la siguiente ventana
problema audio

5) Ir al menú desplegable en "Mixer Device" o "Dispositivo Mezclador" y seleccionar el dispositivo que diga "input". Hacer click en OK.
audio ruido

6) Por último se abre esta ventana, acá tildamos la casilla de "Mute" en "Stereo Mix", así lo deshabilitamos.
sonar problema

Bien eso es todo, a disfrutar del Sonar + Guitar Rig!!

En caso que se pregunten y por que deshabilitamos el Mezclador Estereo? pues bien, lo que se hizo en estos pasos es deshabilitar el Estéreo SOLO PARA GRABAR por line in (y el mic claro), puesto que la mayoría de los cables plug son MONO, por alguna razón al menos en mi pc entra en conflicto y sale ese ruido que me imposibilitó tocar y grabar.

Espero que haya ayudado a alguien con esto ya que darme cuenta de esta simple solución me llevó mucho tiempo de lectura en foros, faqs y tutoriales y NADA me sirvió, hasta que se me ocurrió probar esto y funcionó