Check the new version here

Popular channels

Como obtener un numero faltante en excel

Amigos exceleros, en esta oportunidad vamos a crear una formula que me permita mostrar un numero faltante de una lista de excel.
Cabe señalar que en la lista solo debería haber un numero faltante para que la formula muestre ese numero. Eso quiere decir que si en la lista faltan 2 o mas números, la formula no funcionara.

Comencemos:
En la columna A tenemos una lista de números correlativos, y podemos ver a simple vista que falta el numero 10.



Para poder analizarlo mejor hemos creado las formulas en varias celdas:

C2: =CONTAR(A2:A6)+1


Con esta formula mostramos la cantidad de filas + 1

D2: =(MAA2:A6)+MIN(A2:A6))/2


Aqui el calculo se realiza sumando el numero maximo con el numero minimo y dividiendolo entre 2

E2: = SUMA(A2:A6)


Se obtiene la suma de los numeros de la columna A

F2: =(C2*D2)-E2


El calculo para obtener el numero faltante se realiza multiplicando los resultados de la celda C2 y D2 y restandole la suma total.

Por ultimo, si deseamos poner toda la formula en una sola celda simplemente tenemos que hacer la formula anidada y quedara de la siguiente manera:

=((CONTAR(A2:A6)+1)*(MAA2:A6)+MIN(A2:A6))/2)-SUMA(A2:A6)


De esta manera igual podra mostrar el mismo resultado,

Espero les haya sido de mucha utilidad.
0
0
0
0
0No comments yet
      GIF
      New