epelpad

Ejercicios y sus resultados con pseint

PSeInt


Te recomiendo pseint para que empieces a programar, les dejo seudocodigos de pseint


Trabajo Practico Nº1


Describir a través de un condicional el ingreso del mes del año.

EJERCICIO 1. A través de este ejemplo, diseñar un pseudocódigo que permita calcular áreas y perímetros (utilizando cualquier valor de entrada). Tener en cuenta que sucede si uno de esos valores es cero, pensar que debe siempre ser un numero > a cero no igual.

Ejercicios y sus resultados con pseint


Proceso Ejercicio1
Escribir "Lado1"
Leer lado1
Escribir "Lado2"
Leer lado2
Escribir "El perimetro del rectángulo es:"
Si lado1>0 y lado2>0 Entonces
Escribir lado1*2+lado2*2
Sino
Escribir "Imposible calcular"
Fin Si
Escribir "Y el área del rectangulo es:"
Escribir lado1*lado2
Escribir "Ahora calcular el perimetro del triángulo"
Escribir "Lado 1"
Leer lado1
Escribir "Lado 2 "
Leer lado2
Escribir "Lado 3"
Leer lado3
Escribir "El perimetro de este triángulo es:"
Si Lado1=lado2 y lado2=lado3
Entonces
Escribir 3*lado1
Escribir "Es un triangulo equilatero"
Sino
Si lado1=lado2 y lado2!=lado3 Entonces
Escribir 2*lado1+lado3
Escribir "Es un trianguolo isoceles"
Sino
Escribir lado1+lado2+lado3
Escribir "Es un triangulo escaleno"
Fin Si
Fin Si
//Una vez averiguado que clase de triangulo es y los datos de los lados habremos sacado la base y la altura.
Escribir "Calcular el área del triangulo"
Escribir "Escribe la base"
Leer base
Escribir "Escribe la altura"
Leer altura
Escribir "El area es igual a"
Escribir (base*altura)/2
FinProceso

EJERCICIO 2. Diseñar un algoritmo según los siguientes datos: Un terreno rectangular de xx metros de ancho por xx metros de largo se quiere cercar con 3 vueltas de alambre de púas. ¿Cuántos metros de alambre se necesitan para cercar el terreno? Tener en cuenta que los valores que ingresa el usuario es > a cero y puede ser decimal.

Proceso Ejercicio2
result<-(a*2+l*2);
Escribir "Ingrese el ancho del terreno"
Leer a
Escribir "Ingrese el largo del terreno"
Leer l
Si a>0 y l>0 Entonces
Escribir "La cantidad de metros de alambre que se necesita es:"
Escribir (a*2+l*2)*3;
Sino
Escribir "Los datos son errones"
Fin Si
FinProceso


EJERCICIO 3. Diseñar un algoritmo según los siguientes datos: Un piso de xx metros por xx metros se debe cubrir con baldosas de cerámicas. ¿Cuántas baldosas se necesitan si se sabe que 16 baldosas cubren 1 m2?

Proceso Ejercicio3
Escribir "Escribe el ancho del piso"
Leer a
Escribir "Escribe el largo del piso"
Leer b
Si a>0 o b>0 Entonces
Escribir "Los metros totales son"
Escribir a+b
Escribir "La cantidad de baldosas que se tienen que utilizar son"
Escribir (a+b)*16
Sino
Escribir "Las baldosas son imposibles de colocar"
Fin Si
FinProceso


EJERCICIO 4. Diseñe un algoritmo para hallar el mayor de 3 números.

Proceso Ejercicio4
Escribir "Escriba el primer valor"
Leer a
Escribir "Escriba el segundo valor"
Leer b
Escribir "Escriba el tercer valor"
Leer c
Si a>b y a>c Entonces
Escribir "El mayor valor es:" a
Sino
Si b>a y b>c Entonces
Escribir "El mayor valor es:" b
Sino
Escribir "El mayor valor es:" c
Fin Si
Fin Si
FinProceso


EJERCICIO 5. Diseñar un algoritmo para hallar el aumento al sueldo de un empleado; si el sueldo es mayor a $500.000 su aumento será del 12%, pero si su sueldo es menor El aumento será del 15%. (Debe mostrar cuanto es su sueldo según el %).

pseint


Proceso Ejercicio5
Sal<-"s"
Mientras Sal="S" o Sal="s"
Escribir "Calcular el aumento del sueldo de un empleado";
Escribir "Ingrese el sueldo actual";
Leer Sueldo;
Si Sueldo>500000 Entonces
Aumento=12;
Sino
Aumento=15;
Fin Si
NSueldo=Sueldo+(Sueldo/100)*Aumento
Escribir "El Aumento es del: ",Aumento, "%";
Escribir "Cobra: ",NSueldo;
Escribir "Desea calcular otro sueldo? (S/N) "
Leer Sal
Fin Mientras
FinProceso

Ejercicio 6. Diseñe un algoritmo donde pueda utilizar las siguientes sentencias

Proceso Ejercicio6
Escribir "El número es: Positivo, Negativo o Neutro?";
Sal<-"s"
Mientras Sal="S" o Sal="s"
Escribir "Ingrece el Número"
Leer N
Si N>0 Entonces
Escribir "Es Positivo"
Fin Si
Si N<0 Entonces
Escribir "Es Negativo"
Fin Si
Si N=0 Entonces
Escribir "Es Neutro"
Fin Si
Escribir "Desea saber otro número? (S/N)"
Leer Sal
Fin Mientras
FinProceso

Trabajo Practico Nº2


EJERCICIO 1. USO DE OPERADORES LOGICOS
(Con este programa podrás saber si el número en el que pensás está en el rango establecido o no. Rango: 35 a 50 ó 65 a 90.)

Proceso Ejercicio1
Sal<-"s"
Mientras Sal="S" o Sal="s"
Escribir "Con este programa podrás saber si el número en el que pensás está en el rango establecido o no. Rango: 35 a 50 ó 65 a 90. ";
Escribir "Ingrese el número pensado: ";
leer a;
si a>=35 y a<=50 o a>=65 y a<=90 Entonces
Escribir "El numero esta dentro del rango establecido"
Sino
Escribir "El numero no esta dentro del rango establecido"
FinSi
Escribir "Desea saber otro número? (S/N) "
Leer Sal
Fin Mientras
FinProceso

EJERCICIO 2. EXPRESIONES COLOQUIALES
(Con este programa sabrás fácilmente si el número en el que pensás es par o impar.
Pequeño margen de error, al ingresar números grandes.)

Proceso Ejercicio2
Sal<-"s"
Mientras Sal="S" o Sal="s"
Escribir "Con este programa sabrás fácilmente si el número en el que pensás es par o impar.";
Escribir "Pequeño margen de error, al ingresar números grandes.";
Escribir "Ingrese el número que estas pensando:";
leer a;
si a mod 2=0 Entonces
Escribir "El número es par"
Sino
Escribir "El numero es impar.";
FinSi
Escribir "Desea saber otro número? (S/N)"
Leer Sal
Fin Mientras
FinProceso

EJERCICIO 3. EXPRESIONES COLOQUIALES
AGREGAR ESPACIOS ENTRE NOMBRES Y EDAD DE LA PERSONA
(Con ayuda de este programa te diré cuál es tu nombre completo.)

Proceso Ejercicio3
Escribir "Con ayuda de este programa te diré cuál es tu nombre completo.";
Escribir "Cual es tu primer nombre?";
leer nom;
Escribir "Cual es tu segundo nombre?";
leer snom;
Escribir "Cual es tu primer apellido?";
leer ape;
Escribir "¿Cuál es tu edad?";
leer edad;
Escribir "Tu nombre completo es:" nom," " snom," " ape," " edad
Fin Proceso

EJERCICIO 4. Consonantes y vocales
(Con este programa sabrás si la letra que escribes es consonante o vocal.)

Proceso Ejercicio4
Sal<-"s"
Mientras Sal="S" o Sal="s"
Escribir "Con este programa sabrás si la letra que escribes es consonante o vocal. "
Leer letra
Si letra ="a" O letra="e" o letra= "i" o letra ="o" O letra="u" O letra="A" O letra="E" O letra="I" O letra="O" O letra="U" o letra=" " Entonces
Escribir "La letra es vocal"
Sino
Escribir "La letra es consonante"
Fin Si
Escribir "Desea saber otra letra? (S/N)"
Leer Sal
Fin Mientras
FinProceso

EJERCICIO 5. Crear una calculadora

Proceso Ejercicio5
num1 <-0
num2<-0
op<-0
result<-0
Sal<-"s"
Mientras Sal="S" o Sal="s"
Escribir "Calculadora"
Escribir "Ingrese primer número"
Leer num1
Escribir "Ingrese segundo número"
Leer num2
Escribir "Que operacion desea útilizar?"
Escribir "1 Sumar";
escribir "2 Restar";
escribir "3 Multiplicar";
escribir "4 Dividir";
Leer op;
Si op=1 Entonces
result<-num1+num2
Sino
si op=2 Entonces
result<-num1-num2
Sino
si op=3 Entonces
result <- num1*num2
sino
si op=4 Entonces
result<-num1/num2
Sino
Escribir "Operacion Incorrecta"
FinSi
FinSi
FinSi
FinSi
Escribir "El resultado de su operacion es: " " " result;
Escribir "Desea saber otro número? (S/N)"
Leer Sal
Fin Mientras
FinProceso

ACTUALIZADO 8/10/2014

Trabajo Práctico Nº3


EJERCICIO 1. En este ejercicio corregir el ingreso de las notas para que estas estén dentro de los valores correspondientes (1 al 10). También indicar el nombre de la materia, y que se pueda hacer el cálculo del promedio para 3 materias, y el ingreso de notas sean 3 (Trab-pract, evaluación y concepto).

Proceso Ejercicio1
Sal<-"s"
Mientras Sal="S" o Sal="s" Hacer
Escribir "Ingrese el nombre y apellido";
Leer a;
Escribir "Ingrese el nombre de la materia";
Leer m1;
Escribir "Ingrese la nota";
Leer n1;
Escribir "Ingrese el nombre de la materia";
Leer m2;
Escribir "Ingrese la nota";
Leer n2;
Escribir "Ingrese el nombre de la materia";
Leer m3;
Escribir "Ingrese la nota";
Leer n3;
Si n1>=1 y n1<=10 y n2>=1 y n2<=10 y n3>=1 y n3<=10 Entonces
Escribir (n1+n2+n3)/3;
Sino
Escribir "Reescriba las notas" ;
Escribir "Reescriba la materia";
Leer m1;
Escribir "Ingrese la nota";
Leer n1;
Escribir "Reescriba la materia";
Leer m2;
Escribir "Ingrese la nota";
Leer n2;
Escribir "Reescriba la materia";
Leer m3;
Escribir "Ingrese la nota";
Leer n3;
FinSi
Escribir "Desea obtener otro promedio? (S/N) "
Leer Sal
FinMientras
FinProceso

EJERCICIO 2. Uso de Operadores

Proceso Pitágoras
resp<-'s'
mientras resp='S' o resp='s' Hacer
Escribir 'Teorema de Pitágoras';
Escribir 'Ingrese los datos de los Catetos';
Escribir 'El primer cateto a';
Leer a;
Escribir 'El segundo cateto b';
Leer b;
c<-(rc(a^2+b^2))
Escribir 'la hipotenusa es:',c;
Escribir 'Desea calcular otro? (S/N)'
Leer resp
FinMientras
FinProceso


Proceso Ejercicio2
Sal<-"s"
Mientras Sal="S" o Sal="s" Hacer
Escribir "Teorema de Pitágoras";
Escribir "Ingrese los datos de los Catetos";
Escribir "El primer cateto a";
Leer a;
Escribir "El segundo cateto b";
Leer b;
c<-(rc(a^2+b^2))
Escribir "la hipotenusa es:",c;
//esta codificacion permite desidir si ingresa o no otros datos S"si" y N"no"
Escribir "Desea obtener otro valores? (S/N) "
Leer Sal
FinMientras
FinProceso


EJERCICIO 3. Corregir los errores, marcarlos en color. Luego condicionar para que el ingreso del valores no sea = a cero

Proceso areaTriangulo
resp<-'s'
mientras resp='S' o resp='s' Hacer
Escribir 'EL AREA DE UN TRIANGULO;
Escribir 'ingrese el valor de la altura:';
leer altura;
escribir 'ingrese el valor de la base:';
leer base;
si (altura=3) Entonces
a<-(base*altura)/2;
escribir 'resultado:',a;
r=a*b/2
sino
a<-(base*altura)/2;
escribir 'resultado:',a;
FinSi
Escribir 'Desea calcular otro triangulo? (S/N)'
Leer res
FinMientras
FinProceso


Proceso areaTriangulo
resp<-'s'
mientras resp='S' o resp='s' Hacer
//le falta la comilla al terminar triangulo corrección: Escribir 'EL AREA DE UN TRIANGULO';
Escribir 'EL AREA DE UN TRIANGULO;
Escribir 'ingrese el valor de la altura:';
leer altura;
escribir 'ingrese el valor de la base:';
leer base;
//correcion del si (altura=3) seria si (altura>0) y ( base>0)
si (altura=3) Entonces
a<-(base*altura)/2;
escribir 'resultado:',a;
r=a*b/2
sino
a<-(base*altura)/2;
escribir 'resultado:',a;
FinSi
Escribir 'Desea calcular otro triangulo? (S/N)'
// Tiene un error en Leer res tendría que ser: Leer resp para que funcione el comando: Escribir 'Desea calcular otro triangulo? (S/N)'
Leer res
FinMientras
FinProceso


Corrección en psint para que funcione:

Proceso areaTriangulo
resp<-'s'
mientras resp='S' o resp='s' Hacer
Escribir 'EL AREA DE UN TRIANGULO';
Escribir 'ingrese el valor de la altura:';
leer altura;
escribir 'ingrese el valor de la base:';
leer base;
si (altura>0) y ( base>0) Entonces
a<-(base*altura)/2;
escribir 'resultado:',a;
r=a*b/2
sino
a<-(base*altura)/2;
escribir 'resultado:',a;
FinSi
Escribir 'Desea calcular otro triangulo? (S/N)'
Leer resp
FinMientras
FinProceso

Luego condicionar para que el ingreso del valores no sea = a cero

EJERCICIO 4. Uso de REPETIR. Hacer. RECORDAR EL USO DEL MENU PARA PROXIMOS

proceso Menu
c1<-0
c2<-0
c3<-0
max<-0
Repetir
Escribir '*******MENU*******'
Escribir '1........SUMATORIA'
Escribir '2....TIPO CARACTER'
Escribir '0.......PARA SALIR'
Escribir '******************'
Escribir 'INGRESE SU OPCION:'
leer opcion
segun opcion Hacer
1 : c1<-c1+1
Repetir
escribir 'INGRESE N'
Leer n
Hasta Que 0<n
fact<-1
s<-0
para i<-1 hasta n Hacer
s<-s+1/(fact*i)
FinPara
Escribir 'SUMATORIA: ',s
si max < s Entonces
max<-s
FinSi
2 : c2<-c2+1
Escribir 'INGRESE UN CARACTER:'
Leer L
si ('A'<=L) y (L<='Z') Entonces
Escribir L,'ES UNA MAYUSCULA'
Sino
si ('a'<=L) y (L<='z') Entonces
escribir L,'ES UNA MINUSCULA'
sino
si ('0'<=L) y (L<='9') Entonces
escribir L,'ES UN NUMERO'
Sino
Escribir L,'ES OTRO CARACTER'
FinSi
FinSi
FinSi
FinSegun
hasta que opcion=0
escribir 'SE INGRESO POR LA OPCION 1: ',c1,' VECES'
escribir 'SE INGRESO POR LA OPCION 2: ',c2,' VECES'
Escribir 'SE INGRESO POR LA OPCION 3: ',c3,' VECES'
Escribir 'LA MAXIMA SUMATORIA FUE: ',max
FinProceso



Proceso Ejercicio4
Repetir
Escribir "Elige una opcion a ejecutar"
Escribir "1: Suma";
Escribir "2: Resta";
Escribir "3: Multiplicacion";
Escribir "4: Division";
Escribir "5: Salir";
Leer opc;
Segun opc Hacer
1:
Escribir "Ingrese el primer valor";
Leer num1;
Escribir "Ingrese el segundo valor";
Leer num2;
suma<-num1+num2;
Escribir "El resultado de la suma es:", suma;

2:
Escribir "Ingrese el primer valor"
Leer num1;
Escribir "Ingrese el segundo valor"
Leer num2;
resta<-num1-num2;
Escribir "El resultado de la resta es", resta;
3:
Escribir "Ingrese el primer valor"
Leer num1;
Escribir "Ingrese el segundo valor"
Leer num2;
mult<-num1*num2;
Escribir "El resultado de la multiplicacion es", mult;
4:
Escribir "Ingrese el primer valor"
Leer num1;
Escribir "Ingrese el segundo valor"
Leer num2;
division<-num1/num2;
Escribir "El resultado de la division es", division;
FinSegun
Hasta Que opc=5 ;
FinProceso

EJERCICIO 5. Diseñar un pseudocódigo que muestre las horas trabajadas de una persona y el valor por hora. Calcular su salario e imprimirlo. Agregarle información como por ejemplo: datos del empleado, Empresa, cant de horas trabajadas por día, cantidad de horas trabajador por semana, cant de horas trabajadas por mes, etc

Proceso Ejercicio5
Sal<-"s"
dse<-0
dme<-0
Mientras Sal="S" o Sal="s" Hacer
Escribir "Nombre y apellido";
Leer nom
Escribir "Nombre de la empresa";
Leer nomem
Escribir "Tarifa por hora";
Leer tar
Escribir "Número de horas trabajadas por día";
Leer hor
Escribir "Número de días trabajados por semana";
Leer dse
Escribir "Número de días trabajados por mes";
Leer dme
si 7>=dse entonces
hos<-(hor*dse);
Sino
Escribir "Error vuelva a reescribir sus datos"
Escribir "Nombre y apellido";
Leer nom
Escribir "Nombre de la empresa";
Leer nomem
Escribir "Tarifa por hora";
Leer tar
Escribir "Número de horas trabajadas por día";
Leer hor
Escribir "Número de días trabajados por semana";
Leer dse
Escribir "Número de días trabajados por mes";
Leer dme
FinSi
Si 31>=dme Entonces
hom<-(hor*dme);
Sino
Escribir "Error vuelva a reescribir sus datos"
Escribir "Nombre y apellido";
Leer nom
Escribir "Nombre de la empresa";
Leer nomem
Escribir "Tarifa por hora";
Leer tar
Escribir "Número de horas trabajadas por día";
Leer hor
Escribir "Número de días trabajados por semana";
Leer dse
Escribir "Número de días trabajados por mes";
Leer dme
Fin Si
Escribir "El salario por día es:", tar*hor
Escribir "El salario por semana es:", tar*hos
Escribir "El salario por mes es:" , tar*hom
Escribir "Desea saber otro empleado? (S/N) "
Leer Sal
FinMientras
FinProceso


ACTUALIZADO 16/10/2014

Trabajo Practico Nº 4


A) Definición de vector y un ejemplo.

Conjunto ordenado que contiene un nº fijo de elementos (su dimension) de cualquier tipo valido definido con la condición de que todos deben ser del mismo tipo. Son una forma de almacenar datos que permiten contener una serie de valores del mismo tipo, cada uno de los valores contenidos tienen una posición asociada que se usara para accederlos.

B) Buscar como se declara un vector en PSeInt Visual Basic y C++.

Vectores en PSeInt


En programación y/o algoritmos, un vector es una zona de almacenamiento continuo, que almacena serie de elementos del mismo tipo, los elementos del vector. Desde el punto de vista lógico un vector se puede ver como un conjunto de elementos ordenados en fila.

ejercicios PSeint


El anterior ejemplo nos muestra un vector unidimensional de 3 posiciones para almacenar información y la variable se llama datos.

Para declarar un vector en PSeInt se utiliza la palabra reservada Dimension

Ejemplo:

psint


Para almacenar la información en el vector debemos dar el nombre de la variable y la posición en que queremos guardar la información.

Ejemplo:

Ejercicios y sus resultados con


Este ejemplo muestra que el algoritmo define un vector de 3 posiciones y solicita que se ingrese un valor, el cual va a ser almacenado en el vector con nombre, datos y , posición 1.

Ejercicios y sus resultados con pseint


Para poder almacenar datos en un vector se requiere de la sentencia de ciclos Para. Vemos que el vector es de 3 posiciones lo que quiere decir que se necesita un ciclo que inicie en 1 y termine en 3.

Ejemplo:

pseint


Se hace el ciclo 3 veces, pidiendo los datos, como vemos en el anterior ejemplo.

ejercicios PSeint


Si les solicitan imprimir el contenido de la información que tiene el vector de manera inversa a como fue ingresada, se debe tener en cuenta el siguiente procedimiento:

1.Para guardar los datos tuvimos que iniciar el para en 1 y terminar en 3.

psint


2.Si solicitan imprimir la información al contrario de cómo fue ingresada al vector. Debemos comenzar por la posición 3 y terminar en la posición 1.

Vectores en Visual Basic


Un vector no es más que un conjunto de variables consecutivas en memoria y del mismo tipo guardadas dentro de un variable contenedor. Tipos de variables y vectores más comunes:

•Variables tipo Char: Estas variables contienen un único carácter, es decir, una letra, un signo o un número.
•Variables tipo Int: Contienen un número entero.
•Variables tipo float: Contienen un número decimal.
•Variables tipo String: Contienen cadenas de texto, o lo que es lo mismo, es un vector con varias variables del tipo Char.
•Variables del tipo Boolean: Solo pueden contener un 0 o un 1. El cero es considerado para muchos lenguajes como el literal "False", mientras que el 1 se considera "True".

Como se declara un vector en Visual Basic 6.0


Formula:

Dim Nombre del Vactor o Matriz (primer valor To ultimo valor) As Tipo De Dato

Ejemplo:

Dim Fila(1 To 5) As Integer

Donde:
Nombre del Vactor o Matriz es Fila
Primer Valor es 1
Ultimo Valor es 5
Tipo de Dato es Integer


Ejercicio:

Escribir un programa en Visual Basic que lea N números, calcule la media aritmética de los mismos y muestre los números leídos que son mayores que la media calculada.

Se debe crear:

1.Command Button
2.TextBox
3.Label
4.ListBox

Te quedaría así:

Ejercicios y sus resultados con

Ejercicios y sus resultados con pseint


Como se declara un vector en Visual Basic 2010


En Visual Basic 2010 la declaración de un array, arreglo o vector la hacemos de la misma forma que en Visual Basic 6.

Vectores en C++


C++ es un lenguaje de programación diseñado por Bjarne Stroustrup. La intención de su creación fue el extender al exitoso lenguaje de programación C con mecanismos que permitan la manipulación de objetos. Desde el punto de vista de los lenguajes orientados a objetos, el C++ es un lenguaje híbrido.

Ejemplo:

Programa C++ que accede y modifica los elementos de un array.
Los elementos de un array se pueden utilizar igual que cualquier otra variable y se puede hacer con ellos las mismas operaciones que se pueden hacer con el resto de variables.

#include <iostream>
using namespace std;
int main ()
{
int n, m = 5;
int a[]={2,8,3,0,4}; //se declara un array de 5 elementos de tipo
//int con esos valores iniciales
n = a[0]; //n = 2
a[0]=a[1]+a[2]; //a[0]= 8 + 3 = 11
a[1]++; //a[1]= 9
a[n]=m+10; //a[2]= 15
a[n+1]=7; //a[3]= 7
if(a[0]>=a[1]) //if(11 >= 9)
a[4]=a[0]; // a[4]= 11
cout << a[0]<<" "<< a[1]<< " "<< a[2]<< " "<< a[3]<< " "<< a[4];
cout << endl;
system("pause";
}

C) ¿Cual es la variable que controla la posición del arreglo?

Una vez definido un array, es muy sencillo acceder a cada uno de sus elementos. Cada elemento se accede indicando su posición dentro del array. La única complicación, que es responsable de muchos errores cuando se empieza a programar, es que las posiciones de los elementos empiezan a contarse en el 0 y no en el 1 ejemplo:

ar diaSeleccionado = dias[0]; // diaSeleccionado = "Lunes"
ar otroDia = dias[5]; // otroDia = "Sábado"

En el ejemplo, la primera instrucción quiere obtener el primer elemento del array. Por eso, se indica el nombre del array y entre corchetes la posición del elemento dentro del array.
Las posiciones se empiezan a contar en el 0, por lo que el primer elemento ocupa la posición 0 y se accede a el mediante dias[0].
El valor dias[5] hace referencia al elemento que ocupa la sexta posición dentro del array dias. Como las posiciones empiezan a contarse en 0, la posición 5 hace referencia al sexto elemento, en este caso, el valor Sábado.

Ejercicio

1) Cargar un vector y que los muestre en orden.

Proceso vectorenorden
Definir v,n,i,j,t,k como entero;
Dimension V[1000];
Escribir "Digite el número de elementos del vector"
Leer n;
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir sin saltar "Digite el vector en su posición", i;
Leer v(i);
Fin Para
//4 1 3 2
//1 4 3 2
//1 3 4 2
//1 2 4 3
//1 2 3 4
Para i<-1 Hasta n Con Paso 1 Hacer
Para j<-i Hasta n Con Paso 1 Hacer
Si V(i) > V(j) Entonces
Escribir "Cambiando ", V(i), " por ", V(j);
t = v(i);
V(i) = V(j);
V(j) = t;
Fin Si
Fin Para
Para k<-1 Hasta n Con Paso 1 Hacer
Escribir "Después del ciclo", i, "el vector queda en posición",k, " = ",v(k);
Fin Para
Para k<-1 Hasta n Con Paso 1 Hacer
Escribir "Finalmente el vector queda en posición",k, " = ",v(k);
Fin Para
Fin Para
FinProceso

2) Se solicita que el usuario ingrese un número y el algoritmo verifique que el valor ingresado existe en el vector. Dado el caso de existir se debe indicar la posición en el que se encuentra.

Proceso Vectorposicion
Dimension V[10];
n<-6
escribir "La dimension del vector es: ",n
Escribir "Digite los número de elementos del vector"
Para i<-1 Hasta n Con Paso 1 Hacer
Escribir sin saltar "Digite el vector si es posicion", i;
Leer V(i);
finpara
Escribir "Ingrese número a buscar "
Leer j
Para i<-1 hasta n con paso 1 hacer
si j=V(i) entonces
Escribir "El valor está guardado en la posición " ,i
FinSi
FinPara
FinProceso


3) Desarrollar un algoritmo que permita almacenar los DNI y apellido de diez estudiantes. El usuario debe ingresar un numero de DNI a buscar en el vector y el algoritmo debe mostrar el apellido que corresponde al numero de DNI ingresado.

Proceso base1
Dimension A[10,2]
salida="S"
salida1="S"
escribir "Programa para cargar DNI y nombre de 10 alumnos y luego buscar por DNI"
mientras salida1="s" o salida1="S"
para i=1 hasta 10 con paso 1
a[i,1]=nombre
Escribir "ingrese el DNI del alumno"
leer dni
a[i,2]=dni
FinPara
mientras salida="s" o salida="S"
nop="true"
escribir "Ingrese el DNI a buscar"
leer dnibusqueda

para i=1 hasta 10 con paso 1

si dnibusqueda=a[i,2] entonces
escribir "el nombre es " ,a[i,1]

nop="false"
FinSi
FinPara
si nop="true" entonces
escribir "no se encuentra en la base"
FinSi
escribir "Desea buscar otro alumno? S/N?"
leer salida
finmientras
escribir "Desea cargar nuevamente S/N?"
leer salida1
finmientras
FinProceso


ACTUALIZADO 09/11/2014

Trabajo Practico Nº 5


Ejercitación.

Practica1. Programa que pide n números, cada uno lo multiplica por 5 y el resultado lo guarda en otro arreglo.

Proceso Ejercicio1
Escribir "Digite la dimensión que se le asigna al vector"
Leer a
Dimension Num(a)
Para x<-1 hasta a con paso 1
Escribir "Digite un número para el vector en la posición N°",x
Leer Num(x)
FinPara
Escribir "El resultado de la multiplicación por 5 es: "
Para n<-1 hasta a con paso 1
Escribir Num(n) " * 5 = ",(Num(n)*5)
FinPara
FinProceso


Practica2. Calcular el promedio de los elementos que se encuentren en las posiciones pares de un arreglo de n números.

Proceso Ejercicio2
Escribir "Digite la dimensión que se le asigna al vector"
Leer a
Prom<-0
Dimension Num(a)
si (a MOD 2) <> 0
x<-a-1
Sino
x<-a
FinSi
Para n<-1 hasta a con paso 1
Escribir "Digite un número para el vector en la posición N°",n
Leer Num(n)
FinPara
Para n<-2 hasta x con paso 2
Prom<-Prom+Num(n)
FinPara
Resul<-Prom/(x/2)
Escribir "El promedio de los numeros es:"
Para n<-2 HASTA x con paso 2
Escribir Num(n)
FinPara
Escribir "Tiene como resultado ",Resul
FinProceso



Practica3. Utilice un vector con 10 elementos y devuelva la suma de los mismos.

Proceso Ejercicio3
a<-10
Sal<-"s"
Dimension Num(a)
Mientras Sal="S" o Sal="s"
Para i<-1 hasta a con paso 1
Escribir "Ingresar un valor en la posicion N°",i
Leer Num(i)
Resul<-Resul+Num(i)
FinPara
Escribir "La suma de todos los valores es: ",Resul
Escribir "Desea saber otra suma? (S/N)"
Leer Sal
Fin Mientras
FinProceso


Practica4. Lea las materias y las calificaciones de los alumnos de un grupo, almacénelas en 2 arreglos unidimensionales. Después debe imprimir el contenido de ambos arreglos.

Proceso Ejercicio4
Escribir "Ingresar cantidad de materias"
Leer cant
Dimension Materia(cant)
Dimension nota(cant)
Para i<-1 hasta cant con paso 1
Escribir "Ingresar el nombre de la materia"
Leer Materia(i)
Escribir "Ingresar calificación de la materia " , Materia(i)
Leer nota(i)
si (nota(i)<0) o (nota(i)>10) entonces
escribir "Error"
FinSi
FinPara
Escribir "Materia Nota"
Para i<-1 hasta cant con paso 1
Escribir Materia(i) " ", nota(i)
FinPara
FinProceso


Practica5. Hacer un programa que solicite al usuario 20 números y los ordene de mayor a menor.

Proceso Ejercicio5
n<-20;
Dimension num[n]
para i<-1 hasta n con paso 1 hacer
Escribir sin saltar "ingrese el valor del elemento ", i, ":";
Leer num(i);
FinPara
para i<-2 hasta n con paso 1 hacer
para j<-1 hasta n-i+1 Con Paso 1 hacer
si num(j)<num(j+1) entonces
aux<-num(j);
num(j)<-num(j+1);
num(j+1)<-aux;
FinSi
FinPara
FinPara
Escribir "";
Escribir "Números ordenados decendentemente:";
para i<-1 hasta n con paso 1 hacer
Escribir "[", i, "]:", num(i);
FinPara
FinProceso


Practica6. Realizar una variante del programa anterior ordenado de menor a mayor.

Proceso Ejercicio6
n<-20;
Dimension num[n]
para i<-1 hasta n con paso 1 hacer
Escribir sin saltar "Ingrese el valor del elemento ", i, ":";
Leer num(i);
FinPara
para i<-2 hasta n con paso 1 hacer
para j<-1 hasta n-i+1 Con Paso 1 hacer
si num(j)>num(j+1) entonces
aux<-num(j);
num(j)<-num(j+1);
num(j+1)<-aux;
FinSi
FinPara
FinPara
Escribir "";
Escribir "Números ordenados acendentemente:";
para i<-1 hasta n con paso 1 hacer
Escribir "[", i, "]:", num(i);
FinPara
FinProceso


Practica7. Cargar un arreglo de m números enteros indicar cual es el mayor y donde esta.

Proceso Ejercicio7
Escribir "Digite la cantidad de números que quiera calcular el mayor:"
Leer dim
b<-0
Dimension Num(dim)
Para i<-1 Hasta dim Con Paso 1 Hacer
Escribir sin saltar "Ingrese el número", i;
Leer num(i);
si Num(i)>b
b<-Num(i)
a<-i
FinSi
FinPara
Escribir "El mayor es: " ,b
escribir "El valor está guardado en la posición: ",a
FinProceso

Practica8. Generar un vector de tamaño 20 con números entre -10 y 10. Deje en un arreglo Z todos los números negativos y en un arreglo X todos los positivos o iguales a cero.

Proceso Ejercicio8
Escribir "Digite la cantidad de números que quiera calcular:"
Leer dim
Dimension num(dim)
Para i<-1 Hasta dim Con Paso 1 Hacer
Escribir sin saltar "Ingrese el número", i;
Leer num(i);
Si (a>0) y (0<10) Entonces
Escribir "El número insertado es Positivo";
Sino
Si (a<0) y [0>(-10)] Entonces
Escribir "El número insertado es Negativo";
Sino
Si (a=0) Entonces
Escribir "El número insertado es Neutro";
Sino
Escribir "Error"
Fin Si
FinSi
FinSi
FinPara
FinProceso

Practico9. Genere un vector de tamaño 10 con números enteros leídos desde teclado. Calcule el promedio e indique cuantos elementos del vector son mayores que el promedio y cuantos menores o iguales.

Proceso Ejercicio9
Escribir "Digite la cantidad de números que quiera calcular"
Leer x;
Sal<-"s"
Dimension Num(x)
j<-0;
Mientras Sal="S" o Sal="s"
Para w<-1 hasta x hacer
Escribir "ingresa el número", w, ":"
Leer a
j<-j+a
FinPara
k<-j/x;
Escribir "El promedio es:" , k;
Para i<-1 Hasta x Con Paso 1 Hacer
si Num(x)>b
b<-Num(x)
u<-i
FinSi
FinPara
Escribir "El mayor es: " ,b
Escribir "Desea saber otra suma? (S/N)"
Leer Sal
Fin Mientras
FinProceso

Practico10. Dado un vector con n elementos numéricos enteros ya almacenados, indique cuantos de ellos son múltiplos de 3.

Proceso Ejercicio10
i <- 3
n <- 0
c <- 0
ESCRIBIR "Número: "
LEER n
MIENTRAS i <= n HACER
SI i = ( i / 3 ) * 3 ENTONCES
ESCRIBIR i
c <- c + 1
FINSI
i <- i + 1
FINMIENTRAS
ESCRIBIR "El Número de multiplos de 3 son: "
ESCRIBIR c
FinProceso

ACTUALIZADO 11/11/2014

Trabajo Practico Nº 6


1. La sintanxis para que el usuario defina las posiciones del vector. Que los valores a guardar dentro del vector sean entre 50 y 100 (validar).

Proceso ejercicio1

b<-0
j<-5
Dimension Num(j)
Escribir 'Ingresar ',j ' numeros'
Para i<-1 hasta j con paso 1

Escribir sin saltar'Ingresar el valor N° ',i

Leer Num(i)

Mientras Num(i)<(50) o Num(i)>100

Escribir 'Debe ingresar un valor que se encuentre emtre 50 y 100, vuelva a'

Escribir sin saltar 'Ingresar el ',i '° numero'

Leer Num(i)

escribir ""

FinMientras

si Num(i)>b Entonces

b<-Num(i)

a<-i

FinSi

FinPara

Escribir "El mayor es: " ,b

escribir "La posicion del número mayor es: ",a

FinProceso

2) Crea un array o arreglo multidimensional que contenga la tabla de multiplicar del 1 al 9 (10 filas y 10 columnas). La primera fila y la columna debe contener estos números. El resto de números deberemos calcularlo, usando los números que disponemos, es decir, en la primera fila de 0, calculara 1*1, 1*2, 1*3, etc. usando las posiciones del array o arreglo.

SubProceso calculaTabla ( tablamulti, FILAS, COLUMNAS )

Para i<-2 Hasta FILAS Con Paso 1 Hacer
Para j<-2 Hasta COLUMNAS Con Paso 1 Hacer
tablamulti[i,j]<-tablamulti[i,1]*tablamulti[1,j]
Fin Para
Fin Para

Fin SubProceso

SubProceso rellenaColumnas ( tablamulti, FILAS)

definir cont como entero
cont<-0

Para i<-1 Hasta FILAS Con Paso 1 Hacer
tablamulti[1,i]<-cont
tablamulti[i,1]<-cont
cont<-cont+1
Fin Para

Fin SubProceso

SubProceso mostrarArray ( tablamulti, FILAS, COLUMNAS)

Para i<-1 Hasta FILAS Con Paso 1 Hacer
Para j<-1 Hasta COLUMNAS Con Paso 1 Hacer
escribir tablamulti[i,j]," " Sin Saltar
Fin Para
escribir ""
Fin Para

Fin SubProceso

Proceso Ejercicio4
definir FILAS como entero
definir COLUMNAS como entero
FILAS<-10
COLUMNAS<-10
dimension tablamulti[FILAS,COLUMNAS]
rellenaColumnas(tablamulti, FILAS)
calculaTabla(tablamulti, FILAS, COLUMNAS )
mostrarArray(tablamulti, FILAS, COLUMNAS)

FinProceso


ACTUALIZADO 3/12/2014

Trabajo Practico Nº 7


Crea un arreglo unidimensional donde tu le indiques el tamaño por teclado y crear una función que rellene el arreglo con los múltiplos de un número pedido por teclado. Por ejemplo la sirve para crear las tablas 9x1 y el resultado será 18, 27, 36.

SubProceso mostrarArray (tabla_multiplicar, FILA,COLUMNA )
Escribir "Crea un arreglo unidimensional donde tu le indiques el tamaño por teclado y crear una función que rellene el arreglo con los múltiplos de un número pedido por teclado. Por ejemplo la sirve para crear las tablas 9x1 y el resultado será 18, 27, 36."
FinSubProceso

SubProceso menu( tabla_multiplicar )
definir opc como entero
escribir ""
Escribir "Elija la operación:";
Escribir "(1) Potencia";
Escribir "(2) Multiplicar";
leer opc;
Escribir "Usted escogió la operación", opc;
segun opc Hacer
1: Escribir "Ingrese dos números";
Escribir "Inserte primer número para ser potenciado: "
leer n1;
Escribir "Inserte la potencia : "
leer n2;
Escribir "Vas a potenciar"
Escribir "La potencia es: " ,n1^n2;

2: Escribir "Ingrese el número deseado:";
Leer n; // leemos el numero
Escribir "Ingrese hasta que número se desea multiplicar"
Leer t;
Para i<-1 Hasta t Hacer
var <- n * i
Escribir i, "*" , n , " = ", var,";" ;
FinPara
FinSegun
Fin SubProceso
Proceso Ejercicio10
//Definimos las variables
definir FILAS,COLUMNAS,n,m,i,j,opc como entero
FILAS<-10
COLUMNAS<-10
n1<-0
n2<-0
menudeoperacion<-0
Sal<-"s"
dimension tabla_multiplicar[FILAS,COLUMNAS]
Mientras Sal="S" o Sal="s"
//Funciones
mostrarArray(tabla_multiplicar, FILAS, COLUMNAS)
menu( tabla_multiplicar )
Escribir "Desea saber otra operación? (S/N)"
Leer Sal
Fin Mientras
FinProceso

Trabajo Practico Nº 8


Crear dos arrays unidimensionales y realizar las 4 operaciones básicas. Diseñar un Menu como el siguiente ejemplo (si el ejercicio lo permitiera)

SubProceso mostrarArray (tabla_multiplicar, FILA,COLUMNA )
Escribir "Crear dos arrays unidimensionales y realizar las 4 operaciones básicas. Diseñar un Menu como el siguiente ejemplo (si el ejercicio lo permitiera)"
Fin SubProceso

SubProceso menu( tabla_multiplicar )

Escribir "==== MENU ====";
Escribir "1.- Sumar";
Escribir "2.- Restar";
Escribir "3.- Multiplicar";
Escribir "4.- Dividir";
Escribir "5.- Salir";
Escribir Sin Saltar "Seleccione una opción: ";
Leer opcion;

Segun opcion Hacer
1:
Escribir Sin Saltar "Ingrese el primer numero: ";
Leer num1;
Escribir Sin Saltar "Ingrese el segundo numero: ";
Leer num2;
resultado = num1 + num2;
Escribir "El resultado de la suma es: ",resultado;
2:
Escribir Sin Saltar "Ingrese el primer numero: ";
Leer num1;
Escribir Sin Saltar "Ingrese el segundo numero: ";
Leer num2;
resultado = num1 - num2;
Escribir "El resultado de la resta es: ",resultado;
3:
Escribir Sin Saltar "Ingrese el primer numero: ";
Leer num1;
Escribir Sin Saltar "Ingrese el segundo numero: ";
Leer num2;
resultado = num1 * num2;
Escribir "El resultado de la multiplicacion es: ",resultado;
4:
Escribir Sin Saltar "Ingrese el primer numero: ";
Leer num1;
Escribir Sin Saltar "Ingrese el segundo numero: ";
Leer num2;
resultado = num1 / num2;
Escribir "El resultado de la devision es: ",resultado;
5:
Escribir Sin Saltar "ADIOS------";
De Otro Modo:
Escribir "La opción ingresada no es correcta...";
FinSegun
Fin SubProceso

Proceso final

//Definimos las variables
Definir opcion Como Entero;
definir num1 Como Entero;
Definir num2 Como Entero;
Definir resultado Como Entero;
Sal<-"s"
Mientras Sal="S" o Sal="s"
//Funciones
mostrarArray(tabla_multiplicar, FILA,COLUMNA )
menu( tabla_multiplicar )
Escribir "Desea saber otra operación? (S/N)"
Leer Sal
Fin Mientras

FinProceso

Continuara

4 comentarios - Ejercicios y sus resultados con pseint

jockeyclu123 +3
Gracias genio por el post +10 y a fav, me viene justo al dedo