epelpad

El post que buscas se encuentra eliminado, pero este también te puede interesar

Redes!! Aprendamos algo sobre las Vlans! Aprender a crearlas

Un poco de informacion para los apasionados de las redes!!



¿Qué son las VLANs?


Redes!! Aprendamos algo sobre las Vlans! Aprender a crearlas

VLAN - LAN VIRTUALES: Seguridad, segmentación, flexibilidad.

Las VLAN permiten agrupar usuarios de un dominio de difusión común, con independencia de su ubicación física en la red. Usando la tecnología VLAN se pueden agrupar lógicamente puertos del switch y los usuarios conectados a ellos en comunidades de interés común. Las VLAN pueden existir en un solo switch o bien abarcar varios de ellos.

Las características básicas de configuración de una VLAN son los siguientes:

Cada VLAN lógica es como un bridge físico independiente

Las VLAN pueden extenderse a múltiples switch

Enlaces troncales (trunks) se encargan de transportar tráfico por múltiples VLAN.



redes

CONFIGURACIÓN DE UNA VLAN

Habilitar dominios VTP, definir un enlace troncal, crear una VLAN y verificar el correcto funcionamiento de la VLAN.

El número máximo de VLAN depende del switch.

VLAN1 es una de las VLAN predeterminas de fábrica.

Los avisos CDP y VTP se envían desde la VLAN1.

La dirección IP del Catalyst 2900, 3500 esta en el dominio de difusión VLAN1.

El switch debe hallarse en los modos VTP servidor o transparente
para poder crear, añadir o suprimir VLAN.

Si la VLAN va ha añadirse únicamente a un switch local, utilice
el modo transparente.

Si se desea propagar las VLAN a otros switches del dominio, utilice el modo servidor.

Un switch se encuentra por omisión en estado VTP servidor, de
modo que pueda añadirse, modificarse o suprimirse VLAN.

La pertenencia de los puertos de switch a las VLAN se asigna
manualmente puerto a puerto.(pertenencia VLAN estática o basada en puertos).



cisco

ASIGNACIÓN DE PUERTOS A UNA VLAN

Cada vez que crea una VLAN puede asignar estáticamente un puerto o un número de puertos a la VLAN. Un puerto puede pertenecer a una sola VLAN.


ccna

ENRUTAMIENTO ENTRE VLAN

En un entorno de VLAN conmutada, los paquetes se conmutan sólo entre puertos designados para residir en el mismo “dominio de difusión (broadcast)”.

Las VLAN llevan a cabo particiones en la red y separación de tráfico en la capa 2. Por tanto, la comunicación entre VLAN no puede tener lugar sin un dispositivo de capa 3, como un router, responsable de establecer comunicaciones entre distintos dominios de difusión.

Para llevar a cabo funciones de enrutamiento entre VLAN, han de darse las siguientes circunstancias:

El router debe conocer como llegar a todas las VLAN interconectadas para determinar cuales son los dispositivos finales, incluidas las redes que están conectadas a la VLAN, cada dispositivo final debe estar direccionado con una dirección de capa de red, como la dirección IP.

Cada router debe conocer además la ruta hasta cada red LAN de
destino.
El router tiene ya información acerca de las redes que están
conectadas directamente. Por tanto, deberá aprender las rutas a
las redes que no están conectadas directamente.

Debe existir una conexión física en el router para cada VLAN, o
bien se debe habilitar la troncalidad en una conexión física individual.


ccnp


Configuración de VLAN



examen
Configuración estática:

Es la realizada por un administrador asignado manualmente los puertos a las respectivas Vlans. Por defecto todos los puertos pertenecen a la Vlan1 hasta que el administrador cambie esta configuración.


Configuración dinámica:

El IOS de los switches Catalyst soportan la configuración dinámica a través de un servidor de pertenecía de Vlan (VMPS). El servidor VMPS puede ser un switch de gama alta que ejecute un sistema operativo basado en set (CatOS).


Configuración de VLAN en un switch 2950

Switch#vlan database
Switch(vlan)#vlan [numero de vlan] name [nombre de vlan]
Switch(vlan)#exit

Switch(config)#interface fastethernet 0/numero de puerto
Switch(config-if)#switchport access vlan [numero de vlan]




Ejemplo de la creación de una Vlan 3 Ventas y su correspondiente asociación al Puerto 0/12:

Switch#vlan database
Switch(vlan)#vlan 3 name Ventas
VLAN 3 added:
Name: Ventas
Switch(vlan)#exit
Switch(config)#interface fastethernet 0/12
Switch(config-if)#switchport access vlan 3


Eliminación de Vlan:

Switch#vlan database
Switch(vlan)#no vlan 3

Switches de las series 2900 y 2950 es necesario eliminar el archivo de información de la base de datos de la VLAN que esta almacenado en la memoria flash. Tenga especial cuidado de eliminar el archivo VLAN.dat y no otro.



vlan


El comando para eliminar dicho archivo:

Switch#delete flash:vlan.dat
Delete filename [vlan.dat]?[Enter]
Delete flash:vlan.dat? [Intro]


Si no hay ningún archivo VLAN, aparece el siguiente mensaje:

%Error deleting flash:vlan.dat (No such file or directory)
Habilitación de un puerto troncal:

Switch(config)#interface fastethernet 0/24
Switch(config-if)#switchport mode trunk
Los switches 2950 solo poseen encapsulación 802.1q, en el caso de ser un switch 2900 se debe especificar la encapsulación deseada:

Switch(config)#interface fastethernet 0/24
Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk encapsulation [Dot1q|ISL]



Configuración de VLAN en un switch 1900

Ejemplo de la creación de una Vlan 6 Administración y su correspondiente asociación al Puerto 0/10:

Sw_1900(config)#vlan 6 name administración
Sw_1900(config)#interface ethernet 0/10
Sw_1900(config-if)#vlan-membership static 6




Habilitación de un Puerto troncal en un switch 1900:

Los switches 1900 solo poseen dos puertos FastEthernet, el 26 y el 27. Estos puertos son llamados A y B respectivamente. Solo admite encapsulación ISL.

Sw_1900(config)#interface Fastethernet 0/26
Sw_1900(config-if)#trunk on
Sw_1900(config-if)#exit
Sw_1900(config)#exit

Sw_1900#show trunk A



vlans


Configuración de VLANs estáticas con más de

un Switch, Modos Server y Cliente.


La configuración de VLANs estaticas en un Switch es relativamente sencilla, así como la configuración de interVLANs (Interconexión entre VLAN).

Entre las varias ventajas que tienen el uso de VLAN, es la permitir agrupar de formar logica grupos de usuarios, independientemente de su ubicacion fisica. Como se puede ilustrar de forma general con el siguiente esquema:


cisco networking


Tomando en cuenta como base la siguiente topología implementada.

examenes cisco


Nos propusimos configurar VLAN en más de un Switch con el fin de poder conectar usuarios en diferentes VLAN. Hemos tomado en cuenta que cada Switch está en un piso diferente, y existen usuarios en la red de la VLAN 10 (Ventas), VLAN 30 (Marketing), distribuidos en diferentes pisos. Para lo cual es necesario conectar usuario de VLAN diferentes a un equipo Switch en los diferentes pisos.

Para lograr esto de acuerdo a la documentación revisada, se debe configurar uno de los Switch en modo Server y el (los) otro(s) en modo cliente. En este caso, el Switch0 ha sido configurado como server, con dominio “UATF”, y password “cisco”, y el Switch1 como cliente y con los mismos datos del dominio y la password.

Paso a resumir los pasos a seguir para configurar lo mencionado:



CONFIGURAR VLAN CON MODOS VTP SERVER Y VTP CLIENT

WITCH0 es el Switch Principal, debe estar en modo Server,y es donde se debn configurar las VLANs

SWITCH1 es el Switch Secundario, debe estar en modo Cliente (asignar interfaces a cada VLAN)




===== CONFIGURACION DEL SERVIDOR (Switch 0) ======


Paso 1. Configurar SWITCH0 a modo Server.

SWITCH0(config)#vtp mode server
Device mode already VTP SERVER.
SWITCH0(config)#


Paso 2. Configurar el nombre del dominio VTP.

SWITCH0(config)#vtp domain UATF
Changing VTP domain name from NULL to UATF
SWITCH0(config)#


Paso 3. Configurar contraseña para el dominio VTP.

SWITCH0(config)#vtp password tauro
Setting device VLAN database password to tauro
SWITCH0(config)#


Step 4. Verificar los cambios realizados.

SWITCH0#show vtp status
VTP Version : 2
onfiguration Revision : 0
Maximum VLANs supported locally : 64
Number of existing VLANs : 5
VTP Operating Mode : Server
VTP Domain Name : UATF
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0×8C 0×29 0×40 0xDD 0×7F 0×7A 0×63
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

SWITCH0#show vtp password
VTP Password: tauro
SWITCH0#


===== CONFIGURACION DEL CLIENTE (Switch1) ======


Paso 1. Configurar el modo VTP a Cliente.
Paso 2. Configurar el nombre del dominio VTP (en este caso el mismo, UATF).
Paso 3. Configurar las password del dominio VTP. (La misma password que en el Switch Server)
Paso 4. Verificar los cambios realizados.


SWITCH1#show vtp status
VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 64
Number of existing VLANs : 5
VTP Operating Mode : Client
…………………………….

SWITCH1#show vtp password
VTP Password: tauro
SWITCH1#


===== CONFIGURACION DE PUERTO TRONCALES ======


Configurar los puertos conectados entre los Switch en modo troncal, en este caso caso los puestos fa0/24 de cada Switch. Se ha creado una vlan 300 admin, y se ha configurado en modo “trunk native” para cada interface troncal.

interface FastEthernet0/24
switchport trunk native vlan 300
switchport mode trunk

Verificar el estado de VTP

show vtp status ((en el Switch Cliente))

Switch1#sh vtp status
VTP Version : 2
Configuration Revision : 1
Maximum VLANs supported locally : 255
Number of existing VLANs : 9
VTP Operating Mode : Client
VTP Domain Name : UATF
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0xE8 0×59 0×05 0xB4 0xDD 0×29 0xFF 0×54
Configuration last modified by 192.168.1.2 at 3-1-93 00:13:16
Switch1#

show vlan brief (en el Switch Cliente)

Switch1#sh vlan brief

VLAN Name......................Status.. Ports
—- ——————————– ——— ——————————-
1...default....................... active...Fa0/1, Fa0/2, Fa0/3, Fa0/5
...............................................Fa0/6, Fa0/7, Fa0/8, Fa0/9
...............................................Fa0/11, Fa0/12, Fa0/13, Fa0/14
...............................................Fa0/15, Fa0/16, Fa0/17, Fa0/18
...............................................Fa0/19, Fa0/20, Fa0/21, Fa0/22
...............................................Fa0/23
10..Ventas.......................active....Fa0/4
20..Engenieria...................active
30..Marketing....................active....Fa0/10
300.admin........................active
1002.fddi-default................active
1003.token-ring-default........active
1004.fddinet-default ...........active
1005 trnet-default..............active
Switch1#


===== ASIGNAR PUERTOS A VLAN EN EL SWITCH CLIENTE ======


Una verificado que el Switch Cliente ha aprendido las VLAN configurdas desde Switch Server, usando el comando switchport mode access y switchport access vlan vlan-id para asignar puerto a cada VLAN.

Pruebas de Conexión:

Realizando pruebas de conexión desde el hosts conectados al Switch1 (que está en modo cliente) hasta la IP de loopback en el router, tenemos respuesta sin problemas.


ccna 3


A una estación de trabajo en la misma VLAN, pero conectado al otro Switch.

examen cisco


Espero pueda ayudarles el pequeño aporte sobre configuración de VLANs, InterVLAN, y modo Server y Client con más de un Switch.



Saludos!



Comenten que es gratiss!!!



Mis aportes relacionados!!


Examen final CCNA 4.1 Exploration, subido por mi!

Posible examen! Cisco Packet Tracer: Como configurar rutas estaticas

El juego que todo tecnico soño!Subido por mi!l [EXELENTE JUEGO PARA PROBARTE A VOS MISMO SOBRE REDES, UNICO EN TARINGA]

armar redes

17 comentarios - Redes!! Aprendamos algo sobre las Vlans! Aprender a crearlas

venedos
antes de L va B

(es una joda )
sGoico
Buen material!
Fede007_29 +1
no entendí nada, pero me parece genial el post

se nota que no s enada xD

Dooch
noooo! te pasaste capo!! buen post, a favs!!!
kikato
Buena info , gracias
trankak
te dejo +1pto no tengo mas gracias por tu post
pipelin24
Genial me ayuda a reforzar para la certificacion +5
Misfits_77 -1
Papá, si les vas a enseñar a los pibes, no le enseñes SOBRE CISCO NADA MAS. Cisco es Cisco, pero no es dueño de internet.
Aragonenred +1
Muy interezante, mañana te dejo 10
dario2494 +1
Misfits_77 dijo:Papá, si les vas a enseñar a los pibes, no le enseñes SOBRE CISCO NADA MAS. Cisco es Cisco, pero no es dueño de internet.

No es dueño. Solo un 80% de los equipos Cisco son dueños de Internet. Solo eso. Nada mas.
sharkbull
interesante carnal y por donde empiezo jejeje, si quiero enviar telefonia atravez de vlans jejeje. est es un aportazo
maxicerro
Pueden unirse al grupo de CCNA ARGENTINA https://www.facebook.com/groups/903834486326240/ (sin fines de lucro, solo para publicar info nueva, ejercicios de packet tracker, subneteo, informes y noticias de examenes en Argentina, Etc.)