epelpad

Hotspot con Mikrotik

Hola amigos, hoy quiero compartir con ustedes una solución relativamente económica para brindar internet sin cables (WiFi) casi profesional y con buena potencia.
Hotspot con Mikrotik

Este caso esta armando para brindar conectividad en una playa y alrededores, la prueba de campo demostró un alcance que señal excelente en un radio de 400mts.
Wifi

La forma de conectar es por medio de uno de los radios para el hotspot y el otro hace un enlace a un AP con DHCP. Si solo necesitan hacer el hotspot con un solo radio y tomar la señal por una de la eth lo pueden hacer sin problemas cambiando el cliente dhcp de la wlan a la eth

Los materiales que utilicé:

1 Routerboard 433

hotspot


2 Radios Mikrotik R52hn minipci 802.11a/b/g/n 350Mw

mikrotik


2 Pigtail N Hembra - MMCX

rb


1 Gabinete outdoor para el RB433

433


1 Antena Omni 2.4 Ghz 7 DBI conector N macho

routerboard


1 Antena grillada 2,4 GHz

Hotspot con Mikrotik


1 Fuente 24v - 1 amp y Power over ethernet pasivo

Wifi


¡Todo armado les debería quedar así o mejor!

hotspot

El segundo conector N que ven es para la antena grillada que será el gateway.

El precio estimado de los equipos, poe, fuente y antenas (sin el gabinete que ya lo tenía) es de u$s395 (gremio) a un cambio de 4,35 sería ... 5*5 25 pongo el 5 me llevo 2 ... estemmm $1720 (redondeado y Peso - Argentina)
Una ganga.

mikrotik


Configuración del Routerboad

Voy a dar por entendido como hacemos una conexión por Winbox (software de administración del RouterOS)
Nos logueamos y damos nombres a las interfaces, es un buen comienzo
rb


Configuramos nuestra wan según el tipo de conexión a internet que tengamos, este caso es por dhcp entonces vamos a:
Ip > DHCP Client

Click en + (add) y seleccionamos la interface correspondiente a nuestra WAN, luego solo OK

433


Como les dije al comienzo mi wan es una conexión inalámbrica puesto que este equipo se conecta a un AP (wan es station y hotspot es AP) pero ustedes lo pueden hacer con cualquier Eth y se ahorran un radio.
La configuración de la placa wireless es sencilla, en este caso solo tenemos que configurar el radio como Station, el SSID de nuestro AP, el canal y la seguridad (si es que tiene). Es como conectar tu laptop a una red wifi, solo eso.
Para la interface del hotspot tenemos que hacer una simple configuración en el radio, tenemos que dejarlo como AP (punto de acceso), le damos un nombre en el SSID (el nombre de la red inalámbrica que verán los clientes), elegimos el canal y la norma (dual B/G, si es solo B lograremos mayor alcance)

El siguiente paso y para no complicarnos si somos muy novatos (como yo) ejecutaremos el setup para armar el hotspot
Ip > Hotspot > Servers > Hotspot setup

routerboard


Estas son las opciones del setup:
1.- HotSpot interace = hotspot (o el nobre de la interface que utilizaremos para el server)
Next
2.- Local address of Network = 10.5.50.1/24 (ip por defecto de mikrotik, uds. pueden colocar la que quieran) y marcamos la opción "Masquerade" si no lo está.
Next
3.- Address pool of Network = 10.5.50.2-10.5.50.254 (rango habilitado de ips para los clientes)
Next
4.- Select Certificate = none
Next
5.- Ip Address of SMTP server = 0.0.0.0 (si no tienen un smtp server)
Next
6.- DNS server = 192.168.2.1 (mi caso, el DNS lo tomará de su cliente DHCP)
Next
7.- DNS name = en blanco (si tienen un dominio lo pueden agregar, no es necesario para este caso)
Next
8.- Name of Local HotSpot User = admin (o el que gusten)
Password for the User = mi_clave
Next

Si todo salió bien tiene que aparecer una leyenda que diga: "Setup has completed successfully"
Vamos bien. Ese usuario y clave que creamos es el habilitado que ingresar al sistema y permitido para navegar. Dentro de las opciones de HotSpot hay una solapa de "users" y "users profiles"

Hotspot con Mikrotik

En Users podemos ir agregando todos los usuarios y claves de los clientes para que cada uno se conecte individualmente con sus respectivos datos de login, en esta red voy a usar solo un login, el que creamos en el setup entonces tenemos que configurar la opción S h a r e d Users con el valor que nos guste, por ej. 50. Permitiremos 50 clientes navegando simultáneamente, el 51 DROP jejeje (maldad)

Wifi


Configuraciones adicionales


Vamos a agilizar la navegación utilizando Mangle y Queue Tree (o morir en el intento)
En el menú de la izquierda del Winbox esta "New terminal", es la consola de Mikrotik y entre otras muchas cosas nos va a permitir ingresar configuraciones mucho mas rápido que click en + (add) e ir navegando por las solapas. Solo tienen que copiar y pegar los códigos.

Mangle

/ip firewall mangle
add action=mark-connection chain=prerouting comment=ICMP disabled=no new-connection-mark=icmp_con passthrough=yes protocol=icmp
add action=mark-packet chain=prerouting connection-mark=icmp_con disabled=no new-packet-mark=icmp passthrough=no
add action=mark-connection chain=prerouting comment=DNS disabled=no dst-port=53 new-connection-mark=dns_con passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting connection-mark=dns_con disabled=no new-packet-mark=dns passthrough=no
add action=mark-connection chain=prerouting comment=HTTP connection-bytes=0-500000 disabled=no dst-port=80 new-connection-mark=http_con passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting connection-mark=http_con disabled=no new-packet-mark=http passthrough=no
add action=mark-connection chain=prerouting comment="HTTP DOWN" connection-bytes=500000-5000000 disabled=no dst-port=80 new-connection-mark=http_con_down passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting connection-mark=http_con_down disabled=no new-packet-mark=http_down passthrough=no
add action=mark-connection chain=prerouting comment=MSN disabled=no dst-port=1863 new-connection-mark=msn_con passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting connection-mark=msn_con disabled=no new-packet-mark=msn passthrough=no
add action=mark-connection chain=prerouting comment=WINBOX disabled=no dst-port=8291 new-connection-mark=winbox_con passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting connection-mark=winbox_con disabled=no new-packet-mark=winbox passthrough=no
add action=mark-connection chain=prerouting comment=Https disabled=no dst-port=443 new-connection-mark=https_conn passthrough=yes protocol=tcp
add action=mark-packet chain=prerouting connection-mark=https_conn disabled=no new-packet-mark=https passthrough=no
add action=mark-connection chain=prerouting comment=OTROS disabled=no new-connection-mark=otros_con passthrough=yes
add action=mark-packet chain=prerouting connection-mark=otros_con disabled=no new-packet-mark=otros passthrough=no

Para tipo de cola (queue) utilicé PCQ, lo agregamos:
/queue type
add kind=pcq name=pcq-download pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=dst-address pcq-dst-address-mask=32 pcq-dst-address6-mask=128 pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=128 pcq-total-limit=2000
add kind=pcq name=pcq-upload pcq-burst-rate=0 pcq-burst-threshold=0 pcq-burst-time=10s pcq-classifier=src-address pcq-dst-address-mask=32 pcq-dst-address6-mask=128 pcq-limit=50 pcq-rate=0 pcq-src-address-mask=32 pcq-src-address6-mask=128 pcq-total-limit=2000

Por último agregamos todas las marcas del mangle a queues tree
/queue tree
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=2M name=Download parent=hotspot priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=256k name=Upload parent=wan priority=1
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=ICMP packet-mark=icmp parent=Download priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=DNS packet-mark=dns parent=Download priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=MSN packet-mark=msn parent=Download priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=HTTP packet-mark=http parent=Download priority=5 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=HTTPS packet-mark=https parent=Download priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=HTTPDOWN packet-mark=http_down parent=Download priority=6 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=WINBOX packet-mark=winbox parent=Download priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=OTROS packet-mark=otros parent=Download priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=icmp packet-mark=icmp parent=Upload priority=1 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=dns packet-mark=dns parent=Upload priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=http packet-mark=http parent=Upload priority=5 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=https packet-mark=https parent=Upload priority=3 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=otros packet-mark=otros parent=Upload priority=8 queue=default
add burst-limit=0 burst-threshold=0 burst-time=0s disabled=no limit-at=0 max-limit=0 name=winbox packet-mark=winbox parent=Upload priority=1 queue=default

Les quedaría darle un poco de seguridad al hotspot agregando algunas reglas al filter pero con todo esto debería estar andando.
La conexión es sencilla, elegimos la red y nos conectamos, verán que la conexión es limitada porque no se realizó el login. Abrimos un navegador y escribimos cualquier dirección de internet e inmediatamente nos redireccionará a la página de inicio del Mikrotik, cargamos el usuario y la contraseña y listo!

Todas las críticas y correcciones son bienvenidas porque soy un novato con ganas de ir aprendiendo.
Saludos y hasta la próxima

15 comentarios - Hotspot con Mikrotik

fernandoae
Y?
TooRDJ
Cada dia me gusta mas el MT
_Leokpo_
Estaría bueno saber los costos que tuvistes que poner para tener ideas a la hora de optimizar y profesionalizar las señales transmitidas vía wireless. Tambien para saber donde comprar estos equipos tambien. Saludos. Gracias por el aporte.
alcahute +1
Podes bajar mucho los costos si pones un AP de tipo Ubiquiti con una punto a punto a tu gateway ... mas barato que eso imposible. Esta configuración hace de tu nodo una opción profesional de bajo coste, acordate que estamos poniendo un ruteador de la jerarquía de MK (address-list, queues/queues tree, mangle, firewall, nat, hotspot, etc etc)
En esa oportunidad no llegó a los $1800, todo conseguís en mercado libre, si sos del gremio hacelo directamente con un mayorista (Solution Box, Microcom
_Leokpo_
@alcahute Gracais por la respuestas. Al precio que mensionas, hablamos de hace 2 años supongo jeje. Pero en ML (como dices) se puede abaratar los costos.
Y si, tengo varias tecnologías en el 2.4Ghz, estoy en el más alto canal, pero es bastante vulnerable esta frecuencia por los ruidos...
Saludos nuevamente!
Raulbu +1
Con este tutorial lo hace ver fácil. Vamos a probar RB751U.
elgrillo2610
Amigo como haciendole algunas reglas al filter??
alcahute
Tenes que configurar el firewall para hacerlo mas seguro, hay muchos tutoriales en la red
elgrillo2610
@alcahute amigo me da error al ingresar el queue tree por terminal me dice q faltan parent
alcahute
@elgrillo2610 fijate los nombres en interfaces
bryamcito +1
si necestan ayuda escribanme en facebook: fb/bryamcito con gusto les ayudo
rayc77
no tienes en la vercion 6 balanceo ppoe
guzmandy
amigo mio y si quiero generar automáticamente los user y pass y imprimirlos valga la redundancia en una impresora térmica como seria?
juliobcn
yo apretaría Ctrl + Alt + Supr
paroximus
te dejo 10 porque estoy arrancando con esto del mikrotik y me parecio muy util. gracias
AntoniFoXx
Instalación de Mikrotik Versión 5.20 + Licencia L6 (2015)
https://www.youtube.com/watch?v=Di9-DIiiXHw
Dc_Frank
que buen post +10... che capo.. por que dos Mikrotik R52hn minipci?? digo.. se puede usar una sola minipci para las dos antenas?? ya que veo que tiene para conectar dos pigtail...
perdon por la pregunta, no se de mikrotik, pero me dio curiosidad... saludos... ojala me respondas
alcahute
Necesitas 2 interfaces para levantar el hotspot, como lo harías? yo necesitaba hacer un enlace a un AP a 1km, bien lo podes hacer con una eth para la wan y un radio
PeterMont7
Compa, como le puedo hacer para la siguiente red:

Tengo una red inalámbrica que se conecta a un Access Point Unifi AP, estos usuarios quiero que esten controlados el ancho de banda que ocupan; el AP se conecta al puerto 2 de un Router Board RB 750, al puerto 3 del RB 750 se conecta una PC y al puerto 1 esta conectado a el router del proveedor de servicio, al RB750 quiero que haga las funciones del Modem mediante PPPoE y al router del proveedor lo he puesto en modo bridge.

Pregunta que nomas le tengo que programar al RB 750 para que la red funciones,

Saludos
alcahute
deberías leer algo de server pppoe en mikrotik, hay miles de tutoriales en la red, buena suerte!
Jairoskov
@alcahute Hola amigo, necesito un poco de ayuda aqui, en un hotel hay dos planes uno de 5mb y otro de 20mb el de 5 es el que se le da a todo el mundo que llega un solo usuario que no deberia desconectarse nunca y el de 20 obvio se vende si quieren mas velocidad para este se crea un usuario personalizado con este plan que no deberia desconectarse nunca tampoco, el molesto problema es que los usuarios después de cierto tiempo se desconectan y les pide usuario y clave denuevo
pncl
Se le puede adaptar social hotspot o un captive portal a esta solución?
alcahute
Si y tiene muchas mas opciones, incluso podes hacer un metodo prepago de acceso, tanto por hora como limite de consumo. Busca info en Ryohnosuke