epelpad

Unity Web Player para Linux - instalación en Ubuntu

Unity Web Player es requerido para jugar muchos juegos realizados con esta tecnología.




Este complemento no tiene un instalador para Linux, solo para Windows y Mac. Esto aparentemente es porque requiere la tecnología de Microsoft llamada Silvertlight.




En Linux tenemos una implementación libre de Silvertlight llamada Pipelight que va ganando compatibilidad y permite ejecutar programas cada ves más complejos desarrollados con esta tecnología.



La lógica de como se soluciona es para cualquier distro, pero yo doy los pasos exactos que me funcionaron en Ubuntu 14.4 64 bit y 32 bit.

y dejo el link de como se instala en cualquier distro. Para Canaima y Huayra deben elegir Debian.
http://pipelight.net/cms/installation.html

Copien estos comandos en Writer o cualquier otro editor de texto (como Gedit)
Todos los navegadores deben estar cerrados para una correcta instalación. (Chrome,chromium,Firefox y hasta Thunderbirt)

Copiar y pegar cada uno de estos comandos en la consola/terminal de a uno por vez.
Recordar que cuando uno pone la clave en consola no aparcen ni los "*******"

sudo apt-add-repository ppa:pipelight/stable
sudo apt-get update
sudo apt-get install --install-recommends pipelight-multi
sudo pipelight-plugin --update
sudo pipelight-plugin --enable silverlight
sudo pipelight-plugin --enable widevine
sudo pipelight-plugin --enable unity3d



Ahora todo instalado.

Pueden ver en complementos su instalación



Tambien se instala el complemento "Windows Media Player" cambien el comportamiento a "desactivado" por trae conflictos en el navegador.

Hay algunas páginas que miran desde que sistema operativo y navegador se está entrando al juego y sí ven que es Linux te rechazan, aunque con los pasos anteriores tiengas todo instalado.
¿como se resuelve? le vamos a decir a la página que estás entrando desde Windows 7 con FireFox.
1ªPara esto agregas otro plug-in "User Agent Switcher"
https://addons.mozilla.org/en-US/firefox/addon/user-agent-switcher/?src=ss
2º click en el icono y del menú vas a "Edit user Agent"
3 vas al botón "NEW" para agregar una nueva entrada y "New User Agent"
4ª Tiene que quedar como en la figura de abajo

Les dejo los renglones como para que copien y peguen en cada renglón
Windows 7
Mozilla/5.0 (Windows NT 6.1; rv:30.0) Gecko/20100101 Firefox/30.0
Mozilla
Netscape
5.0 (Windows)
Win32

Después seleccionas por el menú o el icono "Windows 7" para jugar o "Default" para volver.
En la siguiente página puedes ver los datos del User Agent y como cambian.
http://chrispederick.com/work/user-agent-switcher/features/test/

Con lo anterior pueden jugar al Uberstrike sin problemas

Un lector de este post hizo un video tutorial de todo el procedimiento.
muchas gracias.

link: https://www.youtube.com/watch?v=g8Xk3S3jCiM&feature=youtu.be



Por otra parte aparentemente la nueva versión de Unity 3D, la versión 5 (hoy 27/04/14 todavía en desarrollo) no necesitaría ningún plug-in para funcionar.

Les dejo una página de juegos para probar. Y a jugar...

http://www.juegosunity.com/


otros post que te pueden interesar
http://www.taringa.net/posts/linux/17627085/Configurar-Chrome-como-un-rayo.html

http://www.taringa.net/posts/linux/17559837/Juego-nudista-con-Linux-y-AMD.html

http://www.taringa.net/posts/linux/10266019/Nuevos-y-mejores-juegos-nativos-en-linux---para-agendar.html

Les dejo de donde armé toda la Info
http://www.webupd8.org/2014/04/10-things-to-do-after-installing-ubuntu.html

http://www.gamingonlinux.com/articles/unity3d-web-player-in-linux-browsers-thanks-to-pipelight-.2996

38 comentarios - Unity Web Player para Linux - instalación en Ubuntu

sraw +4
Unity Web Player es requerido para jagar muchos juegos realizados con esta tecnología.
DOA1 +1
Arreglado
barrabas_fumado -6
Sin animo de chicanear... pero enserio todavía hay que instalar aplicaciones desde la consola en linux??
barrabas_fumado -1
@francisco0327 me encantaría que linux termine de salir adelante... pero así no muchachos!!...
efrain_18 +5
si uno quiere no se utiliza la terminal, pero por algunas razones la mayoria de los usuario (me incluyo) se nos hace mucho mas rapido abrir una terminal y con un comando instalar varios programas
gonzifpppp
@barrabas_fumado vete a Windows y como los tontos a darle todo el rato Aceptar que tu cerebro no da ni para copiar unos pocos comandos
marcelochino -1
no es necesario para el usuario promedio de una computadora con un linux de ultima generación de escritorio, llamese Ubuntu o sus derivados, Mint, Fedora, Elementary y otros mas que no conozco, instalar programas o aplicaciones ni hacer prácticamente nada desde la consola.

Si usaras un linux de vez en cuando te darías cuenta.... te escribo desde mi mac, saludos!
elultimocarlos
Me dice error al instalar Unity3D, pareciera que se instaló, pero en firefox cuando abro las extenciones dice "Pipelight Error (unity3d)! 0.0

Y por cierto, las extenciones no se muestran en Chrome, sólo funcionan en firefox
DOA1 +1
@elultimocarlos
miré la fuente de la fuente y un comando es distinto. Y ahora me funciona bien en una instalación nueva.

Este es el comando viejo
sudo apt-get install pipelight-multi

Y este es el comando nuevo
sudo apt-get install --install-recommends pipelight-multi

En tu caso esto son los pasos.
Con el centro de Software desinstala pipelight-multi
Y después con los navegadores cerrados

sudo apt-get install --install-recommends pipelight-multi
sudo pipelight-plugin --update
sudo pipeli
DOA1
@elultimocarlos

Me cortó el comentario anterior, pero bueno. Desinstala pipelight-multi con el navegador cerrado y vuelve a instalar con los nuevos comandos.

Despues prueba.
http://www.cartoonnetwork.com.ar/juego/cartoon-network-copatoon-2014-ar

El juego que me dices no funciona porque rechaza directamente al sistema operativo.
Les envié un correo para pedirles que lo arreglen, pero... no se sí me harán caso.
DOA1 +1
ya arreglé el post y agregué lo que faltaba y pude jugar al juego UberStrike sin problemas.
perly
Seguí todos tus pasos genio pero no tuve éxito.
Se instaló todo correctamente pero no consigo jugar al Dead Frontier.
Antes de instalar pipelight y unity3d me pedía que instale unity3d pero cuando le daba click a instalar me ponía null.
Ahora me roma como que está instalado pero con lo siguiente:
Unity web player requires drx level graphics card. Make sure you have graphics card drivers installed.
Investigué un poco y encontré que tenía que instalar directx 9 para solucionar este problema.
Seguí los pasos indicados en este post :
http://www.taringa.net/posts/linux/4130391/Instalar-DirectX-9-en-Ubuntu-facilmente.html

y teóricamente con el dx9 instalado podría jugar al Dead Frontier (con el windows xp instalado en ésta misma máquina lo jugaba) pero sigue apareciendo el mismo error.
Me podrías ayudar?
perly
@DOA1 muchas gracias!
perly
@DOA1 Instalé Xubuntu 14.04
No me laguea para nada.
Sigo los pasos que explicas en el post para instalar el Unity 3d?
DOA1 +1
@perly
Otros pasos no hay, solo los del post, pero yo uso una CPU un poco más moderna, del 2010 con placa integrada HD 4200.
scrat222
tengo un error cuando voy a jugar no carga el juego se queda la pantalla en blanco
carlsdaniel
pero cuales son las contraseñas
DOA1
La contraseña es la del administrador de la CPU. En Huayra es "alumno"
JeztChc
No entiendo la ultima parte sobre que algunas paginas nos rechazan,como es lo del "User Agent Switcher" ??
DOA1
Cada vez que entras a una página el navegador informa tu versión sistema operativo y versión de navegador. Algunas páginas solo dicen que son incompatible por ser Linux.
ottonielmorraz
SWEET! I just got a free Minecraft card code at http://minecraftcode.me/
n0kiadict
Tremendo genio, me funcionó totalmente, voy a hacer un tutorial en video. No sabía lo de Switch User Agent, eso era lo que me faltaba.
DOA1
Gracias, sí haces un video avisame que pongo el enlace a tú video.
calebasd
¡Che! ¿qué hago acá? :'0

Unity Web Player para Linux - instalación en Ubuntu
DOA1
Sí queres ayuda tendrás que explicar mejor el problema.
calebasd
@DOA1 Me salió ese letrero gris que se ve ahí después de poner este comando sudo apt-get install --install-recommends pipelight-multi
DOA1
@calebasd

Despues de copiar y pegar el comando
"sudo apt-get install --install-recommends pipelight-multi
tienes que poner la clave de administrador, mentras escribes la clave la pantalla no ecribe nada, no muestra asteriscos ni nada. Pero escribela y dale enter despues.
calebasd
Unity Web Player para Linux - instalación en Ubuntu

Hice todo y ahí están, pero no me deja usar nada con UNity 3D ni Siverlight
calebasd
@DOA1 No tengo chrome, y no tengo intenciones de usarlo, ni abre la página esa, y ¿entonces no se puede tener Siverlight en ubuntu al final? :v
DOA1
@calebasd

Sí hiciste los pasos, lo tienes instalado. Pero Netflix creo que requiere más cosas.
Hay otros tutoriales para hacerlo funcionar.
http://www.webupd8.org/2013/08/pipelight-use-silverlight-in-your-linux.html
calebasd
@DOA1 Netflix solo necesita SIverlight :u
ponxeo
por que el complemento de unity3d me pide actualizar al jugar lo instale todo perfectamente :/ help nesecito ayuda
DOA1
Puede que te lo pida la primera vez y de vez en cuando cuando haya una actualización.
DOA1
Que página es a la que no puedes entrar?
ponxeo
pero es que tengo ubuntu y como puedo actualizarlo :/
ahLoNso
Una pregunta, es necesario instalar wine o hacer algo antes de el tutorial?
Saludos!
DOA1
No hace falta instalar Wine antes. Se instala todo en un Wine empotrado y configurado solo para esto. Si quieres tener Wine para otra cosa se instala aparte.
ydomo
excelente amigo, va de 10
angel725
Amigo tengo un problema para para instalar el comando sudo apt-get update
DOA1
El comando "sudo apt-get update" es actualizar la lista de programas disponibles.
En sí no instala nada. Pero necesita conexión a Internet.
angel725
tiene conexión y todo pero cuando llego a la parte de activar me dice que ERROR: Plugin unity3d  is unknown
pero seguí todos tus pasos
DOA1
por el error no encuentra el plugin, porque no debe estar instalado. ¿pusiste la clave en el primer comando?
angel725
@DOA1 no lo creo cual era es q soy nuevo en ubuntu
KhungoGraw
Me aparece este error al momento de poner la contraseña que sera ?

Sorry, user canaima is not allowed to execute '/usr/bin/apt-key add Release.key' as root on canaima-popular.
DOA1
Te dejo respuesta abajo
Liusss
una pregunta, yo tengo una canaima, pero a la hora de instalar me da miedo pues me dice que se eliminara 6 paquetes, e aqui todo lo que me dice la consola

apt-get install --install-recommends pipelight-multi
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
libswscale2 libcdio13 libva-x11-1 libproxy-tools libmtp9 libavutil53
libnettle4 libxcb-keysyms1 libbluray1 libresid-builder0c2a libtinfo5
qtcore4-l10n libzvbi0 libxcb-xv0 libtar0 cheese-common libxcb-xfixes0
libpostproc52 libcddb2 libtasn1-6 libavformat55 libdvbpsi6 libdvbpsi7
libmtp-common libvlc5 libdirac-decoder0 libqtcore4 libupnp6 libxcb-shape0
libaacs0 libzvbi-common libhogweed2 libcrystalhd3 libxcb-randr0
libxcb-composite0 libmtp-runtime libiso9660-7 libiso9660-8 libsidplay2
libqtgui4 libgnutls-deb0-28 libcheese-gtk18 libvdpau1 libavcodec55
liblua5.2-0 vlc-data libopus0 libfreerdp1 librtmp0 libaudio2 libvlccore7
libvcdinfo0 libebml0 libebml3 libmatroska0 libmatroska5
Utilice «apt-get autoremove» para eliminarlos.
Se instalarán los siguientes paquetes extras:
cabextract cpp-4.4 fontconfig-config fonts-freefont-ttf g++-4.4 gcc-4.4
gcc-4.4-base gcc-4.7-base libaacs0 libasound2 libasound2-plugins
libavcodec53 libavcodec55 libavformat55 libavutil51 libavutil53 libbluray1
libc-bin libc-dev-bin libc6 libc6-dev libcapi20-3 libcdio13 libcrystalhd3
libdirac-decoder0 libdvbpsi7 libdvdnav4 libebml3 libfontconfig1
libfontconfig1-dev libfreerdp1 libgcc1 libgd2-xpm libgettextpo0 libgfortran3
libgmp10 libgnutls-deb0-28 libgnutls26 libgomp1 libgpg-error0 libgphoto2-2
libgphoto2-l10n libgphoto2-port0 libhogweed2 libiso9660-8 libjbig0 libjpeg8
libjson-c2 liblcms2-2 libltdl7 liblua5.2-0 libmatroska5 libmp3lame0 libmpfr4
libmpg123-0 libmtp-common libmtp-runtime libmtp9 libnettle4 libodbc1
libopenal-data libopenal1 libopus0 liborc-0.4-0 libosmesa6 libp11-kit0
libpostproc52 libproxy-tools libpulse-mainloop-glib0 libpulse0 libqtcore4
libqtgui4 libquadmath0 libresid-builder0c2a librtmp0 libsamplerate0
libschroedinger-1.0-0 libsidplay2 libspeexdsp1 libssl1.0.0 libstdc++6
libstdc++6-4.4-dev libswscale2 libtag1-vanilla libtag1c2a libtar0 libtasn1-6
libtiff4 libtinfo5 libtxc-dxtn-s2tc0 libunistring0 libupnp6 libva-x11-1
libva1 libvdpau1 libvlc5 libvlccore7 libvpx1 libx11-6 libx11-dev libx264-123
libxcb-composite0 libxcb-keysyms1 libxcb-shape0 libxcb-xfixes0 libxvidcore4
libzvbi-common libzvbi0 locales make multiarch-support pkg-config
qtcore4-l10n ttf-freefont ttf-mscorefonts-installer unixodbc unzip vlc-data
wine-compholio wine-compholio-i386
Paquetes sugeridos:
gcc-4.4-locales g++-4.4-multilib gcc-4.4-doc libstdc++6-4.4-dbg
gcc-4.4-multilib libmudflap0-4.4-dev libgcc1-dbg libgomp1-dbg
libmudflap0-dbg libcloog-ppl0 libppl-c2 libppl7 libbluray-bdj glibc-doc
isdnutils-doc firmware-crystalhd libdvdcss2 xfreerdp libgd-tools gnutls-bin
gphoto2 gtkam liblcms2-utils libmyodbc odbc-postgresql tdsodbc unixodbc-bin
libroar-compat2 opus-tools pulseaudio libicu52 qt4-qtconfig
libstdc++6-4.4-doc nvidia-vdpau-driver vdpau-driver make-doc zip
Paquetes recomendados:
manpages-dev libc6-i686 libx11-doc fonts-liberation
Los siguientes paquetes se ELIMINARÁN:
libmtp8 libtar libupnp3 libvlccore4 vlc vlc-nox
Se instalarán los siguientes paquetes NUEVOS:
cabextract fonts-freefont-ttf gcc-4.7-base libaacs0 libasound2-plugins
libavcodec53 libavcodec55 libavformat55 libavutil51 libavutil53 libbluray1
libcapi20-3 libcdio13 libcrystalhd3 libdirac-decoder0 libdvbpsi7 libebml3
libfreerdp1 libgd2-xpm libgettextpo0 libgmp10 libgnutls-deb0-28
libgphoto2-l10n libhogweed2 libiso9660-8 libjbig0 libjpeg8 libjson-c2
liblcms2-2 liblua5.2-0 libmatroska5 libmp3lame0 libmpg123-0 libmtp-common
libmtp-runtime libmtp9 libnettle4 libodbc1 libopenal-data libopenal1
libopus0 libosmesa6 libp11-kit0 libpostproc52 libproxy-tools libquadmath0
libresid-builder0c2a librtmp0 libsamplerate0 libsidplay2 libspeexdsp1
libssl1.0.0 libswscale2 libtar0 libtasn1-6 libtinfo5 libtxc-dxtn-s2tc0
libunistring0 libupnp6 libva-x11-1 libva1 libvdpau1 libvlccore7 libvpx1
libx264-123 libxcb-composite0 libxcb-shape0 libxcb-xfixes0 libxvidcore4
libzvbi-common libzvbi0 multiarch-support pipelight-multi qtcore4-l10n
ttf-mscorefonts-installer unzip wine-compholio wine-compholio-i386
Se actualizarán los siguientes paquetes:
cpp-4.4 fontconfig-config g++-4.4 gcc-4.4 gcc-4.4-base libasound2 libc-bin
libc-dev-bin libc6 libc6-dev libdvdnav4 libfontconfig1 libfontconfig1-dev
libgcc1 libgfortran3 libgnutls26 libgomp1 libgpg-error0 libgphoto2-2
libgphoto2-port0 libltdl7 libmpfr4 liborc-0.4-0 libpulse-mainloop-glib0
libpulse0 libqtcore4 libqtgui4 libschroedinger-1.0-0 libstdc++6
libstdc++6-4.4-dev libtag1-vanilla libtag1c2a libtiff4 libvlc5 libx11-6
libx11-dev libxcb-key
DOA1
Los pasos de este post son solo para Ubuntu no los repitas en Canaima. En Canaima se puede instalar, pero tienes que seguir el enlace original donde está como se instala para debian. Tienes que fijarte en este Link
http://pipelight.net/cms/installation.html
Tienes que saber tu versión de Canaima sobre cual versión de debian está basada. Sí necesitas más te ayudo.
Juventudasd
utilizar algo que corre por wine? nahh mejor no juego, necesitas tener una bestia de pc para correr un simple jueguito, lo digo por que ya lo prove'
DOA1
@jorihuamancha
¿que PC tienes? que placa de video? Estás usando Ubuntu 14.4?
jorihuamancha
@DOA1 Acer Aspire 6415 4gb ram linux Mint 17.1
DOA1
@jorihuamancha
Yo lo hice en Ubuntu 14.4 pero en Linux Mint 17.1 tendría que funcionar. En Linux Mint 17 lo he probado y funciona.
atonidas
Hola muy buenas, voy ha hacer un videotutorial de como instalar unity3d de la forma en que lo has echo, ¿Te importa que lo suba?, te añadire como fuente por su puesto y te comentare en el video.
Un saludo
DOA1
Ningún problema, pongo el link a tú video también sí quieres. Sí usas otra distro como Debian mejor.
severussnape
Muy bueno me funciono genial en Ubuntu 14.4 solo en el Firefox, en Chrome no funciono lastima jejeje
te dejo +10
Si sabes como hacerlo en Chrome avísame .
Saludos
Androsangels
buenas noches.tu publicación es muy buena, si lo hubiera encontrado antes hubiera evitado leerme muchísimas paginas por todas partes. Pero hay algo que no he podido resolver solo y no encuentro por otro lado una respuesta. como hacer que funcione en opera 27.0, a pesar que e usado varios "user agent" me sigue dando el error del sistema operativo.
¿crees poder adarme?
DOA1
Los pasos que doy solo son para instalarlo sobre FireFox. no sé como se hace andar en otro navegador. Y para hacerlo andar en otra versión de Linux tienes que ir a la fuente original.
cesarperezh5
puedo hacer video?
DOA1 +1
ya hay un video en el Post, pero sí queres hacer otro adelante, y sí queres lo sube en este post. como quieras. Lo que está faltando es un tutorial para otras distribuciones.
FabricioSilveira
todo bien meanda ytodo perotengo bugs en los juegos tipo contract wars y otros.
gracias por enseñarme a jugar juegos de unity 3d en ubuntu pero quisiera que me ayuden con este problema
los bug son tipo que me faltan partes del juego tipo textos es lo mas principal y en algunos juegos no puedo escribir pero puedo jugar con las teclas.
bueno adios.
DOA1
Supongo que esos poblemas se resolveran con las actualizaciones.
marcosjavier07
Puede ser que te falten fuentes, te recomiendo copiar las de Windows y pegarlas en tu carpeta Home con el nombre de carpeta ".fonts", después te fijás en Libre Office u otra suite ofimática si te figuran.
FabricioSilveira
de que tipo de mi bgh o de el unity y el juego por mas que lo actualizen sigue igual ajajjajaj es un bug de mi laptop pero nose como lo solucionaria y si no tiene solucion lo dejo quieto,porque juego un juego llamado aottg y quiero crearme una cuenta en un rc mod pero me aparece las descripsiones de donde tenes que escribir en blanco no puedo escribir ni nada.
DOA1
Esto es así. No hay una versión de Unity Web Player para Linux, pero sí hay un emuladorde Windows en Linux llamado Wine. La solución en este post es hacer andar unity Web player dentro del emulador Wine, esto no siempre funciona perfecto porque es un emulador de Windows. las actualizaciones a las que me refiero son las del emulador Wine. y no depende de lo que hagas vos, dependen de los desarrolladores de Wine que hagan más compatible al emulador.
DOA1
Y el otro problema posible es el driver de la placa de video. ¿que placa de video tienes? ¿que versión de Linux estás usando?
Con el programa Hardinfo en display puedes decirme que versión de MESA tienes.
o comando glxinfo | grep OpenGL
FabricioSilveira
mira de aca http://www.ceibal.edu.uy/art%C3%ADculo/noticias/consultas/hardwarepositivo11cle2
la version de mi ubuntu es 12.04,me instale system information y me dice algo de table arp.
creo que es intel (R)Celeron ccreo que eso me fije en procesador o puede ser intel inside algo asi porque ese pegotin esta pegado en mi laptop nose mucho sobre eso aaajajaja.
la mesa es opengl renderer:mesa DRI Intel (R)Bay Trail
bueno espero que te sirva lo que te dije
FabricioSilveira
ah nose si la version delinux es algo de kernel:linux 3.13.0-49-generic (x86_64)
slujan28
no me aparece los plugins en el navegador yo ya los eh instalado pero por alguna extraña razón no me figuran en el firefox! HELP ME :C
DOA1
Que versión de linux usas? Estaba firefox cerrado cuando hiciste todo?
slujan28
@DOA1 ya lo solucione amigo, estaba abierto firefox pero ya esta! solo que se queda pegado siempre en el logo de unity
CRESTULY
sin querer me olvide de cerrar el navegador que va a pasar? ayuda rapido
Meficrow
427 mb de espacio extra? fuck.
DOA1 +1
Y, tiene que instalar Wine.
Meficrow
@DOA1 sip. habra que esperar a que lo saquen para ubuntu... si alguna vez lo hacen.
DOA1 +1
@Meficrow
La versión 5 aparentemente saldrá directamente para el navegador. pero la versión 4 usa Silverlaght para funcionar.
punx90s
A mi no se me cambia a windows u.u
DOA1
¿no entiendo que quisiste decir?


'
punx90s
@DOA1
LuwikDevoraklade
y que crees no me ha funcionado

Linux
FrancoR57
Hace 6 meses probe esto y me andubo en ubuntu 12.04 pero hoy no me deja instalarlo, es decir me instala los plugins menos unity3d en firefox, alguna solucion?¿
DOA1
FireFox, Chrome y todos los navegadores dejaron de darle soporte a este complemento tanto en Windows, Linux o Mac y también a Java, solo queda por un año más a Flash. Solo funcionará en una versión vieja de FireFox como la 50 para atrás. Los desarrolladores deberán deberán migrar de tecnología. Está todo abandonado.