epelpad

El post que buscas se encuentra eliminado, pero este también te puede interesar

Instalar nueva PPAPI de Flash Player en Ubuntu y derivados



Aclaracion: Estos metodos FUNCIONAN , si bien seguro alguien conoce alguno menos ortodoxo este es el metodo que yo he empleado despues de buscar y buscar por internet y dar por mi mismo con la solucion al no solucionar el problema con la info de internet. puede haber informacion redundante pero me limito a mostrarles lo que he hecho y se que asi FUNCIONARÁ! cabe recalcar que no se trata de usar la vieja version de flash player si no el NUEVO PPAPI.

Esto instala la PPAPI de Adobe Flash Player que parece ser no es lo mismo que el tradicional flash player al que ya NO se da mas continuidad, es MUY necesario tenerlo actualizado y usar versiones nuevas, ya que en paginas como MUNDIJUEGOS, por nombrar alguna.. sin esta actualizacion no puedes jugar, asi como a la hora de ver videos en paginas que usen Flash les irá muy bien.

Asi que valoren el esfuerzo y no critiquen destructivamente, ya que es un trabajo propio y no un copy paste


SOLUCION FLASH PLAYER NO FUNCIONA EN
CHROMIUM




Instalamos el Adobe flash plugin tradicional si no lo tenemos ya desde el centro de software o:
sudo apt-get install flashplugin-installer

luego tambien en consola copiamos:
sudo apt-get install pepperflashplugin-nonfree
sudo apt-get install browser-plugin-freshplayer-pepperflash


Con lo anterior deberia funcionar pero en mi caso no fue asi, aun debemos conseguir de Adobe el flash player PPAPI v22 adecuado a tu sistema x32 o x64 en:

https://get.adobe.com/es/flashplayer/

Descomprimimos y copiamos libpepflashplayer.so y manifest.json a la direccion que
veremos en el navegador del plugin flash antiguo, introduciendo "chrome://plugins"
en el navegador y abriendo detalles ahi lo veremos, en mi caso es:

/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so

copiamos y reiniciamos el navegador, ya tenemos la PPAPI de Flash player a v22!!!

Adicionalmente podemos editar como root un fichero para indicarle tambien la ruta del PPAPI:

/etc/chromium/default y lo dejamos asi:

CHROMIUM_FLAGS="--ppapi-flash-path=/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so"

Se que sobran pasos pero en uno de estos es cuando chromium funciona bien con la PPAPI ;D (no puedo volver a borrar todo y comprobar cual es el que funciona jeje asi que hagan todo paso a paso y funcionará.


SOLUCION FLASH PLAYER NO FUNCIONA EN
FIREFOX




Conseguimos de Adobe el flash player PPAPI v22 adecuado a tu sistema x32 o x64

https://get.adobe.com/es/flashplayer/

Descomprimimos y como superusuario, copiamos el archivo libflashplayer.so

al subdirectorio plugins del directorio de la instalación de Firefox.

Por ejemplo, si Firefox está instalado en /usr/lib/mozilla, utiliza el comando

sudo cp libflashplayer.so /usr/lib/mozilla/plugins (o como tu veas pero copialo ahi)

Listo!!!! en about:addons / pluggins veremos que aparece la nueva version!



Ya podemos usar la nueva version del PPAPI en Chromium y Firefox sin necesidad de Chrome!

4 comentarios - Instalar nueva PPAPI de Flash Player en Ubuntu y derivados

LittoIriarte +1
gracias por compartir, muy buena info, saludos
Trollacio_Banano
gracias a ti por pasar
elvoladormarito
ayudame por favor! es que cuando intento copiar los archivos a la ruta que especificaste no me deja
Trollacio_Banano +2
has de hacerlo como ROOT , es decir superusuario usando el comando sudo en consola, si no no te dejará... en consola abre tu gestor de archivos como root y entonces podras copiarlo sin problemas.

en mi caso que uso PCMAN FILE MANAGER pongo en consola:

sudo pcmanfm

y asi se abre una ventana del gestor de archivos como ROOT (superusuario)

si me dices que gestor de archivos usa te digo el comando que has de usar
adriano034 +1
Funciona con el Opera en xubuntu 14 ?
adriano034
@Trollacio_Banano me resulta dificil instalar esos tipos de archivos, me hacen mas facil los .deb
Trollacio_Banano
@adriano034 los .deb son paquetes comprimidos tambien que incluyen el script que autoejecuta la instalacion , un .tar carece de automatizacion normalmente, por eso cuesta mas pero el contenido lo tienes dentro igual
adriano034
@Trollacio_Banano Ahora no puedo instalar el ppapi en opera, me instala una version de 32 bits (la 11 de flash) teniendo la de 64 (porque recien instale el linux)