epelpad

Disponible Linux 4.18 mira los cambios

El día de ayer, Linus Torvalds anunció la nueva versión del kernel de Linux 4.18, que no solo viene a traer cosas nuevas, si no que esta vez se hizo una depuración del código, gracias que se ha eliminado casi 700.000 líneas código viejo y obsoleto.

Disponible Linux 4.18 mira los cambios

Dentro de sus nuevas características podemos encontrar:

  • Mejoras en el soporte para AMDGPU.
  • Inicio del trabajo open source para el hardware NVIDIA Volta GV100.
  • Más trabajo para mitigar Spectre en ARM.
  • Soporte para el cifrado del sistema Speck, ofreciendo una mejor compatibilidad con fscrypt, la biblioteca sobre la que se despliega el cifrado en disco.
  • Eliminación del sistema de archivos Lustre.
  • Soporte para el Steam Controller de Valve.
  • Los sistemas de archivo FUSE pueden ser montados por usuarios sin privilegios.
  • Se ha añadido soporte para Qualcomm Snapdragon 845, el chip usado por muchos dispositivos móviles de gama alta.

Como siempre todo el detalle en KernelNewbies y podemos descargarlo desde kernel.org

2 comentarios - Disponible Linux 4.18 mira los cambios

sam_aberto
Alguien me explica porque está esto en el kernel "Steam Controller de Valve"?
yuki94 +1
@sam_aberto lo poco que tengo entendido en el tema, creo que los drivers van en el kernel, ojo sólo los drivers de libre distribución, y por como yo lo veo, es lo que hace que las distribuciones de linux puedan funcionar en diferentes hardware. No sé, no lo veo tan malo, sé que el mejor control compatible en linux es el de xbox 360 (y capaz que haya otro y no esté enterado)
yuki94 +1
@sam_aberto Mirá, acabo de leer en otro lado esto

"A nivel periféricos quizás lo más llamativo sea el soporte del Steam Controller, por lo que supuestamente ni siquiera sería necesario instalar Steam para disponer de plena funcionalidad con este recomendable mando de juegos."

Parece que actualmente necesitarías tener instalado steam para poder usar el mando (tengo steam pero no el control )
https://www.muylinux.com/2018/08/13/linux-4-18/
abelnicolas1976 +1
Puede estar, pero se puede deshabilitar también (antes de compilarlo).